Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти ПЕРВОЕ наименьшее число по нескольким критериям - Страница 2 - Мир MS Excel

Старая форма входа
  • Страница 2 из 2
  • «
  • 1
  • 2
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти ПЕРВОЕ наименьшее число по нескольким критериям (Формулы/Formulas)
Найти ПЕРВОЕ наименьшее число по нескольким критериям
qwerty4869 Дата: Вторник, 12.01.2021, 19:47 | Сообщение № 21
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

=ЕСЛИОШИБКА(ПОИСКПОЗ(C2;J$2:J$18;0);"")

Не срабатывает... Речь о таблице, где значений много больше. В этом конкретном случае нашел строку, близкую к значению, но не именно ту, в которой находится указанное значение.
Тогда составьте пример по структуре максимально похожий на рабочий, пометьте строки номера которых надо найти, и выложите.


Смысл тот же самый. Разве что по датам, не 2 дня, а 2-3 года и значения иногда могут повторяться. Нужно, чтобы был именно номер строки найденного значения. Я сам пробовал ПОИСКПОЗ, но эта формула выдает неточные значения, причем иногда ошибается весьма значительно.
Эта формула - =АГРЕГАТ(15;6;СТРОКА($A$1:$A$20)/(($H$2:$H$18=A2)/($J$2:$J$18<B2)/($I$2:$I$18>=$E$1)/($I$2:$I$18<=$F$1));1) уже лучше, но есть небольшие расхождения.
 
Ответить
Сообщение
=ЕСЛИОШИБКА(ПОИСКПОЗ(C2;J$2:J$18;0);"")

Не срабатывает... Речь о таблице, где значений много больше. В этом конкретном случае нашел строку, близкую к значению, но не именно ту, в которой находится указанное значение.
Тогда составьте пример по структуре максимально похожий на рабочий, пометьте строки номера которых надо найти, и выложите.


Смысл тот же самый. Разве что по датам, не 2 дня, а 2-3 года и значения иногда могут повторяться. Нужно, чтобы был именно номер строки найденного значения. Я сам пробовал ПОИСКПОЗ, но эта формула выдает неточные значения, причем иногда ошибается весьма значительно.
Эта формула - =АГРЕГАТ(15;6;СТРОКА($A$1:$A$20)/(($H$2:$H$18=A2)/($J$2:$J$18<B2)/($I$2:$I$18>=$E$1)/($I$2:$I$18<=$F$1));1) уже лучше, но есть небольшие расхождения.

Автор - qwerty4869
Дата добавления - 12.01.2021 в 19:47
Egyptian Дата: Вторник, 12.01.2021, 19:50 | Сообщение № 22
Группа: Пользователи
Ранг: Участник
Сообщений: 70
Репутация: 37 ±
Замечаний: 0% ±

Excel 2013/2016
есть небольшие расхождения.

Так пометьте их и укажите нужные, так легче будет сориентироваться.
 
Ответить
Сообщение
есть небольшие расхождения.

Так пометьте их и укажите нужные, так легче будет сориентироваться.

Автор - Egyptian
Дата добавления - 12.01.2021 в 19:50
qwerty4869 Дата: Вторник, 12.01.2021, 19:58 | Сообщение № 23
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Например, используя формулу с функцией Агрегат вместо 806 ячейки идет показание 804.
Я бы выложил таблицу, но она очень объемная, и, когда начинаешь что-то там менять, много чего сбивается.
 
Ответить
СообщениеНапример, используя формулу с функцией Агрегат вместо 806 ячейки идет показание 804.
Я бы выложил таблицу, но она очень объемная, и, когда начинаешь что-то там менять, много чего сбивается.

Автор - qwerty4869
Дата добавления - 12.01.2021 в 19:58
Serge_007 Дата: Вторник, 12.01.2021, 20:05 | Сообщение № 24
Группа: Админы
Ранг: Местный житель
Сообщений: 13723
Репутация: 2302 ±
Замечаний: ±

Excel 2010
Я изменю на время ограничение на вес файла

Сколько он весит?


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЯ изменю на время ограничение на вес файла

Сколько он весит?

Автор - Serge_007
Дата добавления - 12.01.2021 в 20:05
qwerty4869 Дата: Вторник, 12.01.2021, 20:08 | Сообщение № 25
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Все, разобрался! С Функцией АГРЕГАТ работает. В формуле нужно указывать диапазон с первой ячейки, а не с той, которая начинается под заголовком. Поэтому у меня и получались все значения со сдвигом на 2. Всем огромное спасибо за то, что помогли! Премного благодарен!
 
Ответить
СообщениеВсе, разобрался! С Функцией АГРЕГАТ работает. В формуле нужно указывать диапазон с первой ячейки, а не с той, которая начинается под заголовком. Поэтому у меня и получались все значения со сдвигом на 2. Всем огромное спасибо за то, что помогли! Премного благодарен!

Автор - qwerty4869
Дата добавления - 12.01.2021 в 20:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти ПЕРВОЕ наименьшее число по нескольким критериям (Формулы/Formulas)
  • Страница 2 из 2
  • «
  • 1
  • 2
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!