Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Множественный поиск и подстановка значений - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Множественный поиск и подстановка значений (Формулы/Formulas)
Множественный поиск и подстановка значений
shevilmay Дата: Среда, 17.11.2021, 18:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Добрый вечер!
Зашла в тупик при использовании формул массива для множественного поиска и подстановки значений. Необходимо для столбца «Месяц ввода в эксплуатацию» из таблицы Source_Amortization (во вложении) вставить значения c привязкой к Версиям и ЦФО. (Версия и ЦФО - выпадающие списки). Пробовала использовать формулу:
Код
{=ИНДЕКС(Source_Amortization!$A$2:$H$145;ПОИСКПОЗ($C$4;Source_Amortization!$B$2:$B$145;0);;ПОИСКПОЗ($C$5;Source_Amortization!$С$2:$С$145;0))}

, но она выбирает только первый месяц. Я понимаю, что должно быть пересечение, но не могу понять как это реализовать. Подскажите пожалуйста, что нужно исправить?
К сообщению приложен файл: 5522280.jpg(52.5 Kb) · 3189957.jpg(47.6 Kb)
 
Ответить
СообщениеДобрый вечер!
Зашла в тупик при использовании формул массива для множественного поиска и подстановки значений. Необходимо для столбца «Месяц ввода в эксплуатацию» из таблицы Source_Amortization (во вложении) вставить значения c привязкой к Версиям и ЦФО. (Версия и ЦФО - выпадающие списки). Пробовала использовать формулу:
Код
{=ИНДЕКС(Source_Amortization!$A$2:$H$145;ПОИСКПОЗ($C$4;Source_Amortization!$B$2:$B$145;0);;ПОИСКПОЗ($C$5;Source_Amortization!$С$2:$С$145;0))}

, но она выбирает только первый месяц. Я понимаю, что должно быть пересечение, но не могу понять как это реализовать. Подскажите пожалуйста, что нужно исправить?

Автор - shevilmay
Дата добавления - 17.11.2021 в 18:12
jakim Дата: Среда, 17.11.2021, 18:34 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1125
Репутация: 298 ±
Замечаний: 0% ±

Excel 2010
Необходимо приложение в формате Excel, а не фотография.
 
Ответить
Сообщение
Необходимо приложение в формате Excel, а не фотография.

Автор - jakim
Дата добавления - 17.11.2021 в 18:34
shevilmay Дата: Четверг, 18.11.2021, 01:11 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

jakim, вот приложение
К сообщению приложен файл: 5049170.xlsm(36.4 Kb)
 
Ответить
Сообщениеjakim, вот приложение

Автор - shevilmay
Дата добавления - 18.11.2021 в 01:11
Egyptian Дата: Четверг, 18.11.2021, 01:50 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 425
Репутация: 140 ±
Замечаний: 0% ±

Excel 2013/2016
Необходимо для столбца «Месяц ввода в эксплуатацию» из таблицы Source_Amortization (во вложении) вставить значения c привязкой к Версиям и ЦФО.

Код
=INDEX(Source_Amortization!$G$2:$G$145;AGGREGATE(15;6;(ROW($F$2:$F$145)-ROW($F$2)+1)/((Source_Amortization!$B$2:$B$145=$C$4)/(Source_Amortization!$C$2:$C$145=$C$5)/(Source_Amortization!$D$2:$D$145=$C10)/(Source_Amortization!$E$2:$E$145=$D10)/(Source_Amortization!$F$2:$F$145=$E10));1))
К сообщению приложен файл: 3244934.xlsm(36.4 Kb)
 
Ответить
Сообщение
Необходимо для столбца «Месяц ввода в эксплуатацию» из таблицы Source_Amortization (во вложении) вставить значения c привязкой к Версиям и ЦФО.

Код
=INDEX(Source_Amortization!$G$2:$G$145;AGGREGATE(15;6;(ROW($F$2:$F$145)-ROW($F$2)+1)/((Source_Amortization!$B$2:$B$145=$C$4)/(Source_Amortization!$C$2:$C$145=$C$5)/(Source_Amortization!$D$2:$D$145=$C10)/(Source_Amortization!$E$2:$E$145=$D10)/(Source_Amortization!$F$2:$F$145=$E10));1))

Автор - Egyptian
Дата добавления - 18.11.2021 в 01:50
Светлый Дата: Четверг, 18.11.2021, 09:00 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1742
Репутация: 478 ±
Замечаний: 0% ±

Excel 2013, 2016
Ещё решение:
Код
=ИНДЕКС(Source_Amortization!$G$2:$G$145;ПОИСКПОЗ(5;МУМНОЖ(Ч(ВЫБОР({1;2;3;4;5};$C$4;$C$5;$C10;$D10;$E10)=Source_Amortization!$B$2:$F$145);{1:1:1:1:1});))
Код
=ВПР(5;ЕСЛИ({0;1};Source_Amortization!G$2:G$145;МУМНОЖ(Ч(ВЫБОР({1;2;3;4;5};C$4;C$5;C10;D10;E10)=Source_Amortization!B$2:F$145);{1:1:1:1:1}));2;)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Четверг, 18.11.2021, 09:42
 
Ответить
СообщениеЕщё решение:
Код
=ИНДЕКС(Source_Amortization!$G$2:$G$145;ПОИСКПОЗ(5;МУМНОЖ(Ч(ВЫБОР({1;2;3;4;5};$C$4;$C$5;$C10;$D10;$E10)=Source_Amortization!$B$2:$F$145);{1:1:1:1:1});))
Код
=ВПР(5;ЕСЛИ({0;1};Source_Amortization!G$2:G$145;МУМНОЖ(Ч(ВЫБОР({1;2;3;4;5};C$4;C$5;C10;D10;E10)=Source_Amortization!B$2:F$145);{1:1:1:1:1}));2;)

Автор - Светлый
Дата добавления - 18.11.2021 в 09:00
shevilmay Дата: Четверг, 18.11.2021, 09:52 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Egyptian, Светлый, Спасибо большое!
 
Ответить
СообщениеEgyptian, Светлый, Спасибо большое!

Автор - shevilmay
Дата добавления - 18.11.2021 в 09:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Множественный поиск и подстановка значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!