Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Удаление ячеек по дате - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Удаление ячеек по дате (Формулы/Formulas)
Удаление ячеек по дате
Adonis Дата: Четверг, 06.01.2022, 00:08 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый вечер. Есть ли возможность как то удалять не нужные ячейки по дате? Желательна формулами.
Пример: У нас есть сыгранные игры в футболе


Допустим игра состоялось 12.10.2021. Как удалить все игры после этой даты в колючая и её?

К сообщению приложен файл: 3848725.xlsx(135.4 Kb)
 
Ответить
СообщениеДобрый вечер. Есть ли возможность как то удалять не нужные ячейки по дате? Желательна формулами.
Пример: У нас есть сыгранные игры в футболе


Допустим игра состоялось 12.10.2021. Как удалить все игры после этой даты в колючая и её?


Автор - Adonis
Дата добавления - 06.01.2022 в 00:08
Egyptian Дата: Четверг, 06.01.2022, 01:17 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 386
Репутация: 132 ±
Замечаний: 0% ±

Excel 2013/2016
Adonis, Приветствую, "удалить" что-либо формулами не получится, они к этому не приучены. Можно отфильтровать, собственно ваш пример так и составлен.
Формулу в К2, затем протянуть вправо и вниз:
Код
=IFERROR(INDEX(A$2:A$39;AGGREGATE(15;6;ROW($A$1:$A$50)/(DATE(RIGHT($A$2:$A$39;4);MID($A$2:$A$39;4;2);LEFT($A$2:$A$39;2))<$N$1);ROW(A1)));"")

Формула может быть гораздо проще, если в столбце А заменить дату-как-текст на нормальную дату, как в ячейке N1.
Код
=IFERROR(INDEX(A$2:A$39;AGGREGATE(15;6;ROW($A$1:$A$50)/($A$2:$A$39<$N$1);ROW(A1)));"")

[p.s.]
Функция
Код
AGGREGATE()
появилась в Excel начиная с версии 2010. Надеюсь у вас версия не ниже, иначе придется переделывать.
К сообщению приложен файл: 5645800.xlsx(130.4 Kb)


Сообщение отредактировал Egyptian - Четверг, 06.01.2022, 01:24
 
Ответить
СообщениеAdonis, Приветствую, "удалить" что-либо формулами не получится, они к этому не приучены. Можно отфильтровать, собственно ваш пример так и составлен.
Формулу в К2, затем протянуть вправо и вниз:
Код
=IFERROR(INDEX(A$2:A$39;AGGREGATE(15;6;ROW($A$1:$A$50)/(DATE(RIGHT($A$2:$A$39;4);MID($A$2:$A$39;4;2);LEFT($A$2:$A$39;2))<$N$1);ROW(A1)));"")

Формула может быть гораздо проще, если в столбце А заменить дату-как-текст на нормальную дату, как в ячейке N1.
Код
=IFERROR(INDEX(A$2:A$39;AGGREGATE(15;6;ROW($A$1:$A$50)/($A$2:$A$39<$N$1);ROW(A1)));"")

[p.s.]
Функция
Код
AGGREGATE()
появилась в Excel начиная с версии 2010. Надеюсь у вас версия не ниже, иначе придется переделывать.

Автор - Egyptian
Дата добавления - 06.01.2022 в 01:17
Adonis Дата: Четверг, 06.01.2022, 17:53 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Приветствую, "удалить" что-либо формулами не получится, они к этому не приучены. Можно отфильтровать, собственно ваш пример так и составлен.
Формулу в К2, затем протянуть вправо и вниз:

=ЕСЛИОШИБКА(ИНДЕКС(A$2:A$39;АГРЕГАТ(15;6;СТРОКА($A$1:$A$50)/(ДАТА(ПРАВСИМВ($A$2:$A$39;4);ПСТР($A$2:$A$39;4;2);ЛЕВСИМВ($A$2:$A$39;2))<$N$1);СТРОКА(A1)));"")


Спасибо.
thumb
 
Ответить
Сообщение
Приветствую, "удалить" что-либо формулами не получится, они к этому не приучены. Можно отфильтровать, собственно ваш пример так и составлен.
Формулу в К2, затем протянуть вправо и вниз:

=ЕСЛИОШИБКА(ИНДЕКС(A$2:A$39;АГРЕГАТ(15;6;СТРОКА($A$1:$A$50)/(ДАТА(ПРАВСИМВ($A$2:$A$39;4);ПСТР($A$2:$A$39;4;2);ЛЕВСИМВ($A$2:$A$39;2))<$N$1);СТРОКА(A1)));"")


Спасибо.
thumb

Автор - Adonis
Дата добавления - 06.01.2022 в 17:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Удаление ячеек по дате (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!