Домашняя страница Undo Do Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Готовые решения

МЕНЮ САЙТА
  • 1
  • 2
  • 3

КАТЕГОРИИ РАЗДЕЛА

ОПРОСЫ
Какой версией Excel Вы пользуетесь?
Всего ответов: 35650
Главная » Готовые решения » Excel » Формулы

Как сделать визуально наглядной большую формулу?
15.01.2015, 20:50

В Excel довольно часто приходится сталкиваться с "большими" формулами - формулами со множеством вложенных функций или вычислений. Обычно, такие формулы вызывают тоску при взгляде на них - большое количество текста формулы и мало что понятно, особенно если формулу писал другой человек :)

В этой статье я расскажу вам о том,  каким образом можно сделать визуально наглядной, а следовательно более "читаемой" любую длинную формулу. Итак, для начала напишем довольно длинную формулу: =ЕСЛИ(ЗНАК(A1)=-1;0,75;ЕСЛИ(ЕПУСТО(A1);1;ЕСЛИ(И(A1>=0;A1<1);1,25;ЕСЛИ(И(A1>=1;A1<3);2;ЕСЛИ(И(A1>=3;A1<10);5;ЕСЛИ(И(A1>=10;A1<100);7;ЕСЛИ(И(A1>=100;A1<1500);10;ЕСЛИ(A1>=1500;100;1000))))))))

Что делает эта формула? Если начать разбираться по тексту формулы, то:

1. Если значение ячейки А1 отрицательно, то формула возвращает значение 0,75

2. Если значение ячейки А1 пустое, то формула возвращает значение 1

3. Если значение ячейки А1... А дальше пошли вложенные пары условий. Читать их, прямо скажем, не очень удобно. Поэтому мы воспользуемся простым переводом строк (Alt+Enter) непосредственно в строке формул.

Это исходная формула:

 

А тут мы применили перевод строки:

Можно, конечно, и дальше пойти:

но на мой взгляд, это уже перебор :)

Добавил: Serge_007 |
Просмотров: 1975 | Рейтинг: 5.0/3
Всего комментариев: 0
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!