Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Транспонирование горизонтальной таблицы в вертикальную - Страница 2 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 2 из 2
  • «
  • 1
  • 2
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Транспонирование горизонтальной таблицы в вертикальную (Формулы/Formulas)
Транспонирование горизонтальной таблицы в вертикальную
Ярик Дата: Среда, 15.05.2019, 20:13 | Сообщение № 21
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 116
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, спасибо Вам огромное, все работает отлично
извините за неточности в вопросе


753123
 
Ответить
Сообщение_Boroda_, спасибо Вам огромное, все работает отлично
извините за неточности в вопросе

Автор - Ярик
Дата добавления - 15.05.2019 в 20:13
Ярик Дата: Среда, 15.05.2019, 20:14 | Сообщение № 22
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 116
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Всем огромное спасибо кто помогал


753123
 
Ответить
СообщениеВсем огромное спасибо кто помогал

Автор - Ярик
Дата добавления - 15.05.2019 в 20:14
Nic70y Дата: Среда, 15.05.2019, 21:04 | Сообщение № 23
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5279
Репутация: 1144 ±
Замечаний: 0% ±

Excel 2013
по файлу от Александра (_Boroda_)
без использования кривых скобок,
не оптимизировал (т.е. использовал СЧЁТЕСЛИ)
B9
Код
=ИНДЕКС(Таблица4[#Все];1;1)
B10 и далее
Код
=ЕСЛИ(СЧЁТЕСЛИ(B$9:B9;B9)<СЧЁТЗ(ИНДЕКС(Таблица4;;ПОИСКПОЗ(B9;Таблица4[#Заголовки];)));B9;ИНДЕКС(Таблица4[#Заголовки];ПОИСКПОЗ(B9;Таблица4[#Заголовки];)+1))
C
Код
=ИНДЕКС(Таблица4;СЧЁТЕСЛИ(B$9:B9;B9);ПОИСКПОЗ(B9;Таблица4[#Заголовки];))
К сообщению приложен файл: 5092834.xlsb(10.9 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениепо файлу от Александра (_Boroda_)
без использования кривых скобок,
не оптимизировал (т.е. использовал СЧЁТЕСЛИ)
B9
Код
=ИНДЕКС(Таблица4[#Все];1;1)
B10 и далее
Код
=ЕСЛИ(СЧЁТЕСЛИ(B$9:B9;B9)<СЧЁТЗ(ИНДЕКС(Таблица4;;ПОИСКПОЗ(B9;Таблица4[#Заголовки];)));B9;ИНДЕКС(Таблица4[#Заголовки];ПОИСКПОЗ(B9;Таблица4[#Заголовки];)+1))
C
Код
=ИНДЕКС(Таблица4;СЧЁТЕСЛИ(B$9:B9;B9);ПОИСКПОЗ(B9;Таблица4[#Заголовки];))

Автор - Nic70y
Дата добавления - 15.05.2019 в 21:04
Ярик Дата: Пятница, 17.05.2019, 22:45 | Сообщение № 24
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 116
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Nic70y, большое Вам спасибо за помощь


753123
 
Ответить
СообщениеNic70y, большое Вам спасибо за помощь

Автор - Ярик
Дата добавления - 17.05.2019 в 22:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Транспонирование горизонтальной таблицы в вертикальную (Формулы/Formulas)
  • Страница 2 из 2
  • «
  • 1
  • 2
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!