Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Положительные и отрицательные числа в одном столбце - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Положительные и отрицательные числа в одном столбце (Формулы/Formulas)
Положительные и отрицательные числа в одном столбце
Pro_ex Дата: Вторник, 30.11.2021, 17:13 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте, помогите объединить две формулы в одну.

если В1 "Продажа" тогда число в ячейке А1 будет с минусом (-199)
Код
=ЕСЛИ(B1="Продажа";A1=$A$1)-A1


если В1 "Покупка", тогда число в ячейке А1 будет с плюсом (199)
Код
=ЕСЛИ(B1="Покупка";A1=$A$1)+A1


Как объединить две формулы, чтобы все числа записывались в один столбец? И возможно формулу сделать короче, немного проще.

Попробовал сделать, не хватает +А1, не получается дописать, все значения с минусом.
Код
=ЕСЛИ(B1="Продажа";A1=$A$1;ЕСЛИ(B1="Покупка";A1=$A$1))-A1


Пример в файле, спасибо.
К сообщению приложен файл: __.xlsx(9.8 Kb)


Сообщение отредактировал Pro_ex - Вторник, 30.11.2021, 17:24
 
Ответить
СообщениеЗдравствуйте, помогите объединить две формулы в одну.

если В1 "Продажа" тогда число в ячейке А1 будет с минусом (-199)
Код
=ЕСЛИ(B1="Продажа";A1=$A$1)-A1


если В1 "Покупка", тогда число в ячейке А1 будет с плюсом (199)
Код
=ЕСЛИ(B1="Покупка";A1=$A$1)+A1


Как объединить две формулы, чтобы все числа записывались в один столбец? И возможно формулу сделать короче, немного проще.

Попробовал сделать, не хватает +А1, не получается дописать, все значения с минусом.
Код
=ЕСЛИ(B1="Продажа";A1=$A$1;ЕСЛИ(B1="Покупка";A1=$A$1))-A1


Пример в файле, спасибо.

Автор - Pro_ex
Дата добавления - 30.11.2021 в 17:13
Serge_007 Дата: Вторник, 30.11.2021, 17:26 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15568
Репутация: 2559 ±
Замечаний: ±

Excel 2016
Здравствуйте
Код
=((B1="Покупка")-(B1="Продажа"))*A1


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте
Код
=((B1="Покупка")-(B1="Продажа"))*A1

Автор - Serge_007
Дата добавления - 30.11.2021 в 17:26
Pro_ex Дата: Вторник, 30.11.2021, 17:31 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 44
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте


Добрый день, Serge_007 благодарю!
 
Ответить
Сообщение
Здравствуйте


Добрый день, Serge_007 благодарю!

Автор - Pro_ex
Дата добавления - 30.11.2021 в 17:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Положительные и отрицательные числа в одном столбце (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!