Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР по нескольким столбцам - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР по нескольким столбцам (Формулы/Formulas)
ВПР по нескольким столбцам
miha_ Дата: Суббота, 02.04.2022, 21:19 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 84
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Добрый вечер, уважаемые форумчане.
Подскажите, пожалуйста как можно упростить формулу?
Код
=ЕСЛИОШИБКА(ВПР(Q2;ВЫБОР({1;2};B3:B31;A3:A31);2;);
ЕСЛИОШИБКА(ВПР(Q2;ВЫБОР({1;2};D3:D31;C3:C31);2;);
ЕСЛИОШИБКА(ВПР(Q2;ВЫБОР({1;2};F3:F31;E3:E31);2;);
ЕСЛИОШИБКА(ВПР(Q2;ВЫБОР({1;2};H3:H31;G3:G31);2;);"ошибка"))))

Она решает простую задачу, впр с поиском по нескольким столбцам. Если столбцов много, формула становится весьма громоздкой.
К сообщению приложен файл: 3634050.xlsx(10.4 Kb)


Сообщение отредактировал miha_ - Суббота, 02.04.2022, 21:19
 
Ответить
СообщениеДобрый вечер, уважаемые форумчане.
Подскажите, пожалуйста как можно упростить формулу?
Код
=ЕСЛИОШИБКА(ВПР(Q2;ВЫБОР({1;2};B3:B31;A3:A31);2;);
ЕСЛИОШИБКА(ВПР(Q2;ВЫБОР({1;2};D3:D31;C3:C31);2;);
ЕСЛИОШИБКА(ВПР(Q2;ВЫБОР({1;2};F3:F31;E3:E31);2;);
ЕСЛИОШИБКА(ВПР(Q2;ВЫБОР({1;2};H3:H31;G3:G31);2;);"ошибка"))))

Она решает простую задачу, впр с поиском по нескольким столбцам. Если столбцов много, формула становится весьма громоздкой.

Автор - miha_
Дата добавления - 02.04.2022 в 21:19
gling Дата: Суббота, 02.04.2022, 22:47 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2389
Репутация: 625 ±
Замечаний: 0% ±

2010
Здравствуйте.
пробуйте такую формулу
Код
=ИНДЕКС(A1:G31;СУММПРОИЗВ((A1:G31=Q2)*СТРОКА(A1:G31));СУММПРОИЗВ((A1:G31=Q2)*СТОЛБЕЦ(A1:G31))-1)
Но это если только номер заявки не будет повторяться в таблице.


ЯД-41001506838083

Сообщение отредактировал gling - Суббота, 02.04.2022, 22:50
 
Ответить
СообщениеЗдравствуйте.
пробуйте такую формулу
Код
=ИНДЕКС(A1:G31;СУММПРОИЗВ((A1:G31=Q2)*СТРОКА(A1:G31));СУММПРОИЗВ((A1:G31=Q2)*СТОЛБЕЦ(A1:G31))-1)
Но это если только номер заявки не будет повторяться в таблице.

Автор - gling
Дата добавления - 02.04.2022 в 22:47
miha_ Дата: Воскресенье, 03.04.2022, 19:24 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 84
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
gling, Спасибо. Оригинальный способ.
ПОдскажите, пожалуйста, а если исходное значение будет встречаться несколько раз?
 
Ответить
Сообщениеgling, Спасибо. Оригинальный способ.
ПОдскажите, пожалуйста, а если исходное значение будет встречаться несколько раз?

Автор - miha_
Дата добавления - 03.04.2022 в 19:24
gling Дата: Воскресенье, 03.04.2022, 20:26 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2389
Репутация: 625 ±
Замечаний: 0% ±

2010
исходное значение
это номер заявки?
Если номер заявки повторяется, тогда нужно искать другое решение.


ЯД-41001506838083
 
Ответить
Сообщение
исходное значение
это номер заявки?
Если номер заявки повторяется, тогда нужно искать другое решение.

Автор - gling
Дата добавления - 03.04.2022 в 20:26
Egyptian Дата: Воскресенье, 03.04.2022, 22:51 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 425
Репутация: 140 ±
Замечаний: 0% ±

Excel 2013/2016
Для повторяющегося номера заявки можно попробовать так:
Код
=IFERROR(INDEX($A$1:$G$31;AGGREGATE(15;6;ROW($A$1:$A$100)/($A$1:$G$31=$Q$2);1);AGGREGATE(15;6;COLUMN($A$1:$R$1)-1/($A$1:$G$31=$Q$2);ROW(A1)));"")
К сообщению приложен файл: 8632545.xlsx(10.1 Kb)
 
Ответить
СообщениеДля повторяющегося номера заявки можно попробовать так:
Код
=IFERROR(INDEX($A$1:$G$31;AGGREGATE(15;6;ROW($A$1:$A$100)/($A$1:$G$31=$Q$2);1);AGGREGATE(15;6;COLUMN($A$1:$R$1)-1/($A$1:$G$31=$Q$2);ROW(A1)));"")

Автор - Egyptian
Дата добавления - 03.04.2022 в 22:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР по нескольким столбцам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!