Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как растянуть формулу на все листы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как растянуть формулу на все листы (Формулы/Formulas)
Как растянуть формулу на все листы
alexfin Дата: Среда, 28.09.2022, 21:58 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте. Помогите бестолковому.
на листе СВОД данные в диапазоне B1:B80
есть восемьдесят листов с названием 1,2,3 и т.д.
нужно вставить формулу на все листы что бы на первом в ячейку а1 бралось значение B1 свода на втором листе с ячейки B2 и тд
 
Ответить
СообщениеЗдравствуйте. Помогите бестолковому.
на листе СВОД данные в диапазоне B1:B80
есть восемьдесят листов с названием 1,2,3 и т.д.
нужно вставить формулу на все листы что бы на первом в ячейку а1 бралось значение B1 свода на втором листе с ячейки B2 и тд

Автор - alexfin
Дата добавления - 28.09.2022 в 21:58
Serge_007 Дата: Среда, 28.09.2022, 22:50 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15568
Репутация: 2559 ±
Замечаний: ±

Excel 2016
Код
=ДВССЫЛ(ПСТР(ЯЧЕЙКА("имяфайла";A1);ПОИСК("]";ЯЧЕЙКА("имяфайла";A1))+1;99)+1&"!B1")


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Код
=ДВССЫЛ(ПСТР(ЯЧЕЙКА("имяфайла";A1);ПОИСК("]";ЯЧЕЙКА("имяфайла";A1))+1;99)+1&"!B1")

Автор - Serge_007
Дата добавления - 28.09.2022 в 22:50
bigorq Дата: Среда, 28.09.2022, 22:51 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 140
Репутация: 25 ±
Замечаний: 0% ±

Нет
Здраствуйте
В LibreOffice выделяю все листы и в А1 всавляю формулу
Код
=INDEX($свод.$A$1:$A$6;SHEET())

в Excel не уверен, что есть Sheet()
 
Ответить
СообщениеЗдраствуйте
В LibreOffice выделяю все листы и в А1 всавляю формулу
Код
=INDEX($свод.$A$1:$A$6;SHEET())

в Excel не уверен, что есть Sheet()

Автор - bigorq
Дата добавления - 28.09.2022 в 22:51
Serge_007 Дата: Среда, 28.09.2022, 22:54 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 15568
Репутация: 2559 ±
Замечаний: ±

Excel 2016
в Excel не уверен, что есть Sheet()
Появилась в релизе Офиса 2016


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
в Excel не уверен, что есть Sheet()
Появилась в релизе Офиса 2016

Автор - Serge_007
Дата добавления - 28.09.2022 в 22:54
Gustav Дата: Среда, 28.09.2022, 23:03 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2211
Репутация: 893 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Можно еще такой вариант - так сказать, с прикосновением к программированию:
1. По Alt+F11 идём в Редактор Visual Basic
2. Там Ctrl+G для перехода в Окно отладки (Immediate)
3. Вставляем в это окно такую строку кода (копируем отсюда):
[vba]
Код
For i = 1 To 80: Sheets(CStr(i)).[A1] = "=СВОД!B" & i: Next
[/vba]
4. Находясь на этой строке, жмем Enter.


МОИ: Ник, Tip box: 41001663842605
 
Ответить
СообщениеМожно еще такой вариант - так сказать, с прикосновением к программированию:
1. По Alt+F11 идём в Редактор Visual Basic
2. Там Ctrl+G для перехода в Окно отладки (Immediate)
3. Вставляем в это окно такую строку кода (копируем отсюда):
[vba]
Код
For i = 1 To 80: Sheets(CStr(i)).[A1] = "=СВОД!B" & i: Next
[/vba]
4. Находясь на этой строке, жмем Enter.

Автор - Gustav
Дата добавления - 28.09.2022 в 23:03
_Boroda_ Дата: Четверг, 29.09.2022, 09:33 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16496
Репутация: 6420 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Топаем на ярлык листа 1. Держа Шифт, топаем на ярлык листа 80. В ячейку А1 вводим формулу
Код
=ИНДЕКС(СВОД!B:B;ПРАВБ(ПОДСТАВИТЬ(ЯЧЕЙКА("filename";A1);"]";" ");2))

Жмем на лист СВОД, чтобы разгруппировать листы
К сообщению приложен файл: _1.xlsm(10.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТопаем на ярлык листа 1. Держа Шифт, топаем на ярлык листа 80. В ячейку А1 вводим формулу
Код
=ИНДЕКС(СВОД!B:B;ПРАВБ(ПОДСТАВИТЬ(ЯЧЕЙКА("filename";A1);"]";" ");2))

Жмем на лист СВОД, чтобы разгруппировать листы

Автор - _Boroda_
Дата добавления - 29.09.2022 в 09:33
alexfin Дата: Четверг, 29.09.2022, 11:06 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

спасибо огромное, все получилось
 
Ответить
Сообщениеспасибо огромное, все получилось

Автор - alexfin
Дата добавления - 29.09.2022 в 11:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как растянуть формулу на все листы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!