Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти определенное значение из нескольких столбцов - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти определенное значение из нескольких столбцов (Формулы/Formulas)
Найти определенное значение из нескольких столбцов
fantasyy8 Дата: Пятница, 13.10.2023, 16:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Привет
Подскажите, как можно найти значение. Например таблица А1:V23
Столбец А это цена, остальное это наименовани товара.
И при этом исходные данные в одной таблице, а результат необходимо внести в другую таблицу
К сообщению приложен файл: 8310768.jpg (50.1 Kb) · 7564423.jpg (4.9 Kb)
 
Ответить
СообщениеПривет
Подскажите, как можно найти значение. Например таблица А1:V23
Столбец А это цена, остальное это наименовани товара.
И при этом исходные данные в одной таблице, а результат необходимо внести в другую таблицу

Автор - fantasyy8
Дата добавления - 13.10.2023 в 16:00
bigor Дата: Пятница, 13.10.2023, 16:24 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1016
Репутация: 195 ±
Замечаний: 0% ±

нет
Привет
Код
=SUMPRODUCT()


Сообщение отредактировал bigor - Пятница, 13.10.2023, 16:25
 
Ответить
СообщениеПривет
Код
=SUMPRODUCT()

Автор - bigor
Дата добавления - 13.10.2023 в 16:24
fantasyy8 Дата: Пятница, 13.10.2023, 17:30 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

=СУММПРОИЗВ()


Что? В новую таблицу надо подтянуть цену уже из готовой таблице. Известно номер товара. Данных больше чем представленно в примере.
 
Ответить
Сообщение
=СУММПРОИЗВ()


Что? В новую таблицу надо подтянуть цену уже из готовой таблице. Известно номер товара. Данных больше чем представленно в примере.

Автор - fantasyy8
Дата добавления - 13.10.2023 в 17:30
bigorq Дата: Пятница, 13.10.2023, 20:57 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 197
Репутация: 47 ±
Замечаний: 0% ±

Нет
Пример ещё мы не видели
 
Ответить
СообщениеПример ещё мы не видели

Автор - bigorq
Дата добавления - 13.10.2023 в 20:57
DrMini Дата: Суббота, 14.10.2023, 06:27 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Что? В новую таблицу надо подтянуть цену уже из готовой таблице

Судя по вашему объяснению я вижу вот так:
Код
=ИНДЕКС(Лист1!$A$2:$A$5;ПОИСКПОЗ(B1;Лист1!$B$2:$B$5))
К сообщению приложен файл: Hu.xlsx (10.5 Kb)
 
Ответить
Сообщение
Что? В новую таблицу надо подтянуть цену уже из готовой таблице

Судя по вашему объяснению я вижу вот так:
Код
=ИНДЕКС(Лист1!$A$2:$A$5;ПОИСКПОЗ(B1;Лист1!$B$2:$B$5))

Автор - DrMini
Дата добавления - 14.10.2023 в 06:27
DrMini Дата: Суббота, 14.10.2023, 09:28 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Ну, или можно ещё вот так попробовать (вдруг угадал).
Выбираете на Лист2 в ячейке B1 наименование товара.
К сообщению приложен файл: hu_kopija.xlsx (11.5 Kb)
 
Ответить
СообщениеНу, или можно ещё вот так попробовать (вдруг угадал).
Выбираете на Лист2 в ячейке B1 наименование товара.

Автор - DrMini
Дата добавления - 14.10.2023 в 09:28
fantasyy8 Дата: Суббота, 14.10.2023, 23:47 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

=ИНДЕКС(Лист1!$A$2:$A$5;ПОИСКПОЗ(B1;Лист1!$B$2:$B$5))


Спасибо. Попробовал, но что-то не вышло.
Попытка в прикрепленном файле
К сообщению приложен файл: primer.xlsx (11.9 Kb)
 
Ответить
Сообщение
=ИНДЕКС(Лист1!$A$2:$A$5;ПОИСКПОЗ(B1;Лист1!$B$2:$B$5))


Спасибо. Попробовал, но что-то не вышло.
Попытка в прикрепленном файле

Автор - fantasyy8
Дата добавления - 14.10.2023 в 23:47
DrMini Дата: Воскресенье, 15.10.2023, 08:44 | Сообщение № 8
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
но что-то не вышло

Во первых у вас во всех ячейках (кроме столбцов A и B) впереди данных стоит пробел.
Во вторых теперь понял, что вам нужно брать любое значение в массиве Лист2 B2:F23 и при нахождении нужных данных брать цену из пересечения строки в диапазоне Лист2 A2:A23.
Я "копал" в другую сторону.
На это знаний маловато.
 
Ответить
Сообщение
но что-то не вышло

Во первых у вас во всех ячейках (кроме столбцов A и B) впереди данных стоит пробел.
Во вторых теперь понял, что вам нужно брать любое значение в массиве Лист2 B2:F23 и при нахождении нужных данных брать цену из пересечения строки в диапазоне Лист2 A2:A23.
Я "копал" в другую сторону.
На это знаний маловато.

Автор - DrMini
Дата добавления - 15.10.2023 в 08:44
bigorq Дата: Воскресенье, 15.10.2023, 09:18 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 197
Репутация: 47 ±
Замечаний: 0% ±

Нет
Повторю, СУММПРОИЗВ() самое простое решение, если артикулы уникальные (с телефона не рассмотрю)
 
Ответить
СообщениеПовторю, СУММПРОИЗВ() самое простое решение, если артикулы уникальные (с телефона не рассмотрю)

Автор - bigorq
Дата добавления - 15.10.2023 в 09:18
DrMini Дата: Воскресенье, 15.10.2023, 10:12 | Сообщение № 10
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Покопался в Internet'e нашёл вот такое решение:
Код
=ЕСЛИОШИБКА(ДВССЫЛ(АДРЕС(МИН(ЕСЛИ(СЖПРОБЕЛЫ(A1:F23)=H2;СТРОКА(A1:F23)));СТОЛБЕЦ(A1)));"нет")
К сообщению приложен файл: primer_0.xlsx (14.0 Kb)
 
Ответить
СообщениеПокопался в Internet'e нашёл вот такое решение:
Код
=ЕСЛИОШИБКА(ДВССЫЛ(АДРЕС(МИН(ЕСЛИ(СЖПРОБЕЛЫ(A1:F23)=H2;СТРОКА(A1:F23)));СТОЛБЕЦ(A1)));"нет")

Автор - DrMini
Дата добавления - 15.10.2023 в 10:12
bigorq Дата: Воскресенье, 15.10.2023, 11:40 | Сообщение № 11
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 197
Репутация: 47 ±
Замечаний: 0% ±

Нет
Код
=(СУММПРОИЗВ((СЖПРОБЕЛЫ(B$2:F$23) =H2)*(A$2:A$23)))
, массивная
 
Ответить
Сообщение
Код
=(СУММПРОИЗВ((СЖПРОБЕЛЫ(B$2:F$23) =H2)*(A$2:A$23)))
, массивная

Автор - bigorq
Дата добавления - 15.10.2023 в 11:40
DrMini Дата: Воскресенье, 15.10.2023, 11:51 | Сообщение № 12
Группа: Проверенные
Ранг: Старожил
Сообщений: 1566
Репутация: 179 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Так?
Только, только разобрался но... припозднился.
Код
=СУММПРОИЗВ((СЖПРОБЕЛЫ(Лист2!$B$2:$F$23)=A2)*(Лист2!$A$2:$A$23))

[offtop]на пару скобок короче.[/offtop]
К сообщению приложен файл: primerFinal.xlsx (13.1 Kb)


Сообщение отредактировал DrMini - Воскресенье, 15.10.2023, 11:52
 
Ответить
СообщениеТак?
Только, только разобрался но... припозднился.
Код
=СУММПРОИЗВ((СЖПРОБЕЛЫ(Лист2!$B$2:$F$23)=A2)*(Лист2!$A$2:$A$23))

[offtop]на пару скобок короче.[/offtop]

Автор - DrMini
Дата добавления - 15.10.2023 в 11:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти определенное значение из нескольких столбцов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!