Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсвечивание строк, сумма ячейки которой подсчитана в итоге - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсвечивание строк, сумма ячейки которой подсчитана в итоге (Формулы/Formulas)
Подсвечивание строк, сумма ячейки которой подсчитана в итоге
nemoalexei Дата: Четверг, 30.11.2023, 00:34 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

последняя
Подсвечивание строк, сумма ячейки которой подсчитана в итоге внизу или в рядом в итоговой таблице, к примеру, есть таблица, в ней 20 строк, в каждой слева описание расхода, справа в ячейке сумма, если мы эту ячейку добавляем в суммирование, чтобы не пропустить и не повторить её позже, она подсвечивается цветом автоматически. Это надо, когда суммирование идёт вручную и не подряд, а выборочно.
К сообщению приложен файл: primer_reestr_platezhej.xlsx (11.6 Kb)


Алексей С.

Сообщение отредактировал nemoalexei - Четверг, 30.11.2023, 00:35
 
Ответить
СообщениеПодсвечивание строк, сумма ячейки которой подсчитана в итоге внизу или в рядом в итоговой таблице, к примеру, есть таблица, в ней 20 строк, в каждой слева описание расхода, справа в ячейке сумма, если мы эту ячейку добавляем в суммирование, чтобы не пропустить и не повторить её позже, она подсвечивается цветом автоматически. Это надо, когда суммирование идёт вручную и не подряд, а выборочно.

Автор - nemoalexei
Дата добавления - 30.11.2023 в 00:34
elovkov Дата: Четверг, 30.11.2023, 08:40 | Сообщение № 2
Группа: Друзья
Ранг: Обитатель
Сообщений: 368
Репутация: 50 ±
Замечаний: 0% ±

Excel 2013
С допстолбцами и УФ
Зеленым подсвечиваются ячейки, учтенные в суммировании
НГаверное все это можно вкрутить в форматирование, через имена и т.п., но лень) направление примерно задал куда рыть можно
К сообщению приложен файл: 9830697.xlsx (13.1 Kb)


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица

Сообщение отредактировал elovkov - Четверг, 30.11.2023, 08:43
 
Ответить
СообщениеС допстолбцами и УФ
Зеленым подсвечиваются ячейки, учтенные в суммировании
НГаверное все это можно вкрутить в форматирование, через имена и т.п., но лень) направление примерно задал куда рыть можно

Автор - elovkov
Дата добавления - 30.11.2023 в 08:40
nemoalexei Дата: Четверг, 30.11.2023, 17:49 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

последняя
elovkov, Добрый вечер. Спасибо большое, хорошее решение. Формулы можно скрыть на листе и будет чисто. Но не могу понять, почему это не работает на 2 и 3 ячейке. Как где их не удаляю их в суммах, выделение цветом остаётся.


Алексей С.
 
Ответить
Сообщениеelovkov, Добрый вечер. Спасибо большое, хорошее решение. Формулы можно скрыть на листе и будет чисто. Но не могу понять, почему это не работает на 2 и 3 ячейке. Как где их не удаляю их в суммах, выделение цветом остаётся.

Автор - nemoalexei
Дата добавления - 30.11.2023 в 17:49
nemoalexei Дата: Четверг, 30.11.2023, 23:21 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

последняя
elovkov, Отремонтировал, просто добавил сверху две пустые строчки, заработало без ошибок, так смотрел, смотрел, по формулам, вроде всё вроде правильно, так и не понял, почему их цепляет!)


Алексей С.
 
Ответить
Сообщениеelovkov, Отремонтировал, просто добавил сверху две пустые строчки, заработало без ошибок, так смотрел, смотрел, по формулам, вроде всё вроде правильно, так и не понял, почему их цепляет!)

Автор - nemoalexei
Дата добавления - 30.11.2023 в 23:21
elovkov Дата: Пятница, 01.12.2023, 12:48 | Сообщение № 5
Группа: Друзья
Ранг: Обитатель
Сообщений: 368
Репутация: 50 ±
Замечаний: 0% ±

Excel 2013
Наверное это потому что есть еще 20 и 30, моя формула находит С20 и думает что это то же самое что С2, а 40 и 50 нету. Так что если список будет расширяться - придется добавлять еще строки))) В общем так себе решение, колхозное, но работает)


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица

Сообщение отредактировал elovkov - Пятница, 01.12.2023, 12:49
 
Ответить
СообщениеНаверное это потому что есть еще 20 и 30, моя формула находит С20 и думает что это то же самое что С2, а 40 и 50 нету. Так что если список будет расширяться - придется добавлять еще строки))) В общем так себе решение, колхозное, но работает)

Автор - elovkov
Дата добавления - 01.12.2023 в 12:48
Nic70y Дата: Пятница, 01.12.2023, 12:55 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
2013 у меня давно "накрылся" проверить не могу
Код
=ЕСЛИОШИБКА(ПОДСТАВИТЬ(Ф.ТЕКСТ(H2);"=";"+")&"+";"")
Код
=ИНДЕКС($I$2:$I$13;ПОИСКПОЗ("*+"&АДРЕС(СТРОКА(C2);3;4;1)&"+*";$I$2:$I$13;0))


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Пятница, 01.12.2023, 12:58
 
Ответить
Сообщение2013 у меня давно "накрылся" проверить не могу
Код
=ЕСЛИОШИБКА(ПОДСТАВИТЬ(Ф.ТЕКСТ(H2);"=";"+")&"+";"")
Код
=ИНДЕКС($I$2:$I$13;ПОИСКПОЗ("*+"&АДРЕС(СТРОКА(C2);3;4;1)&"+*";$I$2:$I$13;0))

Автор - Nic70y
Дата добавления - 01.12.2023 в 12:55
elovkov Дата: Пятница, 01.12.2023, 13:15 | Сообщение № 7
Группа: Друзья
Ранг: Обитатель
Сообщений: 368
Репутация: 50 ±
Замечаний: 0% ±

Excel 2013
проверить не могу

работает)

Формулы можно скрыть на листе и будет чисто


А можно вообще на другой лист и скрыть лист, вторую формулу протянуть до 1000, в УФ тоже диапазон до 1000, чтобы уже добавлялось не задумываясь


Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица

Сообщение отредактировал elovkov - Пятница, 01.12.2023, 13:19
 
Ответить
Сообщение
проверить не могу

работает)

Формулы можно скрыть на листе и будет чисто


А можно вообще на другой лист и скрыть лист, вторую формулу протянуть до 1000, в УФ тоже диапазон до 1000, чтобы уже добавлялось не задумываясь

Автор - elovkov
Дата добавления - 01.12.2023 в 13:15
nemoalexei Дата: Пятница, 01.12.2023, 15:39 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

последняя
Nic70y, Почему 2013, вроде последний. Вот файл.
К сообщению приложен файл: reestr_platezhej_po_nalogam_20.xlsx (12.9 Kb)


Алексей С.
 
Ответить
СообщениеNic70y, Почему 2013, вроде последний. Вот файл.

Автор - nemoalexei
Дата добавления - 01.12.2023 в 15:39
Nic70y Дата: Пятница, 01.12.2023, 15:48 | Сообщение № 9
Группа: Друзья
Ранг: Экселист
Сообщений: 8759
Репутация: 2273 ±
Замечаний: 0% ±

Excel 2010
Почему 2013
у меня когда-то был Excel 2013, сейчас 2010, по этому свои формулы проверить не могу,
если у Вас в месяцах формулы всегда типа +++, тогда
Цитата Nic70y, [url=http://www.excelworld.ru/forum/2-52717-344164-16-1701424512 ()
=ЕСЛИОШИБКА(ПОДСТАВИТЬ(Ф.ТЕКСТ(H2);"=";"+")&"+";"")

=ИНДЕКС($I$2:$I$13;ПОИСКПОЗ("*+"&АДРЕС(СТРОКА(C2);3;4;1)&"+*";$I$2:$I$13;0))
даст более точный результат


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Пятница, 01.12.2023, 15:54
 
Ответить
Сообщение
Почему 2013
у меня когда-то был Excel 2013, сейчас 2010, по этому свои формулы проверить не могу,
если у Вас в месяцах формулы всегда типа +++, тогда
Цитата Nic70y, [url=http://www.excelworld.ru/forum/2-52717-344164-16-1701424512 ()
=ЕСЛИОШИБКА(ПОДСТАВИТЬ(Ф.ТЕКСТ(H2);"=";"+")&"+";"")

=ИНДЕКС($I$2:$I$13;ПОИСКПОЗ("*+"&АДРЕС(СТРОКА(C2);3;4;1)&"+*";$I$2:$I$13;0))
даст более точный результат

Автор - Nic70y
Дата добавления - 01.12.2023 в 15:48
nemoalexei Дата: Пятница, 01.12.2023, 18:28 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

последняя
Nic70y, Да, спасибо, Ваши формулы работают независимо от начала, можно удалить пустые первые две строки и они включаются в анализ, счет, красит или не красит по факту суммирования. Спасибо большое за корректировки, советы.


Алексей С.
 
Ответить
СообщениеNic70y, Да, спасибо, Ваши формулы работают независимо от начала, можно удалить пустые первые две строки и они включаются в анализ, счет, красит или не красит по факту суммирования. Спасибо большое за корректировки, советы.

Автор - nemoalexei
Дата добавления - 01.12.2023 в 18:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсвечивание строк, сумма ячейки которой подсчитана в итоге (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!