Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет товаров всего и по значению из выпадающего списка - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет товаров всего и по значению из выпадающего списка (Формулы/Formulas)
Подсчет товаров всего и по значению из выпадающего списка
adidas77 Дата: Воскресенье, 28.01.2024, 11:32 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

2019
Доброго времени суток!!! Нужна Ваша помощь. На складах имеются одинаковые товары. Необходимо заполнить таблицу по значению из ячейки в выпадающем списке. Т.е. если в выпадающем списке выбрать "Всего" - в таблице отражаются указанные данные за все склады, если в выпадающем списке выбрать, например "Склад № 1" - то таблица заполняется только по этому складу.
К сообщению приложен файл: proba1.xlsx (17.6 Kb)
 
Ответить
СообщениеДоброго времени суток!!! Нужна Ваша помощь. На складах имеются одинаковые товары. Необходимо заполнить таблицу по значению из ячейки в выпадающем списке. Т.е. если в выпадающем списке выбрать "Всего" - в таблице отражаются указанные данные за все склады, если в выпадающем списке выбрать, например "Склад № 1" - то таблица заполняется только по этому складу.

Автор - adidas77
Дата добавления - 28.01.2024 в 11:32
DrMini Дата: Воскресенье, 28.01.2024, 13:40 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1647
Репутация: 208 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Здравствуйте adidas77,
Так?
Код
=СУММЕСЛИМН(Таблица1[1-2 кат.];$A$21:$A$52;$B$11;$B$21:$B$52;$C8)
К сообщению приложен файл: 2376133.xlsx (17.9 Kb)
 
Ответить
СообщениеЗдравствуйте adidas77,
Так?
Код
=СУММЕСЛИМН(Таблица1[1-2 кат.];$A$21:$A$52;$B$11;$B$21:$B$52;$C8)

Автор - DrMini
Дата добавления - 28.01.2024 в 13:40
adidas77 Дата: Воскресенье, 28.01.2024, 14:28 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

2019
DrMini, По категориям получилось суппер!!!. В таблице результатов в столбце всего можно и сумму категорий поставить (сумму по строкам. Не решен вопрос если в выпадающем списке выбрать "всего" - за все склады не считает.
К сообщению приложен файл: 4735185.xlsx (17.5 Kb)
 
Ответить
СообщениеDrMini, По категориям получилось суппер!!!. В таблице результатов в столбце всего можно и сумму категорий поставить (сумму по строкам. Не решен вопрос если в выпадающем списке выбрать "всего" - за все склады не считает.

Автор - adidas77
Дата добавления - 28.01.2024 в 14:28
DrMini Дата: Воскресенье, 28.01.2024, 15:09 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1647
Репутация: 208 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Не решен вопрос если в выпадающем списке выбрать "всего"

Тогда можно так:
Код
=ЕСЛИ($B$11="Всего:";СУММЕСЛИ($B$21:$B$52;$C8;F21:F52);СУММЕСЛИМН(Таблица1[1-2 кат.];$A$21:$A$52;$B$11;$B$21:$B$52;$C8))
К сообщению приложен файл: 2323811.xlsx (18.0 Kb)
 
Ответить
Сообщение
Не решен вопрос если в выпадающем списке выбрать "всего"

Тогда можно так:
Код
=ЕСЛИ($B$11="Всего:";СУММЕСЛИ($B$21:$B$52;$C8;F21:F52);СУММЕСЛИМН(Таблица1[1-2 кат.];$A$21:$A$52;$B$11;$B$21:$B$52;$C8))

Автор - DrMini
Дата добавления - 28.01.2024 в 15:09
adidas77 Дата: Воскресенье, 28.01.2024, 15:18 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

2019
DrMini, Огромное спасибо. Все получилось. Я упустил из вида СУММЕСЛИМН.
 
Ответить
СообщениеDrMini, Огромное спасибо. Все получилось. Я упустил из вида СУММЕСЛИМН.

Автор - adidas77
Дата добавления - 28.01.2024 в 15:18
Gustav Дата: Воскресенье, 28.01.2024, 17:32 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2739
Репутация: 1137 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
=СУММЕСЛИМН(Таблица1[1-2 кат.];$A$21:$A$52;$B$11;$B$21:$B$52;$C8)

за все склады не считает

Считает и в таком виде, если в B11 одинокую "звездульку" * поместить. Соответственно, ее можно в таком виде и в список прописать (обычно в подобном списке она интуитивно понятна и без слова "всего"). Но если хочется в выпадающем списке видеть именно слово "Всего:", то можно в исходной формуле организовать подстановку на лету:
Код
=СУММЕСЛИМН(Таблица1[1-2 кат.];$A$21:$A$52; ПОДСТАВИТЬ($B$11;"Всего:";"*"); $B$21:$B$52;$C8)


МОИ: Ник, Tip box: 41001663842605
 
Ответить
Сообщение
=СУММЕСЛИМН(Таблица1[1-2 кат.];$A$21:$A$52;$B$11;$B$21:$B$52;$C8)

за все склады не считает

Считает и в таком виде, если в B11 одинокую "звездульку" * поместить. Соответственно, ее можно в таком виде и в список прописать (обычно в подобном списке она интуитивно понятна и без слова "всего"). Но если хочется в выпадающем списке видеть именно слово "Всего:", то можно в исходной формуле организовать подстановку на лету:
Код
=СУММЕСЛИМН(Таблица1[1-2 кат.];$A$21:$A$52; ПОДСТАВИТЬ($B$11;"Всего:";"*"); $B$21:$B$52;$C8)

Автор - Gustav
Дата добавления - 28.01.2024 в 17:32
DrMini Дата: Воскресенье, 28.01.2024, 19:07 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1647
Репутация: 208 ±
Замечаний: 0% ±

Excel LTSC 2024 RUS
Считает и в таком виде, если в B11 одинокую "звездульку" * поместить.

Здорово. Не додумался.
UPD:
цифирки симпатично смотрятся.
К сообщению приложен файл: 3069550.png (14.1 Kb)


Сообщение отредактировал DrMini - Воскресенье, 28.01.2024, 19:11
 
Ответить
Сообщение
Считает и в таком виде, если в B11 одинокую "звездульку" * поместить.

Здорово. Не додумался.
UPD:
цифирки симпатично смотрятся.

Автор - DrMini
Дата добавления - 28.01.2024 в 19:07
Gustav Дата: Воскресенье, 28.01.2024, 21:46 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2739
Репутация: 1137 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
[offtop]
цифирки симпатично смотрятся

Гы :)


МОИ: Ник, Tip box: 41001663842605
 
Ответить
Сообщение[offtop]
цифирки симпатично смотрятся

Гы :)

Автор - Gustav
Дата добавления - 28.01.2024 в 21:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет товаров всего и по значению из выпадающего списка (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!