Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сопоставить 2 колонки и задать значения - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сопоставить 2 колонки и задать значения (Формулы/Formulas)
Сопоставить 2 колонки и задать значения
piar61ru Дата: Вторник, 30.01.2024, 11:41 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

excel 2021
Добрый день всем. Помогите с формулой пожалуйста. Если в колонке B совпадает со значением в колонке E. Тогда ставим в колонку A, соответствующее значение из колонки D. Только там не построчное совпадение искать нужно, а как бы по всей колонке E. Т.к. в B часть строк удалена.
К сообщению приложен файл: seo_redirekty_proverka_koda_ot.xlsx (111.5 Kb)
 
Ответить
СообщениеДобрый день всем. Помогите с формулой пожалуйста. Если в колонке B совпадает со значением в колонке E. Тогда ставим в колонку A, соответствующее значение из колонки D. Только там не построчное совпадение искать нужно, а как бы по всей колонке E. Т.к. в B часть строк удалена.

Автор - piar61ru
Дата добавления - 30.01.2024 в 11:41
Serge_007 Дата: Вторник, 30.01.2024, 11:49 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
Здравствуйте

Код
=ИНДЕКС(D$2:D$2722;ПОИСКПОЗ(B2;E$2:E$2722;))


[p.s.]В Excel нет колонок, есть столбцы)
К сообщению приложен файл: 5728741.png (8.4 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=ИНДЕКС(D$2:D$2722;ПОИСКПОЗ(B2;E$2:E$2722;))


[p.s.]В Excel нет колонок, есть столбцы)

Автор - Serge_007
Дата добавления - 30.01.2024 в 11:49
piar61ru Дата: Вторник, 30.01.2024, 12:20 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

excel 2021
Круто, спасибо большое!
 
Ответить
СообщениеКруто, спасибо большое!

Автор - piar61ru
Дата добавления - 30.01.2024 в 12:20
Gopronotmore Дата: Среда, 31.01.2024, 11:18 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 199
Репутация: 3 ±
Замечаний: 0% ±

Excel 2007
А можно уйти от индекса и если есть возможность поменять местами колонки D и E, то через ВПР
 
Ответить
СообщениеА можно уйти от индекса и если есть возможность поменять местами колонки D и E, то через ВПР

Автор - Gopronotmore
Дата добавления - 31.01.2024 в 11:18
Serge_007 Дата: Среда, 31.01.2024, 13:11 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 16475
Репутация: 2749 ±
Замечаний: ±

Excel 2016
уйти от индекса
Код
=ВПР(B2;ВЫБОР({1;2};E$2:E$2722;D$2:D$2722);2;)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
уйти от индекса
Код
=ВПР(B2;ВЫБОР({1;2};E$2:E$2722;D$2:D$2722);2;)

Автор - Serge_007
Дата добавления - 31.01.2024 в 13:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сопоставить 2 колонки и задать значения (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2024 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!