Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Номер комбинации перестановки - Страница 2 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 2 из 2«12
Модератор форума: _Boroda_, Pelena 
Мир MS Excel » Работа и общение » Мозговой штурм » Номер комбинации перестановки
Номер комбинации перестановки
Принимаете участие?
MCH Дата: Понедельник, 05.09.2016, 09:09 | Сообщение № 21
Группа: Админы
Ранг: Старожил
Сообщений: 1756
Репутация: 665 ±
Замечаний: ±

По первоначальной задаче
Код
=СУММ((A1:D1>ТРАНСП(B1:E1))*({1:2:3:4}>{0;1;2;3})*{24;6;2;1})

Код
=СУММ(СЧЁТЕСЛИ(СМЕЩ(E1;;;;-{4;3;2;1});"<"&A1:D1)*{24;6;2;1})

Код
=СУММ((РАНГ(A1:D1;СМЕЩ(E1;;;;-{5;4;3;2});1)-1)*{24;6;2;1})

Код
=МУМНОЖ(РАНГ(A1:D1;СМЕЩ(E1;;;;-{5;4;3;2});1)-1;{24:6:2:1})

Решения на 61, 60, 58, 58 символов соответственно

до 152-...РАНГ не додумался, но можно было бы дожать
 
Ответить
СообщениеПо первоначальной задаче
Код
=СУММ((A1:D1>ТРАНСП(B1:E1))*({1:2:3:4}>{0;1;2;3})*{24;6;2;1})

Код
=СУММ(СЧЁТЕСЛИ(СМЕЩ(E1;;;;-{4;3;2;1});"<"&A1:D1)*{24;6;2;1})

Код
=СУММ((РАНГ(A1:D1;СМЕЩ(E1;;;;-{5;4;3;2});1)-1)*{24;6;2;1})

Код
=МУМНОЖ(РАНГ(A1:D1;СМЕЩ(E1;;;;-{5;4;3;2});1)-1;{24:6:2:1})

Решения на 61, 60, 58, 58 символов соответственно

до 152-...РАНГ не додумался, но можно было бы дожать

Автор - MCH
Дата добавления - 05.09.2016 в 09:09
Светлый Дата: Понедельник, 05.09.2016, 11:12 | Сообщение № 22
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 226
Репутация: 56 ±
Замечаний: 0% ±

Excel 2007
buchlotnik, замечательное решение!


Программировать проще, чем писать стихи.
 
Ответить
Сообщениеbuchlotnik, замечательное решение!

Автор - Светлый
Дата добавления - 05.09.2016 в 11:12
buchlotnik Дата: Понедельник, 05.09.2016, 11:26 | Сообщение № 23
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
замечательное решение!
оно, скорее, "в лоб" - но получилось короче, чем со СМЕЩ(), как я ни крутил B)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
замечательное решение!
оно, скорее, "в лоб" - но получилось короче, чем со СМЕЩ(), как я ни крутил B)

Автор - buchlotnik
Дата добавления - 05.09.2016 в 11:26
Светлый Дата: Понедельник, 05.09.2016, 11:29 | Сообщение № 24
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 226
Репутация: 56 ±
Замечаний: 0% ±

Excel 2007
MCH, а по своей задаче формулу можете выложить?


Программировать проще, чем писать стихи.
 
Ответить
СообщениеMCH, а по своей задаче формулу можете выложить?

Автор - Светлый
Дата добавления - 05.09.2016 в 11:29
MCH Дата: Понедельник, 05.09.2016, 12:05 | Сообщение № 25
Группа: Админы
Ранг: Старожил
Сообщений: 1756
Репутация: 665 ±
Замечаний: ±

MCH, а по своей задаче формулу можете выложить?

Код
=СУММ(ЕСЛИ((СТРОКА($1:$36)>A1:E1)*(СТРОКА($1:$36)<B1:F1);ЧИСЛКОМБ(36-СТРОКА($1:$36);{4;3;2;1;0})))+1
 
Ответить
Сообщение
MCH, а по своей задаче формулу можете выложить?

Код
=СУММ(ЕСЛИ((СТРОКА($1:$36)>A1:E1)*(СТРОКА($1:$36)<B1:F1);ЧИСЛКОМБ(36-СТРОКА($1:$36);{4;3;2;1;0})))+1

Автор - MCH
Дата добавления - 05.09.2016 в 12:05
Светлый Дата: Понедельник, 05.09.2016, 13:27 | Сообщение № 26
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 226
Репутация: 56 ±
Замечаний: 0% ±

Excel 2007
получил формулу номера перестановки 5 из 5 для лексиграфического порядка 97 символов

Формулу можно выложить?


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
получил формулу номера перестановки 5 из 5 для лексиграфического порядка 97 символов

Формулу можно выложить?

Автор - Светлый
Дата добавления - 05.09.2016 в 13:27
krosav4ig Дата: Понедельник, 05.09.2016, 23:04 | Сообщение № 27
Группа: Друзья
Ранг: Старожил
Сообщений: 1349
Репутация: 547 ±
Замечаний: 0% ±

Excel 2007, 2013
у мну оказывается первая формула 91, вторая 156 (забыл ФАКТР() сократить :( )
1 для лексиграфического порядка 97 символов
Код
=СУММ(МУМНОЖ(Ч(ТРАНСП(A1:E1)>ЕСЛИ({1:2:3:4:5}<{1;2;3;4;5};A1:E1));{1:1:1:1:1})*ФАКТР({4:3:2:1:0}))

2 для антилексиграфического порядка 162 символа (уверен, что можно сократить, но до этого никак не дошло)
Код
=СУММ(МУМНОЖ(Ч(ПРОСМОТР(-{1:2:3:4:5};-{5:4:3:2:1};O1:S1)<ЕСЛИ({1:2:3:4:5}<{1;2;3;4;5};ПРОСМОТР(-{1;2;3;4;5};-{5:4:3:2:1};O1:S1);));{1:1:1:1:1})*ФАКТР({4:3:2:1:0}))

универсальные формулы генерации (массивные, волатильные, генерация перебором, жуть прям %) ) для лексиграфического и антилексиграфического порядков, обе 334
Код
=ИНДЕКС(ОСТАТ(ЦЕЛОЕ((СТРОКА(СМЕЩ(A$1;;;$Y$1^$W$1))-1)/($Y$1^(СТОЛБЕЦ(СМЕЩ($A1;;;;$W$1))-1)));$Y$1);НАИМЕНЬШИЙ(ЕСЛИ(ПОДСТАВИТЬ(МУМНОЖ(10^(1+ОСТАТ(ЦЕЛОЕ((СТРОКА(СМЕЩ(A$1;;;$Y$1^$W$1))-1)/($Y$1^(СТОЛБЕЦ(СМЕЩ($A1;;;;$W$1))-1)));$Y$1));СТРОКА(СМЕЩ(A$1;;;$W$1))^0);0;)=ПОВТОР(1;$W$1);СТРОКА(СМЕЩ(A$1;;;$Y$1^$W$1)));$G1+1);$W$1-СТОЛБЕЦ(A1)+1)

Код
=ИНДЕКС($Y$1-1-ОСТАТ(ЦЕЛОЕ((СТРОКА(СМЕЩ(A$1;;;$Y$1^$W$1))-1)/($Y$1^(СТОЛБЕЦ(СМЕЩ($A1;;;;$W$1))-1)));$Y$1);НАИМЕНЬШИЙ(ЕСЛИ(ПОДСТАВИТЬ(МУМНОЖ(10^(1+ОСТАТ(ЦЕЛОЕ((СТРОКА(СМЕЩ(A$1;;;$Y$1^$W$1))-1)/($Y$1^(СТОЛБЕЦ(СМЕЩ($A1;;;;$W$1))-1)));$Y$1));СТРОКА(СМЕЩ(A$1;;;$W$1))^0);0;)=ПОВТОР(1;$W$1);СТРОКА(СМЕЩ(A$1;;;$Y$1^$W$1)));$G1+1);СТОЛБЕЦ(A1))
К сообщению приложен файл: N_Perest.xlsx(59Kb)


(_)Õvõ(_)
 
Ответить
Сообщениеу мну оказывается первая формула 91, вторая 156 (забыл ФАКТР() сократить :( )
1 для лексиграфического порядка 97 символов
Код
=СУММ(МУМНОЖ(Ч(ТРАНСП(A1:E1)>ЕСЛИ({1:2:3:4:5}<{1;2;3;4;5};A1:E1));{1:1:1:1:1})*ФАКТР({4:3:2:1:0}))

2 для антилексиграфического порядка 162 символа (уверен, что можно сократить, но до этого никак не дошло)
Код
=СУММ(МУМНОЖ(Ч(ПРОСМОТР(-{1:2:3:4:5};-{5:4:3:2:1};O1:S1)<ЕСЛИ({1:2:3:4:5}<{1;2;3;4;5};ПРОСМОТР(-{1;2;3;4;5};-{5:4:3:2:1};O1:S1);));{1:1:1:1:1})*ФАКТР({4:3:2:1:0}))

универсальные формулы генерации (массивные, волатильные, генерация перебором, жуть прям %) ) для лексиграфического и антилексиграфического порядков, обе 334
Код
=ИНДЕКС(ОСТАТ(ЦЕЛОЕ((СТРОКА(СМЕЩ(A$1;;;$Y$1^$W$1))-1)/($Y$1^(СТОЛБЕЦ(СМЕЩ($A1;;;;$W$1))-1)));$Y$1);НАИМЕНЬШИЙ(ЕСЛИ(ПОДСТАВИТЬ(МУМНОЖ(10^(1+ОСТАТ(ЦЕЛОЕ((СТРОКА(СМЕЩ(A$1;;;$Y$1^$W$1))-1)/($Y$1^(СТОЛБЕЦ(СМЕЩ($A1;;;;$W$1))-1)));$Y$1));СТРОКА(СМЕЩ(A$1;;;$W$1))^0);0;)=ПОВТОР(1;$W$1);СТРОКА(СМЕЩ(A$1;;;$Y$1^$W$1)));$G1+1);$W$1-СТОЛБЕЦ(A1)+1)

Код
=ИНДЕКС($Y$1-1-ОСТАТ(ЦЕЛОЕ((СТРОКА(СМЕЩ(A$1;;;$Y$1^$W$1))-1)/($Y$1^(СТОЛБЕЦ(СМЕЩ($A1;;;;$W$1))-1)));$Y$1);НАИМЕНЬШИЙ(ЕСЛИ(ПОДСТАВИТЬ(МУМНОЖ(10^(1+ОСТАТ(ЦЕЛОЕ((СТРОКА(СМЕЩ(A$1;;;$Y$1^$W$1))-1)/($Y$1^(СТОЛБЕЦ(СМЕЩ($A1;;;;$W$1))-1)));$Y$1));СТРОКА(СМЕЩ(A$1;;;$W$1))^0);0;)=ПОВТОР(1;$W$1);СТРОКА(СМЕЩ(A$1;;;$Y$1^$W$1)));$G1+1);СТОЛБЕЦ(A1))

Автор - krosav4ig
Дата добавления - 05.09.2016 в 23:04
Светлый Дата: Вторник, 06.09.2016, 08:10 | Сообщение № 28
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 226
Репутация: 56 ±
Замечаний: 0% ±

Excel 2007
Тему считаю успешной. Выкладываю сборный файл.
Большое спасибо участникам!
К сообщению приложен файл: N_Perest_Otvet.xls(52Kb)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеТему считаю успешной. Выкладываю сборный файл.
Большое спасибо участникам!

Автор - Светлый
Дата добавления - 06.09.2016 в 08:10
Светлый Дата: Вторник, 06.09.2016, 12:30 | Сообщение № 29
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 226
Репутация: 56 ±
Замечаний: 0% ±

Excel 2007
универсальные формулы генерации

У меня попроще получилось, 111 символов. Для универсальности 6 можно заменить на число_элементов+1 и 9 на 99:
Код
=НАИМЕНЬШИЙ(СЧЁТЕСЛИ($H1:H1;$A$1:$E$1)*9+$A$1:$E$1;ОТБР(ОСТАТ($G1;ФАКТР(6-СТОЛБЕЦ(A1)))/ФАКТР(6-СТОЛБЕЦ(B1)))+1)

И заполнение комбинациями образца в приложенном файле. Часть формул почистил, чтобы файл загрузился на форум. Протянуть предыдущие до необходимых границ.
К сообщению приложен файл: zapoln.xls(84Kb)


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
универсальные формулы генерации

У меня попроще получилось, 111 символов. Для универсальности 6 можно заменить на число_элементов+1 и 9 на 99:
Код
=НАИМЕНЬШИЙ(СЧЁТЕСЛИ($H1:H1;$A$1:$E$1)*9+$A$1:$E$1;ОТБР(ОСТАТ($G1;ФАКТР(6-СТОЛБЕЦ(A1)))/ФАКТР(6-СТОЛБЕЦ(B1)))+1)

И заполнение комбинациями образца в приложенном файле. Часть формул почистил, чтобы файл загрузился на форум. Протянуть предыдущие до необходимых границ.

Автор - Светлый
Дата добавления - 06.09.2016 в 12:30
krosav4ig Дата: Вторник, 06.09.2016, 15:47 | Сообщение № 30
Группа: Друзья
Ранг: Старожил
Сообщений: 1349
Репутация: 547 ±
Замечаний: 0% ±

Excel 2007, 2013
нашел ссылку, откуда стащил формулы E90E50fx Combinatorics using Excel formulas файл Sequences_without_repetition_no_support.xlsx


(_)Õvõ(_)
 
Ответить
Сообщениенашел ссылку, откуда стащил формулы E90E50fx Combinatorics using Excel formulas файл Sequences_without_repetition_no_support.xlsx

Автор - krosav4ig
Дата добавления - 06.09.2016 в 15:47
Мир MS Excel » Работа и общение » Мозговой штурм » Номер комбинации перестановки
Страница 2 из 2«12
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!