Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт часов в ненормированном графике смен - Страница 2 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 2 из 2
  • «
  • 1
  • 2
Модератор форума: _Boroda_, Pelena  
Мир MS Excel » Работа и общение » Мозговой штурм » Подсчёт часов в ненормированном графике смен
Подсчёт часов в ненормированном графике смен
Понравилось
Светлый Дата: Понедельник, 09.07.2018, 16:04 | Сообщение № 21
Группа: Проверенные
Ранг: Ветеран
Сообщений: 516
Репутация: 124 ±
Замечаний: 0% ±

Excel 2007
Нет, я не такой ас в знании функций Excel. Уже иссяк.
Жду решения.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеНет, я не такой ас в знании функций Excel. Уже иссяк.
Жду решения.

Автор - Светлый
Дата добавления - 09.07.2018 в 16:04
MCH Дата: Вторник, 10.07.2018, 15:12 | Сообщение № 22
Группа: Админы
Ранг: Старожил
Сообщений: 1875
Репутация: 709 ±
Замечаний: ±

с 12.07.18 буду в отпуске, думать над задачей уже некогда.
Ничего нового не придумал

Пытался ЧАС() применить вместо ОСТАТ(;24) но к сокращению это не проводит
с помощью ТЕКСТ можно "занулить" текст, отбросить знак, установить формат по условию, но ничего короткого не получилось.
Значит есть более короткий алгоритм решения задачи

Либо нужна дополнительная подсказка, либо решение (завтра - 11.07.18)
 
Ответить
Сообщениес 12.07.18 буду в отпуске, думать над задачей уже некогда.
Ничего нового не придумал

Пытался ЧАС() применить вместо ОСТАТ(;24) но к сокращению это не проводит
с помощью ТЕКСТ можно "занулить" текст, отбросить знак, установить формат по условию, но ничего короткого не получилось.
Значит есть более короткий алгоритм решения задачи

Либо нужна дополнительная подсказка, либо решение (завтра - 11.07.18)

Автор - MCH
Дата добавления - 10.07.2018 в 15:12
_Boroda_ Дата: Вторник, 10.07.2018, 17:06 | Сообщение № 23
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12659
Репутация: 5191 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Блин, сижу вот, думаю - как подсказку дать, не написав саму формулу. Что-то ничего не придумывается. Ну, разве что вот - в обеих формулах по 56(57) символов алгоритм сохраняется, но есть кусок из 15 символов, который можно заменить на 3 символа


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеБлин, сижу вот, думаю - как подсказку дать, не написав саму формулу. Что-то ничего не придумывается. Ну, разве что вот - в обеих формулах по 56(57) символов алгоритм сохраняется, но есть кусок из 15 символов, который можно заменить на 3 символа

Автор - _Boroda_
Дата добавления - 10.07.2018 в 17:06
Светлый Дата: Вторник, 10.07.2018, 22:30 | Сообщение № 24
Группа: Проверенные
Ранг: Ветеран
Сообщений: 516
Репутация: 124 ±
Замечаний: 0% ±

Excel 2007
Кроме функции Ч() ничего не могу придумать, но она вырождает массив и результат неверный.
Очень странная функция.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеКроме функции Ч() ничего не могу придумать, но она вырождает массив и результат неверный.
Очень странная функция.

Автор - Светлый
Дата добавления - 10.07.2018 в 22:30
krosav4ig Дата: Вторник, 10.07.2018, 22:57 | Сообщение № 25
Группа: Друзья
Ранг: Старожил
Сообщений: 1601
Репутация: 666 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Цитата Светлый, 10.07.2018 в 22:30, в сообщении № 24 ()
вырождает массив

массив - нет, а вот диапазон - да


(_)Õvõ(_)
 
Ответить
Сообщение
Цитата Светлый, 10.07.2018 в 22:30, в сообщении № 24 ()
вырождает массив

массив - нет, а вот диапазон - да

Автор - krosav4ig
Дата добавления - 10.07.2018 в 22:57
MCH Дата: Среда, 11.07.2018, 08:31 | Сообщение № 26
Группа: Админы
Ранг: Старожил
Сообщений: 1875
Репутация: 709 ±
Замечаний: ±

Так D6:AG6-Ч(D5:AG5) не работает
Как еще можно подавить текст или нужно в другом направлении думать?
 
Ответить
СообщениеТак D6:AG6-Ч(D5:AG5) не работает
Как еще можно подавить текст или нужно в другом направлении думать?

Автор - MCH
Дата добавления - 11.07.2018 в 08:31
_Boroda_ Дата: Среда, 11.07.2018, 10:59 | Сообщение № 27
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12659
Репутация: 5191 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Через час убегаю до ночи , поэтому сейчас выкладываю
массив - нет, а вот диапазон - да
можно и диапазон массивом через Ч
Так D6:AG6-Ч(D5:AG5) не работает
Да, а вот так работает D6:AG6-Ч(+D5:AG5)
Плюсик перед ссылкой на диапазон многие функции, возвращающие одно значение, заставляет давать массив

У меня сначала было 55 без равно
Код
=СУММ(ОСТАТ(ТЕКСТ(ABS(Ч(+D5:AG5)-D6:AG6);"[>12]-0");24))

Код
=СУММ(ОСТАТ(ТЕКСТ(ABS(Ч(+D5:AG6)*{1:-1});"[>12]-#");24))


Симбиоз с формулами Михаила и Сергея даст 44 знака
Код
=СУММ(ABS(ОСТАТ(D6:AG6-Ч(+D5:AG5)+12;24)-12))

Код
=СУММ(12-ABS(12-ОСТАТ(D6:AG6-Ч(+D5:AG5);24)))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЧерез час убегаю до ночи , поэтому сейчас выкладываю
массив - нет, а вот диапазон - да
можно и диапазон массивом через Ч
Так D6:AG6-Ч(D5:AG5) не работает
Да, а вот так работает D6:AG6-Ч(+D5:AG5)
Плюсик перед ссылкой на диапазон многие функции, возвращающие одно значение, заставляет давать массив

У меня сначала было 55 без равно
Код
=СУММ(ОСТАТ(ТЕКСТ(ABS(Ч(+D5:AG5)-D6:AG6);"[>12]-0");24))

Код
=СУММ(ОСТАТ(ТЕКСТ(ABS(Ч(+D5:AG6)*{1:-1});"[>12]-#");24))


Симбиоз с формулами Михаила и Сергея даст 44 знака
Код
=СУММ(ABS(ОСТАТ(D6:AG6-Ч(+D5:AG5)+12;24)-12))

Код
=СУММ(12-ABS(12-ОСТАТ(D6:AG6-Ч(+D5:AG5);24)))

Автор - _Boroda_
Дата добавления - 11.07.2018 в 10:59
MCH Дата: Среда, 11.07.2018, 11:45 | Сообщение № 28
Группа: Админы
Ранг: Старожил
Сообщений: 1875
Репутация: 709 ±
Замечаний: ±

Плюсик перед ссылкой на диапазон многие функции, возвращающие одно значение, заставляет давать массив

Нужно проверить в 2003 Excel, возможно не будет работать
 
Ответить
Сообщение
Плюсик перед ссылкой на диапазон многие функции, возвращающие одно значение, заставляет давать массив

Нужно проверить в 2003 Excel, возможно не будет работать

Автор - MCH
Дата добавления - 11.07.2018 в 11:45
_Boroda_ Дата: Среда, 11.07.2018, 11:50 | Сообщение № 29
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12659
Репутация: 5191 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А куда оно денется?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА куда оно денется?

Автор - _Boroda_
Дата добавления - 11.07.2018 в 11:50
Светлый Дата: Среда, 11.07.2018, 12:00 | Сообщение № 30
Группа: Проверенные
Ранг: Ветеран
Сообщений: 516
Репутация: 124 ±
Замечаний: 0% ±

Excel 2007
Вот чего не знал, того не знал! С минусом даёт ошибку, с 0& даёт нули, а про плюс не догадался.
Действительно, странная функция.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеВот чего не знал, того не знал! С минусом даёт ошибку, с 0& даёт нули, а про плюс не догадался.
Действительно, странная функция.

Автор - Светлый
Дата добавления - 11.07.2018 в 12:00
Светлый Дата: Среда, 11.07.2018, 12:16 | Сообщение № 31
Группа: Проверенные
Ранг: Ветеран
Сообщений: 516
Репутация: 124 ±
Замечаний: 0% ±

Excel 2007
Ну, тогда в свете открывшихся знаний у меня 43 символа без равно.
Дать время подумать или открыть?


Программировать проще, чем писать стихи.
 
Ответить
СообщениеНу, тогда в свете открывшихся знаний у меня 43 символа без равно.
Дать время подумать или открыть?

Автор - Светлый
Дата добавления - 11.07.2018 в 12:16
MCH Дата: Среда, 11.07.2018, 12:29 | Сообщение № 32
Группа: Админы
Ранг: Старожил
Сообщений: 1875
Репутация: 709 ±
Замечаний: ±

А куда оно денется?

Сейчас проверить негде, но помню, что в подобной ситуации Excel 2003 выдавал ошибку на тексте
 
Ответить
Сообщение
А куда оно денется?

Сейчас проверить негде, но помню, что в подобной ситуации Excel 2003 выдавал ошибку на тексте

Автор - MCH
Дата добавления - 11.07.2018 в 12:29
_Boroda_ Дата: Среда, 11.07.2018, 22:57 | Сообщение № 33
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12659
Репутация: 5191 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
В 2003 нормально работает
43 смвола - мне понятно, думаю, Михаилу тоже


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВ 2003 нормально работает
43 смвола - мне понятно, думаю, Михаилу тоже

Автор - _Boroda_
Дата добавления - 11.07.2018 в 22:57
Светлый Дата: Среда, 11.07.2018, 23:17 | Сообщение № 34
Группа: Проверенные
Ранг: Ветеран
Сообщений: 516
Репутация: 124 ±
Замечаний: 0% ±

Excel 2007
Думаю, что ещё что-то сократить уже не удастся.
Код
=СУММ(ABS(ЧАС(D6:AG6-Ч(+D5:AG5)+36&":")-12))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДумаю, что ещё что-то сократить уже не удастся.
Код
=СУММ(ABS(ЧАС(D6:AG6-Ч(+D5:AG5)+36&":")-12))

Автор - Светлый
Дата добавления - 11.07.2018 в 23:17
Светлый Дата: Среда, 11.07.2018, 23:57 | Сообщение № 35
Группа: Проверенные
Ранг: Ветеран
Сообщений: 516
Репутация: 124 ±
Замечаний: 0% ±

Excel 2007

=СУММ(ОСТАТ(ТЕКСТ(ABS(Ч(+D5:AG6)*{1:-1});"[>12]-#");24))

Эта формула не работает. При паре 8-16 она даёт 8+8, а д.б. 8


Программировать проще, чем писать стихи.
 
Ответить
Сообщение

=СУММ(ОСТАТ(ТЕКСТ(ABS(Ч(+D5:AG6)*{1:-1});"[>12]-#");24))

Эта формула не работает. При паре 8-16 она даёт 8+8, а д.б. 8

Автор - Светлый
Дата добавления - 11.07.2018 в 23:57
Мир MS Excel » Работа и общение » Мозговой штурм » Подсчёт часов в ненормированном графике смен
  • Страница 2 из 2
  • «
  • 1
  • 2
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!