Домашняя страница Undo Do Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выпадающий список

МЕНЮ САЙТА
  • 1
  • 2
  • 3

НОВОСТИ САЙТА
«  Декабрь 2016  »
ПнВтСрЧтПтСбВс
   1234
567891011
12131415161718
19202122232425
262728293031

ОПРОСЫ
Какой версией Excel Вы пользуетесь?
Всего ответов: 35789
Для того что бы перевести сумму денежных средств из числового представления в текстовое воспользуйтесь формулой:
Code
=ИНДЕКС({"";"сто ";"двести ";"триста ";"четыреста ";"пятьсот ";"шестьсот ";"семьсот ";"восемьсот ";"девятьсот "};ОСТАТ(ОТБР(A1/10^8);10)+1)&ВЫБОР(ОСТАТ(ОТБР(A1/10^7);10)+1;"";ИНДЕКС({"десять ";"одиннадцать ";"двенадцать ";"тринадцать ";"четырнадцать ";"пятнадцать ";"шестнадцать ";"семнадцать ";"восемнадцать ";"девятнадцать "};ОСТАТ(ОТБР(A1/10^6);10)+1);"двадцать ";"тридцать ";"сорок ";"пятьдесят ";"шестьдесят ";"семьдесят ";"восемьдесят ";"девяносто ")&ЕСЛИ(ОСТАТ(ОТБР(A1/10^7);10)<>1;ИНДЕКС({"";"один ";"два ";"три ";"четыре ";"пять ";"шесть ";"семь ";"восемь ";"девять "};ОСТАТ(ОТБР(A1/10^6);10)+1);"")&ЕСЛИ(ОСТАТ(ОТБР(A1/10^6);1000);"миллион"&ЕСЛИ(ОСТАТ(ОТБР(A1/10^7);10)=1;"ов ";ВПР(ОСТАТ(ОТБР(A1/10^6);10);{0;"ов ":1;" ":2;"а ":5;"ов "};2));"")&ИНДЕКС({"";"сто ";"двести ";"триста ";"четыреста ";"пятьсот ";"шестьсот ";"семьсот ";"восемьсот ";"девятьсот "};ОСТАТ(ОТБР(A1/10^5);10)+1)&ВЫБОР(ОСТАТ(ОТБР(A1/10^4);10)+1;"";ИНДЕКС({"десять ";"одиннадцать ";"двенадцать ";"тринадцать ";"четырнадцать ";"пятнадцать ";"шестнадцать ";"семнадцать ";"восемнадцать ";"девятнадцать "};ОСТАТ(ОТБР(A1/1000);10)+1);"двадцать ";"тридцать ";"сорок ";"пятьдесят ";"шестьдесят ";"семьдесят ";"восемьдесят ";"девяносто ")&ЕСЛИ(ОСТАТ(ОТБР(A1/10^4);10)<>1;ИНДЕКС({"";"одна ";"две ";"три ";"четыре ";"пять ";"шесть ";"семь ";"восемь ";"девять "};ОСТАТ(ОТБР(A1/1000);10)+1);"")&ЕСЛИ(ОСТАТ(ОТБР(A1/1000);1000);"тысяч"&ЕСЛИ(ОСТАТ(ОТБР(A1/10^4);10)=1;" ";ВПР(ОСТАТ(ОТБР(A1/1000);10);{0;" ":1;"а ":2;"и ":5;" "};2));"")&ИНДЕКС({"";"сто ";"двести ";"триста ";"четыреста ";"пятьсот ";"шестьсот ";"семьсот ";"восемьсот ";"девятьсот "};ОСТАТ(ОТБР(A1/100);10)+1)&ВЫБОР(ОСТАТ(ОТБР(A1/10);10)+1;"";ИНДЕКС({"десять ";"одиннадцать ";"двенадцать ";"тринадцать ";"четырнадцать ";"пятнадцать ";"шестнадцать ";"семнадцать ";"восемнадцать ";"девятнадцать "};ОСТАТ(ОТБР(A1);10)+1);"двадцать ";"тридцать ";"сорок ";"пятьдесят ";"шестьдесят ";"семьдесят ";"восемьдесят ";"девяносто ")&ЕСЛИ(ОТБР(A1)=0;"ноль ";ЕСЛИ(ОСТАТ(ОТБР(A1/10);10)<>1;ИНДЕКС({"";"один ";"два ";"три ";"четыре ";"пять ";"шесть ";"семь ";"восемь ";"девять "};ОСТАТ(ОТБР(A1);10)+1);""))&"рубл"&ЕСЛИ(ОСТАТ(ОТБР(A1/10);10)=1;"ей";ВПР(ОСТАТ(ОТБР(A1);10);{0;"ей":1;"ь":2;"я":5;"ей"};2))&ТЕКСТ(ОТБР((A1-ОТБР(A1)+0,00001)*100);" 00\ коп.;;")
ИНДЕКС ПОИСКПОЗ ЧАСТОТА
Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!