Домашняя страница Undo Do Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Готовые решения

МЕНЮ САЙТА
  • 1
  • 2
  • 3

КАТЕГОРИИ РАЗДЕЛА

ОПРОСЫ
Какой версией Excel Вы пользуетесь?
Всего ответов: 35661
Главная » Готовые решения » Excel » Формулы

Определение знака зодиака по дате
25.04.2013, 10:07
[ Файл-пример (23.0Kb) ]
С помощью этой формулы можно определить знак зодиака по дате
Для определения знака зодиака по дате (дата вводится в ячейку А1) используйте такую формулу:
Code
=ПРОСМОТР(ДАТА(;МЕСЯЦ(A1);ДЕНЬ(A1));{1;20;50;81;111;142;173;205;236;267;297;327;357}; {"Козерог";"Водолей";"Рыбы";"Овен";"Телец";"Близнецы";"Рак";"Лев";"Дева";"Весы";"Скорпион";"Стрелец";"Козерог"})
Для определения знака зодиака на сегодняшний день используйте такую формулу:
Code
=ПРОСМОТР(ДАТА(;МЕСЯЦ(ТДАТА());ДЕНЬ(ТДАТА()));{1;20;50;81;111;142;173;205;236;267;297;327;357}; {"Козерог";"Водолей";"Рыбы";"Овен";"Телец";"Близнецы";"Рак";"Лев";"Дева";"Весы";"Скорпион";"Стрелец";"Козерог"})
Добавил: Serge_007 |
Просмотров: 9028 | Рейтинг: 0.0/0
Всего комментариев: 6
0   Спам
1    Денька   (10.10.2013 02:08)
   Ошибка в определении знака зодиака Лев.

0   Спам
2    Serge_007   (10.10.2013 07:40)
   Приведите пример ошибки

0   Спам
3    Buffonata   (08.11.2013 09:37)
   Я тоже во льве эту ошибку обнаружила, ставлю свой день рожденья 18.08 - получается дева

0   Спам
4    Serge_007   (08.11.2013 10:07)
   Исправил даты согласно википедии

0   Спам
5    АнатоличЪ   (18.12.2013 21:25)
   20 апреля в формуле телец, а в жизни овен) проверил свою дату рождения. хз как там в вики.

0   Спам
6    dmgudkov   (18.04.2014 14:00)
   Для тех кто будет в жизни пользоваться этой формулой предлагаю лёгкий тюнинг: Необходимо добавить в начало формулы =ЕСЛИ(A1="";"";................)

=ЕСЛИ(A1="";"";ПРОСМОТР(ДАТА(;МЕСЯЦ(A1);ДЕНЬ(A1));{1;20;50;81;111;142;173;205;236;267;297;327;357};{"Козерог";"Водолей";"Рыбы";"Овен";"Телец";"Близнецы";"Рак";"Лев";"Дева";"Весы";"Скорпион";"Стрелец";"Козерог"}))

Это нужно для того, чтобы в ячейках таблицы, в которых ещё не проставлены даты рождения людей, отображалось ПУСТО, а не #Н/Д

Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!