Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Удаление ячеек с нулями до первого положительного значения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Удаление ячеек с нулями до первого положительного значения (Макросы/Sub)
Удаление ячеек с нулями до первого положительного значения
murka73 Дата: Среда, 27.01.2016, 10:25 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Суть проблемы в том, что есть большая таблица с более 300 столбцами и более 60 тыс. строк. Первый столбец номер, последующие - дни года (365). Необходимо в каждой строчке удалить ячейки с нулями, чтобы с 1 дня года все строки таблицы начинались с положительного значения (после первого положительного значения данные должны оставаться неизменными), то есть привести таблицу к виду, где все начисления начинались бы с первого дня. Сломал голову, в макросах не силен, стандартными средствами тоже не пойму как сделать. Приложил обрезанный пример с 33 строками. Буду рад любой помощи, ребята.
К сообщению приложен файл: 5680537.xlsx(42Kb)
 
Ответить
СообщениеСуть проблемы в том, что есть большая таблица с более 300 столбцами и более 60 тыс. строк. Первый столбец номер, последующие - дни года (365). Необходимо в каждой строчке удалить ячейки с нулями, чтобы с 1 дня года все строки таблицы начинались с положительного значения (после первого положительного значения данные должны оставаться неизменными), то есть привести таблицу к виду, где все начисления начинались бы с первого дня. Сломал голову, в макросах не силен, стандартными средствами тоже не пойму как сделать. Приложил обрезанный пример с 33 строками. Буду рад любой помощи, ребята.

Автор - murka73
Дата добавления - 27.01.2016 в 10:25
Manyasha Дата: Среда, 27.01.2016, 11:03 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1721
Репутация: 722 ±
Замечаний: 0% ±

Excel 2007, 2010
murka73, посмотрите формульный вариант, может подойдет?
Для столбца B - массивная (вводить через ctrl+shift+enter)
Код
=ИНДЕКС('Начисления %'!B2:NB2;ПОИСКПОЗ(1;--('Начисления %'!B2:NB2>0);0))

Для столбцов С и далее - не массивная
Код
=ЕСЛИОШИБКА(ИНДЕКС('Начисления %'!$B2:$NB2;ПОИСКПОЗ($B2;'Начисления %'!$B2:$NB2;0)+СТОЛБЕЦ(A1));"")
К сообщению приложен файл: 5680537-1.rar(62Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеmurka73, посмотрите формульный вариант, может подойдет?
Для столбца B - массивная (вводить через ctrl+shift+enter)
Код
=ИНДЕКС('Начисления %'!B2:NB2;ПОИСКПОЗ(1;--('Начисления %'!B2:NB2>0);0))

Для столбцов С и далее - не массивная
Код
=ЕСЛИОШИБКА(ИНДЕКС('Начисления %'!$B2:$NB2;ПОИСКПОЗ($B2;'Начисления %'!$B2:$NB2;0)+СТОЛБЕЦ(A1));"")

Автор - Manyasha
Дата добавления - 27.01.2016 в 11:03
murka73 Дата: Среда, 27.01.2016, 13:09 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Решение подошло, большое спасибо ^_^
 
Ответить
СообщениеРешение подошло, большое спасибо ^_^

Автор - murka73
Дата добавления - 27.01.2016 в 13:09
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Удаление ячеек с нулями до первого положительного значения (Макросы/Sub)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!