Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вычисление разрывов в интервале - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Вычисление разрывов в интервале (Макросы/Sub)
Вычисление разрывов в интервале
LexusBb Дата: Вторник, 23.02.2016, 10:56 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
В работе по факту даны интервалы выполненые в определенное время. в колонке разрыв должны отображаться разрывы. в формуле это действие я прописал, только вот время исчислений длительное сильно. Подскажите как можно вычислить через VBA.
К сообщению приложен файл: 2_3.part1.rar(100Kb) · 2_3.part2.rar(53Kb)
 
Ответить
СообщениеВ работе по факту даны интервалы выполненые в определенное время. в колонке разрыв должны отображаться разрывы. в формуле это действие я прописал, только вот время исчислений длительное сильно. Подскажите как можно вычислить через VBA.

Автор - LexusBb
Дата добавления - 23.02.2016 в 10:56
nilem Дата: Вторник, 23.02.2016, 11:20 | Сообщение № 2
Группа: Авторы
Ранг: Старожил
Сообщений: 1189
Репутация: 435 ±
Замечаний: 0% ±

Excel 2013
может формулу попроще?
для D9:
Код
=ЕСЛИ(C9<B10;C9;"")


Яндекс.Деньги 4100159601573
 
Ответить
Сообщениеможет формулу попроще?
для D9:
Код
=ЕСЛИ(C9<B10;C9;"")

Автор - nilem
Дата добавления - 23.02.2016 в 11:20
SLAVICK Дата: Вторник, 23.02.2016, 11:25 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 1962
Репутация: 669 ±
Замечаний: 0% ±

2007,2010,2013,2016
Можно так например:
[vba]
Код
z1 = Range("a6:e" & lastrow).Value
    For i = 1 To UBound(z1) - 1
    If Not z1(i + 1, 2) = z1(i, 3) Then z1(i, 4) = z1(i, 3): z1(i, 5) = z1(i + 1, 2)
    Next
Range("a6:e" & lastrow).Value = z1
[/vba]
Или формулу полегче Ваша формула мало того что массивная так еще и в ссылке столбцы целиком. :o
К сообщению приложен файл: 2_4.xlsm(25Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеМожно так например:
[vba]
Код
z1 = Range("a6:e" & lastrow).Value
    For i = 1 To UBound(z1) - 1
    If Not z1(i + 1, 2) = z1(i, 3) Then z1(i, 4) = z1(i, 3): z1(i, 5) = z1(i + 1, 2)
    Next
Range("a6:e" & lastrow).Value = z1
[/vba]
Или формулу полегче Ваша формула мало того что массивная так еще и в ссылке столбцы целиком. :o

Автор - SLAVICK
Дата добавления - 23.02.2016 в 11:25
LexusBb Дата: Вторник, 23.02.2016, 12:48 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо огромное.!!!!!!!!!!!
 
Ответить
СообщениеСпасибо огромное.!!!!!!!!!!!

Автор - LexusBb
Дата добавления - 23.02.2016 в 12:48
LexusBb Дата: Вторник, 23.02.2016, 13:54 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добавил авто очистку столбцов, чтоб при вводе данных не засорялось
К сообщению приложен файл: ____2.xlsm(33Kb)
 
Ответить
СообщениеДобавил авто очистку столбцов, чтоб при вводе данных не засорялось

Автор - LexusBb
Дата добавления - 23.02.2016 в 13:54
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Вычисление разрывов в интервале (Макросы/Sub)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!