Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Получить значения ячеек диапазона в объединенные ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Получить значения ячеек диапазона в объединенные ячейки (Макросы/Sub)
Получить значения ячеек диапазона в объединенные ячейки
Serg85 Дата: Суббота, 12.03.2016, 10:01 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
День добрый суть проблемы такова: Объеденные ячейки должны последовательно ссылаться на не объеденные к примеру Объеденная ячейка А1:А2 должна ссылаться на В1,А3:А4 на В2 и т д. Приходиться все ссылки делать вручную.
К сообщению приложен файл: 7698926.xlsx(10Kb)


Сообщение отредактировал Manyasha - Суббота, 12.03.2016, 16:31
 
Ответить
СообщениеДень добрый суть проблемы такова: Объеденные ячейки должны последовательно ссылаться на не объеденные к примеру Объеденная ячейка А1:А2 должна ссылаться на В1,А3:А4 на В2 и т д. Приходиться все ссылки делать вручную.

Автор - Serg85
Дата добавления - 12.03.2016 в 10:01
al-Ex Дата: Суббота, 12.03.2016, 10:42 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 149
Репутация: 55 ±
Замечаний: 0% ±

Excel 2010
Не, как-то без объединённых ячеек надо обойтись.
Некорректно они работают при автоматизации.
 
Ответить
СообщениеНе, как-то без объединённых ячеек надо обойтись.
Некорректно они работают при автоматизации.

Автор - al-Ex
Дата добавления - 12.03.2016 в 10:42
vikttur Дата: Суббота, 12.03.2016, 11:18 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2030
Репутация: 355 ±
Замечаний: 0% ±

Код
=ИНДЕКС($B$1:$B$10;СТРОКА()/2+1)
 
Ответить
Сообщение
Код
=ИНДЕКС($B$1:$B$10;СТРОКА()/2+1)

Автор - vikttur
Дата добавления - 12.03.2016 в 11:18
buchlotnik Дата: Суббота, 12.03.2016, 11:21 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
можно как-то так
Код
=ИНДЕКС($E$1:$E$5;СТРОКА(A1)/2+1)
К сообщению приложен файл: 1799166.xlsx(10Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеможно как-то так
Код
=ИНДЕКС($E$1:$E$5;СТРОКА(A1)/2+1)

Автор - buchlotnik
Дата добавления - 12.03.2016 в 11:21
KuklP Дата: Суббота, 12.03.2016, 11:48 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 2006
Репутация: 436 ±
Замечаний: 20% ±

Бедные "Объеденные ячейки"! Кто ж их объедал-то? Вот же мерзавец...


Ну, с НДС и мы чего-то стoим! kuklp@mail.ru
WM Z206653985942, R334086032478, U238399322728
 
Ответить
СообщениеБедные "Объеденные ячейки"! Кто ж их объедал-то? Вот же мерзавец...

Автор - KuklP
Дата добавления - 12.03.2016 в 11:48
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Получить значения ячеек диапазона в объединенные ячейки (Макросы/Sub)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!