Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск всех совпадений в массиве и возврат их значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Поиск всех совпадений в массиве и возврат их значений (Макросы/Sub)
Поиск всех совпадений в массиве и возврат их значений
feik Дата: Вторник, 29.03.2016, 11:43 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Друзья добрый день!
Поделитесь идеей пожалуйста.
Имеется список блюд, меню. (список)
Имеется массив (данные) проданных блюд в какой то период, его выгружаю из кассовой системы. Названия блюд в массиве похожий но, система присваивает свои доп обозначения (акций или наборов).
Очень нужно найти совпадения блюда из "списка" в "данных" и вернуть его количество к соответствующему блюду в "списке".
функция ВПР тут идеально работает, но, в "данных" блюда порой повторяюся, а ВПР берет первое подходящее значение, следовательно другие последующие совпадения не учитываются, к тому же доп обозначения системы часто обновляются.
О чем мечтаю: Чтобы в списке из блюд проставлялось сумма проданных блюд имеющие максимально похожие названия.
Скажем на против "Пицца Капуста" в графе количество посчиталась сумма всех продаж наименований, которые содержит текст "Пицца Капуста", независимо от приставок.
Это реально? Как можно это сделать используя макросы?
Заранее очень признателен за помощь.
К сообщению приложен файл: 4448222.xlsx(30Kb)


нет нет, да и да!)
 
Ответить
СообщениеДрузья добрый день!
Поделитесь идеей пожалуйста.
Имеется список блюд, меню. (список)
Имеется массив (данные) проданных блюд в какой то период, его выгружаю из кассовой системы. Названия блюд в массиве похожий но, система присваивает свои доп обозначения (акций или наборов).
Очень нужно найти совпадения блюда из "списка" в "данных" и вернуть его количество к соответствующему блюду в "списке".
функция ВПР тут идеально работает, но, в "данных" блюда порой повторяюся, а ВПР берет первое подходящее значение, следовательно другие последующие совпадения не учитываются, к тому же доп обозначения системы часто обновляются.
О чем мечтаю: Чтобы в списке из блюд проставлялось сумма проданных блюд имеющие максимально похожие названия.
Скажем на против "Пицца Капуста" в графе количество посчиталась сумма всех продаж наименований, которые содержит текст "Пицца Капуста", независимо от приставок.
Это реально? Как можно это сделать используя макросы?
Заранее очень признателен за помощь.

Автор - feik
Дата добавления - 29.03.2016 в 11:43
_Boroda_ Дата: Вторник, 29.03.2016, 11:48 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9379
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММЕСЛИ(Данные!B$7:B$99;A2&"*";Данные!D$7:D$99)

Только вовнутрь "Пицца Барбекю " включится еще и "Пицца Барбекю Веселая". Вам так и нужно?
К сообщению приложен файл: 4448222_1.xlsx(31Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММЕСЛИ(Данные!B$7:B$99;A2&"*";Данные!D$7:D$99)

Только вовнутрь "Пицца Барбекю " включится еще и "Пицца Барбекю Веселая". Вам так и нужно?

Автор - _Boroda_
Дата добавления - 29.03.2016 в 11:48
feik Дата: Вторник, 29.03.2016, 11:57 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Эмм... Да!))) Огромное спасибо Вам!) Супер, все гениальное просто!!)) hands hands hands clap clap clap yahoo yahoo


нет нет, да и да!)
 
Ответить
Сообщение_Boroda_, Эмм... Да!))) Огромное спасибо Вам!) Супер, все гениальное просто!!)) hands hands hands clap clap clap yahoo yahoo

Автор - feik
Дата добавления - 29.03.2016 в 11:57
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Поиск всех совпадений в массиве и возврат их значений (Макросы/Sub)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!