Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автофильтр по горизонтали - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Автофильтр по горизонтали (Макросы/Sub)
Автофильтр по горизонтали
3377160 Дата: Понедельник, 06.06.2016, 17:15 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Не нашел подобного вопроса, хотя думал кто-то уже таким задавался.
Есть таблица, необходимо отфильтровать(ну или вернее будет вывести) значения с сортировкой по строке A горизонтально.
Помоги плиз, или укажите где такое уже было.
К сообщению приложен файл: 3308424.xlsx(32Kb)


Сообщение отредактировал 3377160 - Понедельник, 06.06.2016, 17:17
 
Ответить
СообщениеНе нашел подобного вопроса, хотя думал кто-то уже таким задавался.
Есть таблица, необходимо отфильтровать(ну или вернее будет вывести) значения с сортировкой по строке A горизонтально.
Помоги плиз, или укажите где такое уже было.

Автор - 3377160
Дата добавления - 06.06.2016 в 17:15
_Boroda_ Дата: Понедельник, 06.06.2016, 17:19 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вам вручную? Тогда так можно - выделяете В2:Н6 - Данные - Сортировка - Параметры - Столбца - ОК - Сортировать по - Строка2 - ОК


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВам вручную? Тогда так можно - выделяете В2:Н6 - Данные - Сортировка - Параметры - Столбца - ОК - Сортировать по - Строка2 - ОК

Автор - _Boroda_
Дата добавления - 06.06.2016 в 17:19
3377160 Дата: Понедельник, 06.06.2016, 17:32 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, спасибо Вам, такое есть) Моя вина, я пока писал сообщения в теме, сам уже запутался)
Вопрос мой, как например из начальных данных вывести все столбцы со значением в строке 2 равным 7. т.е. аналог автофильтра по столбцу.
Файлик обновил.
Если нужно, обновлю первое сообщение.
К сообщению приложен файл: 9940991.xlsx(33Kb)
 
Ответить
Сообщение_Boroda_, спасибо Вам, такое есть) Моя вина, я пока писал сообщения в теме, сам уже запутался)
Вопрос мой, как например из начальных данных вывести все столбцы со значением в строке 2 равным 7. т.е. аналог автофильтра по столбцу.
Файлик обновил.
Если нужно, обновлю первое сообщение.

Автор - 3377160
Дата добавления - 06.06.2016 в 17:32
_Boroda_ Дата: Понедельник, 06.06.2016, 18:09 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если нужно, обновлю первое сообщение

Ага. И как тогда будет выглядеть мое?
Смотрите файл, так нужно?
Первая строка
Код
=ЕСЛИ(СЧЁТЕСЛИ($A12:A12;$C10)>=СЧЁТЕСЛИ($B2:$H2;$C10);"";$C10)

Остальные (формула массива, вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ЕСЛИ(B$12="";"";ИНДЕКС($A3:$H3;НАИМЕНЬШИЙ(ЕСЛИ($B$2:$H$2=B$12;СТОЛБЕЦ($B$2:$H$2));СТОЛБЕЦ(A13))))&""

Не оптимизировал, уже домой хочу с работы.
К сообщению приложен файл: 9940991_1.xlsx(34Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Если нужно, обновлю первое сообщение

Ага. И как тогда будет выглядеть мое?
Смотрите файл, так нужно?
Первая строка
Код
=ЕСЛИ(СЧЁТЕСЛИ($A12:A12;$C10)>=СЧЁТЕСЛИ($B2:$H2;$C10);"";$C10)

Остальные (формула массива, вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ЕСЛИ(B$12="";"";ИНДЕКС($A3:$H3;НАИМЕНЬШИЙ(ЕСЛИ($B$2:$H$2=B$12;СТОЛБЕЦ($B$2:$H$2));СТОЛБЕЦ(A13))))&""

Не оптимизировал, уже домой хочу с работы.

Автор - _Boroda_
Дата добавления - 06.06.2016 в 18:09
3377160 Дата: Понедельник, 06.06.2016, 18:16 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, Спасибо, все так!)
 
Ответить
Сообщение_Boroda_, Спасибо, все так!)

Автор - 3377160
Дата добавления - 06.06.2016 в 18:16
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Автофильтр по горизонтали (Макросы/Sub)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!