Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/макросом сопоставление списков для индефикации ID - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по VBA » макросом сопоставление списков для индефикации ID (Макросы/Sub)
макросом сопоставление списков для индефикации ID
vermut Дата: Пятница, 24.06.2016, 08:56 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
Ребята, приветствую! Есть 2 списка в первом - наименование и ID во втором только наименование, необходимо для второго проставить ID в соответствие с первым списком. Как все это реализовать girl_sad
К сообщению приложен файл: 4357309.xlsx(17Kb)
 
Ответить
СообщениеРебята, приветствую! Есть 2 списка в первом - наименование и ID во втором только наименование, необходимо для второго проставить ID в соответствие с первым списком. Как все это реализовать girl_sad

Автор - vermut
Дата добавления - 24.06.2016 в 08:56
китин Дата: Пятница, 24.06.2016, 09:00 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а может на формулах ?
Код
=ИНДЕКС($A$3:$A$40;ПОИСКПОЗ(E6;$B$3:$B$40;0))
К сообщению приложен файл: 123.xlsx(11Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 24.06.2016, 09:11
 
Ответить
Сообщениеа может на формулах ?
Код
=ИНДЕКС($A$3:$A$40;ПОИСКПОЗ(E6;$B$3:$B$40;0))

Автор - китин
Дата добавления - 24.06.2016 в 09:00
vermut Дата: Пятница, 24.06.2016, 09:05 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
а мо жет на формулах ?


Спасибо, попробую сейчас, у меня в списках около 7000 - 12000 строк, боюсь будет тормозить
 
Ответить
Сообщение
а мо жет на формулах ?


Спасибо, попробую сейчас, у меня в списках около 7000 - 12000 строк, боюсь будет тормозить

Автор - vermut
Дата добавления - 24.06.2016 в 09:05
китин Дата: Пятница, 24.06.2016, 09:10 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а можно еще и так
Код
=ПРОСМОТР(1;ПОИСК(E6;$B$3:$B$40);$A$3:$A$40)
д.б. побыстрее, хотя и ИНДЕКС по одному столбцу тормозить не должна на 12к строчек


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа можно еще и так
Код
=ПРОСМОТР(1;ПОИСК(E6;$B$3:$B$40);$A$3:$A$40)
д.б. побыстрее, хотя и ИНДЕКС по одному столбцу тормозить не должна на 12к строчек

Автор - китин
Дата добавления - 24.06.2016 в 09:10
vermut Дата: Пятница, 24.06.2016, 09:30 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
можно еще и так


БОЛЬШОЕ СПАСИБО
 
Ответить
Сообщение
можно еще и так


БОЛЬШОЕ СПАСИБО

Автор - vermut
Дата добавления - 24.06.2016 в 09:30
vermut Дата: Пятница, 24.06.2016, 10:12 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
можно еще и так


Игорь, не получается вашим методом, ID не совпадают, что не так я делаю?
 
Ответить
Сообщение
можно еще и так


Игорь, не получается вашим методом, ID не совпадают, что не так я делаю?

Автор - vermut
Дата добавления - 24.06.2016 в 10:12
RAN Дата: Пятница, 24.06.2016, 10:21 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4277
Репутация: 829 ±
Замечаний: 0% ±

2010
что не так я делаю?

А что вы делаете?


Быть или не быть, вот в чем загвоздка!
 
Ответить
Сообщение
что не так я делаю?

А что вы делаете?

Автор - RAN
Дата добавления - 24.06.2016 в 10:21
китин Дата: Пятница, 24.06.2016, 10:25 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
я не понял что у вас не получается. там не ни одной формулы( по ссылке ). приложите кусок реального файла и покажите где ошибка


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Пятница, 24.06.2016, 10:26
 
Ответить
Сообщениея не понял что у вас не получается. там не ни одной формулы( по ссылке ). приложите кусок реального файла и покажите где ошибка

Автор - китин
Дата добавления - 24.06.2016 в 10:25
vermut Дата: Пятница, 24.06.2016, 10:54 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
Игорь, спасибо разобралась
 
Ответить
СообщениеИгорь, спасибо разобралась

Автор - vermut
Дата добавления - 24.06.2016 в 10:54
Мир MS Excel » Вопросы и решения » Вопросы по VBA » макросом сопоставление списков для индефикации ID (Макросы/Sub)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!