Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проставить номера между строчками с текстом - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Проставить номера между строчками с текстом (Макросы/Sub)
Проставить номера между строчками с текстом
ant6729 Дата: Вторник, 30.08.2016, 13:54 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 244
Репутация: 0 ±
Замечаний: 60% ±

Excel 2010
Добрый день, как проставить номера между текстовыми значениями не руками как в документе

?
К сообщению приложен файл: __.xlsx(8Kb)
 
Ответить
СообщениеДобрый день, как проставить номера между текстовыми значениями не руками как в документе

?

Автор - ant6729
Дата добавления - 30.08.2016 в 13:54
Gustav Дата: Вторник, 30.08.2016, 14:11 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1348
Репутация: 534 ±
Замечаний: 0% ±

начинал с Excel 4.0...
Протягиваемая формула для B2 и ниже:
Код
=ЕСЛИ(И(ЕПУСТО(A1);ЕПУСТО(A2));B1; ЕСЛИ(ЕПУСТО(A2);МАКС($B$1:B1)+1;""))


Мой tip box - яд 41001663842605
 
Ответить
СообщениеПротягиваемая формула для B2 и ниже:
Код
=ЕСЛИ(И(ЕПУСТО(A1);ЕПУСТО(A2));B1; ЕСЛИ(ЕПУСТО(A2);МАКС($B$1:B1)+1;""))

Автор - Gustav
Дата добавления - 30.08.2016 в 14:11
ant6729 Дата: Вторник, 30.08.2016, 14:56 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 244
Репутация: 0 ±
Замечаний: 60% ±

Excel 2010
Круто, оперативно, спасибо!
 
Ответить
СообщениеКруто, оперативно, спасибо!

Автор - ant6729
Дата добавления - 30.08.2016 в 14:56
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Проставить номера между строчками с текстом (Макросы/Sub)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!