Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/получить сумму и вставить в другой лист - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по VBA » получить сумму и вставить в другой лист (Макросы/Sub)
получить сумму и вставить в другой лист
Maks1390 Дата: Четверг, 01.09.2016, 21:31 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте, помогите осуществить следующую схему.
В листе 1 - получить сумму всех данных из столбца N и вставить ее в лист 2 - ячейка С5 с заменой данных в ней.
Спасибо за помощь.
 
Ответить
СообщениеЗдравствуйте, помогите осуществить следующую схему.
В листе 1 - получить сумму всех данных из столбца N и вставить ее в лист 2 - ячейка С5 с заменой данных в ней.
Спасибо за помощь.

Автор - Maks1390
Дата добавления - 01.09.2016 в 21:31
Nic70y Дата: Четверг, 01.09.2016, 21:43 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3908
Репутация: 827 ±
Замечаний: 0% ±

Excel 2013
[vba]
Код
Sheets(2).[c5] = Application.Sum(Sheets(1).Range("n:n"))
[/vba]а чем
Код
=СУММ(Лист1!N:N)
не устраивает?
тег формулы барахлит =СУММ(Лист1!N:N) (конечно)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Четверг, 01.09.2016, 21:46
 
Ответить
Сообщение[vba]
Код
Sheets(2).[c5] = Application.Sum(Sheets(1).Range("n:n"))
[/vba]а чем
Код
=СУММ(Лист1!N:N)
не устраивает?
тег формулы барахлит =СУММ(Лист1!N:N) (конечно)

Автор - Nic70y
Дата добавления - 01.09.2016 в 21:43
_Boroda_ Дата: Четверг, 01.09.2016, 21:43 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
[vba]
Код
Sheets("Лист2").Range("C5") = WorksheetFunction.Sum(Sheets("Лист1").Range("N:N"))
[/vba]


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
[vba]
Код
Sheets("Лист2").Range("C5") = WorksheetFunction.Sum(Sheets("Лист1").Range("N:N"))
[/vba]

Автор - _Boroda_
Дата добавления - 01.09.2016 в 21:43
Maks1390 Дата: Четверг, 01.09.2016, 22:53 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Так нужно?
[vba]
Код
Sheets("Лист2").Range("C5") = WorksheetFunction.Sum(Sheets("Лист1").Range("N:N"))
[/vba]


Да, именно так, но я забыл про одно условие, нужно брать только те данные из столбца N где столбец В соответствует "выполнен"

Всем спасибо за ответы.


Сообщение отредактировал Maks1390 - Четверг, 01.09.2016, 23:00
 
Ответить
Сообщение
Так нужно?
[vba]
Код
Sheets("Лист2").Range("C5") = WorksheetFunction.Sum(Sheets("Лист1").Range("N:N"))
[/vba]


Да, именно так, но я забыл про одно условие, нужно брать только те данные из столбца N где столбец В соответствует "выполнен"

Всем спасибо за ответы.

Автор - Maks1390
Дата добавления - 01.09.2016 в 22:53
KuklP Дата: Четверг, 01.09.2016, 23:32 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 2110
Репутация: 453 ±
Замечаний: 0% ±

Странно, тут одной формулы хватит. Зачем огород с ВБА?


Ну, с НДС и мы чего-то стoим! kuklp@mail.ru
WM Z206653985942, R334086032478, U238399322728
 
Ответить
СообщениеСтранно, тут одной формулы хватит. Зачем огород с ВБА?

Автор - KuklP
Дата добавления - 01.09.2016 в 23:32
Maks1390 Дата: Пятница, 02.09.2016, 00:45 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Странно, тут одной формулы хватит. Зачем огород с ВБА?

Можете написать эту формулу)?
 
Ответить
Сообщение
Странно, тут одной формулы хватит. Зачем огород с ВБА?

Можете написать эту формулу)?

Автор - Maks1390
Дата добавления - 02.09.2016 в 00:45
_Boroda_ Дата: Пятница, 02.09.2016, 01:35 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Один из вариантов
Код
=СУММЕСЛИ(Лист1!B1:B99;"Выполнен";Лист1!N1:N99)
На 99 строк
[p.s.]
Вы в следующий раз файлик свой прикладывайте[/p.s.]


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеОдин из вариантов
Код
=СУММЕСЛИ(Лист1!B1:B99;"Выполнен";Лист1!N1:N99)
На 99 строк
[p.s.]
Вы в следующий раз файлик свой прикладывайте[/p.s.]

Автор - _Boroda_
Дата добавления - 02.09.2016 в 01:35
Maks1390 Дата: Суббота, 03.09.2016, 12:49 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Так нужно?
Sheets("Лист2").Range("C5") = WorksheetFunction.Sum(Sheets("Лист1").Range("N:N"))

Да, именно так, но я забыл про одно условие, нужно брать только те данные из столбца N где столбец В соответствует "выполнен"


А как это реализовать все-таки в VBA?
 
Ответить
Сообщение
Так нужно?
Sheets("Лист2").Range("C5") = WorksheetFunction.Sum(Sheets("Лист1").Range("N:N"))

Да, именно так, но я забыл про одно условие, нужно брать только те данные из столбца N где столбец В соответствует "выполнен"


А как это реализовать все-таки в VBA?

Автор - Maks1390
Дата добавления - 03.09.2016 в 12:49
KuklP Дата: Суббота, 03.09.2016, 13:25 | Сообщение № 9
Группа: Проверенные
Ранг: Старожил
Сообщений: 2110
Репутация: 453 ±
Замечаний: 0% ±

Внимательно прочитать постскриптум модератора из №7.


Ну, с НДС и мы чего-то стoим! kuklp@mail.ru
WM Z206653985942, R334086032478, U238399322728
 
Ответить
СообщениеВнимательно прочитать постскриптум модератора из №7.

Автор - KuklP
Дата добавления - 03.09.2016 в 13:25
Мир MS Excel » Вопросы и решения » Вопросы по VBA » получить сумму и вставить в другой лист (Макросы/Sub)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!