Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет количества значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Подсчет количества значений (Макросы/Sub)
Подсчет количества значений
baaur Дата: Понедельник, 10.10.2016, 13:45 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 67
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте уважаемые форумчане!

Необходима ваша помощь, есть файлы выгруженные из 1С, в столбце № числа выгружает в числовом формате, как можно подсчитывать количество значений в каждой ячейке?

Или возможно ли макросом перевести в числовой формат?

Заранее спасибо!
К сообщению приложен файл: 1552944.xlsx(12Kb)
 
Ответить
СообщениеЗдравствуйте уважаемые форумчане!

Необходима ваша помощь, есть файлы выгруженные из 1С, в столбце № числа выгружает в числовом формате, как можно подсчитывать количество значений в каждой ячейке?

Или возможно ли макросом перевести в числовой формат?

Заранее спасибо!

Автор - baaur
Дата добавления - 10.10.2016 в 13:45
Pelena Дата: Понедельник, 10.10.2016, 14:20 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9890
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Формулой не вариант?
Код
=ЕСЛИОШИБКА(ЕСЛИ(ЕЧИСЛО(B2);ТЕКСТ(B2;"0000000000");ТЕКСТ(--B2;ПОВТОР("0";ДЛСТР(СЖПРОБЕЛЫ(B2)))));B2)
К сообщению приложен файл: 5439617.xlsx(14Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Формулой не вариант?
Код
=ЕСЛИОШИБКА(ЕСЛИ(ЕЧИСЛО(B2);ТЕКСТ(B2;"0000000000");ТЕКСТ(--B2;ПОВТОР("0";ДЛСТР(СЖПРОБЕЛЫ(B2)))));B2)

Автор - Pelena
Дата добавления - 10.10.2016 в 14:20
baaur Дата: Понедельник, 10.10.2016, 14:34 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 67
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Формулой не вариант?


hands Спасибо большое! Только бы теперь запомнить :D
 
Ответить
Сообщение
Формулой не вариант?


hands Спасибо большое! Только бы теперь запомнить :D

Автор - baaur
Дата добавления - 10.10.2016 в 14:34
_Boroda_ Дата: Понедельник, 10.10.2016, 14:43 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант формулой
Код
=ТЕКСТ(B2;ПОВТОР(0;ЕСЛИОШИБКА(ПОИСК(" ";B2)-1;10)))
К сообщению приложен файл: 1552944_1.xlsx(15Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант формулой
Код
=ТЕКСТ(B2;ПОВТОР(0;ЕСЛИОШИБКА(ПОИСК(" ";B2)-1;10)))

Автор - _Boroda_
Дата добавления - 10.10.2016 в 14:43
baaur Дата: Понедельник, 10.10.2016, 14:46 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 67
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Еще вариант формулой


Спасибо, отличная формула, легче будет запомнить!!! hands
 
Ответить
Сообщение
Еще вариант формулой


Спасибо, отличная формула, легче будет запомнить!!! hands

Автор - baaur
Дата добавления - 10.10.2016 в 14:46
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Подсчет количества значений (Макросы/Sub)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!