Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Количество уникальных значений по нескольким условиям. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Количество уникальных значений по нескольким условиям. (Макросы/Sub)
Количество уникальных значений по нескольким условиям.
Bregra Дата: Пятница, 19.05.2017, 17:53 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Добрый день,

Помогите решить вот такую проблему. Есть несколько столбцов в каждом столбце условие. Как можно посчитать количество уникальных значений по нескольким условиям и записать результат в массив. Во вложении пример. В этом файле есть результат, который должен получиться в массиве. Спасибо.
К сообщению приложен файл: Exampl.xlsx(8.6 Kb)
 
Ответить
СообщениеДобрый день,

Помогите решить вот такую проблему. Есть несколько столбцов в каждом столбце условие. Как можно посчитать количество уникальных значений по нескольким условиям и записать результат в массив. Во вложении пример. В этом файле есть результат, который должен получиться в массиве. Спасибо.

Автор - Bregra
Дата добавления - 19.05.2017 в 17:53
gling Дата: Пятница, 19.05.2017, 18:15 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2163
Репутация: 540 ±
Замечаний: 0% ±

2010
Здравствуйте.
Цитата
и записать результат в массив.
Это раздел для VBA, но в файле не увидел ни макросов ни массивов (в который нужно что то записать), попробуйте формулу
Код
=СУММПРОИЗВ(--($A$2:$A$13&$B$2:$B$13&$C$2:$C$13=F3&G3&H3))
К сообщению приложен файл: 1339408.xlsx(9.4 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Пятница, 19.05.2017, 18:28
 
Ответить
СообщениеЗдравствуйте.
Цитата
и записать результат в массив.
Это раздел для VBA, но в файле не увидел ни макросов ни массивов (в который нужно что то записать), попробуйте формулу
Код
=СУММПРОИЗВ(--($A$2:$A$13&$B$2:$B$13&$C$2:$C$13=F3&G3&H3))

Автор - gling
Дата добавления - 19.05.2017 в 18:15
Bregra Дата: Пятница, 19.05.2017, 18:48 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Спасибо. Но нужно именно макрос и записать в массив, чтобы потом использовать эти данные в дальнейшем макросе.
 
Ответить
СообщениеСпасибо. Но нужно именно макрос и записать в массив, чтобы потом использовать эти данные в дальнейшем макросе.

Автор - Bregra
Дата добавления - 19.05.2017 в 18:48
Bregra Дата: Пятница, 19.05.2017, 18:50 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
И по вашему примеру нельзя найти уникальные значения. У вас результат можно получит если только уникальные значения уже есть.
 
Ответить
СообщениеИ по вашему примеру нельзя найти уникальные значения. У вас результат можно получит если только уникальные значения уже есть.

Автор - Bregra
Дата добавления - 19.05.2017 в 18:50
gling Дата: Пятница, 19.05.2017, 19:43 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2163
Репутация: 540 ±
Замечаний: 0% ±

2010
Записал макрос макрорекордером, адаптируйте к своим данным и "причешите". Не получится обращайтесь на форум.
К сообщению приложен файл: Exampl.xlsm(18.6 Kb)


ЯД-41001506838083
 
Ответить
СообщениеЗаписал макрос макрорекордером, адаптируйте к своим данным и "причешите". Не получится обращайтесь на форум.

Автор - gling
Дата добавления - 19.05.2017 в 19:43
Bregra Дата: Пятница, 19.05.2017, 22:31 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Спасибо. Но задача состоит записать данные в массив, поэтому не нужно выводить данные на лист (не нужно использовать копирование формулы). Есть ли у кого то хотя бы задумка как быстро это можно реализовать, если в примере будет много данных. Например 100 тысяч строк и 10 условий, по которым нужно посчитать количество уникальных значений. Если использовать например словарь, будет ли быстро это работать? Спасибо за любой совет
 
Ответить
СообщениеСпасибо. Но задача состоит записать данные в массив, поэтому не нужно выводить данные на лист (не нужно использовать копирование формулы). Есть ли у кого то хотя бы задумка как быстро это можно реализовать, если в примере будет много данных. Например 100 тысяч строк и 10 условий, по которым нужно посчитать количество уникальных значений. Если использовать например словарь, будет ли быстро это работать? Спасибо за любой совет

Автор - Bregra
Дата добавления - 19.05.2017 в 22:31
buchlotnik Дата: Суббота, 20.05.2017, 09:23 | Сообщение № 7
Группа: Заблокированные
Ранг: Участник клуба
Сообщений: 3442
Репутация: 928 ±
Замечаний: 20% ±

2010, 2013, 2016 RUS / ENG
Bregra, так всё же - вам на выходе лишь количество уникальных или их перечень в памяти держать? Потому как пример ваш
Цитата
быстро
решает банальное построение сводной таблицы
К сообщению приложен файл: 6529369.xlsx(12.3 Kb)


Сообщение отредактировал buchlotnik - Суббота, 20.05.2017, 09:34
 
Ответить
СообщениеBregra, так всё же - вам на выходе лишь количество уникальных или их перечень в памяти держать? Потому как пример ваш
Цитата
быстро
решает банальное построение сводной таблицы

Автор - buchlotnik
Дата добавления - 20.05.2017 в 09:23
Bregra Дата: Суббота, 20.05.2017, 11:46 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Спасибо. Отличное решение. Я почему то все время думал, что нужно через словарь делать, но тогда нужно было бы создавать ключ по нескольким полям, а потом разделять ключ на условия. А ваше решение как раз то, что нужно, нужно перечень уникальных условий и их количество


Сообщение отредактировал Bregra - Суббота, 20.05.2017, 11:46
 
Ответить
СообщениеСпасибо. Отличное решение. Я почему то все время думал, что нужно через словарь делать, но тогда нужно было бы создавать ключ по нескольким полям, а потом разделять ключ на условия. А ваше решение как раз то, что нужно, нужно перечень уникальных условий и их количество

Автор - Bregra
Дата добавления - 20.05.2017 в 11:46
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Количество уникальных значений по нескольким условиям. (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!