Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет среднего значения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Расчет среднего значения (Макросы/Sub)
Расчет среднего значения
misharin Дата: Понедельник, 05.06.2017, 16:23 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день!

Просьба помочь с макросом (или формулой):
Во вложенном примере в графе заданы квартала (графа В), квартал состоит из нескольких выделов (графа C), у каждого выдела своя площадь (графа D), и свой класс пожарной опасности (графа I). Задача состоит в том что, необходимо в каждом квартале площадь определенного класса пожарной опасности (от 1 до 5) умножить на соответствующий класс, далее просуммировать их и разделить на общую площадь квартала.

На примере квартала 1:
сумма площадей выделов с классом пож.опасности 3 равно 6,8: 6,8 х 3=20,4;
сумма площадей выделов с классом пож.опасности 4 равно 57,2: 57,2 х 4=228,8;
сумма площадей выделов с классом пож.опасности 5 равно 45,0: 45,0 х 5=225,0;
Далее, 20,4+228,8+225,0=474,2
Далее, 474,2/109,0=4,4
Округленно = 4

Заранее Благодарю!
К сообщению приложен файл: 5267586.xls(27Kb)
 
Ответить
СообщениеДобрый день!

Просьба помочь с макросом (или формулой):
Во вложенном примере в графе заданы квартала (графа В), квартал состоит из нескольких выделов (графа C), у каждого выдела своя площадь (графа D), и свой класс пожарной опасности (графа I). Задача состоит в том что, необходимо в каждом квартале площадь определенного класса пожарной опасности (от 1 до 5) умножить на соответствующий класс, далее просуммировать их и разделить на общую площадь квартала.

На примере квартала 1:
сумма площадей выделов с классом пож.опасности 3 равно 6,8: 6,8 х 3=20,4;
сумма площадей выделов с классом пож.опасности 4 равно 57,2: 57,2 х 4=228,8;
сумма площадей выделов с классом пож.опасности 5 равно 45,0: 45,0 х 5=225,0;
Далее, 20,4+228,8+225,0=474,2
Далее, 474,2/109,0=4,4
Округленно = 4

Заранее Благодарю!

Автор - misharin
Дата добавления - 05.06.2017 в 16:23
sboy Дата: Понедельник, 05.06.2017, 16:48 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1113
Репутация: 280 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Не совсем понятно куда выводить результат) сделал сбоку
формула для среднего
Код
=ОКРУГЛ(СУММПРОИЗВ($D$2:$D$56*$I$2:$I$56*($B$2:$B$56=N3))/СУММЕСЛИ($B$2:$B$56;N3;$D$2:$D$56);)


upd. Кажется понял куда выводить результат, файл перезалил
К сообщению приложен файл: 4226146.xls(34Kb)


Сообщение отредактировал sboy - Понедельник, 05.06.2017, 17:04
 
Ответить
СообщениеДобрый день.
Не совсем понятно куда выводить результат) сделал сбоку
формула для среднего
Код
=ОКРУГЛ(СУММПРОИЗВ($D$2:$D$56*$I$2:$I$56*($B$2:$B$56=N3))/СУММЕСЛИ($B$2:$B$56;N3;$D$2:$D$56);)


upd. Кажется понял куда выводить результат, файл перезалил

Автор - sboy
Дата добавления - 05.06.2017 в 16:48
misharin Дата: Понедельник, 05.06.2017, 17:04 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Не совсем понял как можно протянуть эти формулы ко всей таблицы (для примеры часть таблицы только привел)

В Графу K нужно вставить в каждый выдел среднее (не округленное) значение, в графу L в каждый выдел среднее (Округленное) значение по кварталу
 
Ответить
СообщениеНе совсем понял как можно протянуть эти формулы ко всей таблицы (для примеры часть таблицы только привел)

В Графу K нужно вставить в каждый выдел среднее (не округленное) значение, в графу L в каждый выдел среднее (Округленное) значение по кварталу

Автор - misharin
Дата добавления - 05.06.2017 в 17:04
sboy Дата: Понедельник, 05.06.2017, 17:06 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1113
Репутация: 280 ±
Замечаний: 0% ±

Excel 2010
misharin, так?
К сообщению приложен файл: 1820531.xls(36Kb)
 
Ответить
Сообщениеmisharin, так?

Автор - sboy
Дата добавления - 05.06.2017 в 17:06
misharin Дата: Понедельник, 05.06.2017, 17:21 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Не совсем понял как можно протянуть эти формулы ко всей таблицы (для примеры часть таблицы только привел)

В Графу K нужно вставить в каждый выдел среднее (не округленное) значение, в графу L в каждый выдел среднее (Округленное) значение по кварталу
 
Ответить
СообщениеНе совсем понял как можно протянуть эти формулы ко всей таблицы (для примеры часть таблицы только привел)

В Графу K нужно вставить в каждый выдел среднее (не округленное) значение, в графу L в каждый выдел среднее (Округленное) значение по кварталу

Автор - misharin
Дата добавления - 05.06.2017 в 17:21
misharin Дата: Вторник, 06.06.2017, 07:03 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
sboy, разобрался. все работает вроде. Благодарю!
 
Ответить
Сообщениеsboy, разобрался. все работает вроде. Благодарю!

Автор - misharin
Дата добавления - 06.06.2017 в 07:03
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Расчет среднего значения (Макросы/Sub)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!