Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Макрос суммы ячеек для столбца - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Макрос суммы ячеек для столбца (Макросы/Sub)
Макрос суммы ячеек для столбца
Kenbroladeb Дата: Вторник, 06.06.2017, 08:43 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Всем здравствуйте. Если такая тема была, извините, не нашел. Дайте ссылку, я удалю эту.
Нужен макрос для подсчета суммы ячеек в каждой строке и выводом на столб.
Пример:
от A1 до C1 есть n числа, нужен вывод суммы в столбе D
Код

=СУММ(A1:C1)

Мне нужно протянуть формулу "=СУММ(A1:C1)" по всему столбцу D, "=СУММ(A2:C2)", "=СУММ(A3:C3)","=СУММ(A4:C4)"
Нужно чтобы это делалось автоматически, за угол тянуть не вариант, так как строки будут удаляться, а формула рано или поздно скушается, да и обьем файла увеличивается если таким образом протянуть до конца...
К сообщению приложен файл: _Microsoft_Exce.xlsx(9Kb)
 
Ответить
СообщениеВсем здравствуйте. Если такая тема была, извините, не нашел. Дайте ссылку, я удалю эту.
Нужен макрос для подсчета суммы ячеек в каждой строке и выводом на столб.
Пример:
от A1 до C1 есть n числа, нужен вывод суммы в столбе D
Код

=СУММ(A1:C1)

Мне нужно протянуть формулу "=СУММ(A1:C1)" по всему столбцу D, "=СУММ(A2:C2)", "=СУММ(A3:C3)","=СУММ(A4:C4)"
Нужно чтобы это делалось автоматически, за угол тянуть не вариант, так как строки будут удаляться, а формула рано или поздно скушается, да и обьем файла увеличивается если таким образом протянуть до конца...

Автор - Kenbroladeb
Дата добавления - 06.06.2017 в 08:43
Karataev Дата: Вторник, 06.06.2017, 08:52 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 857
Репутация: 321 ±
Замечаний: 0% ±

Excel


Сообщение отредактировал Karataev - Вторник, 06.06.2017, 08:53
 
Ответить
Сообщение

Автор - Karataev
Дата добавления - 06.06.2017 в 08:52
Kenbroladeb Дата: Вторник, 06.06.2017, 16:09 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Излишнее цитирование на форуме запрещено.
Спасибо, работает. А можно сделать, чтобы макрос запускался при изменении ячеек, а не вручную запускать? Как-то через Worksheet_Change или Worksheet_SelectionChange, я не знаю...


Сообщение отредактировал Manyasha - Вторник, 06.06.2017, 16:19
 
Ответить
СообщениеИзлишнее цитирование на форуме запрещено.
Спасибо, работает. А можно сделать, чтобы макрос запускался при изменении ячеек, а не вручную запускать? Как-то через Worksheet_Change или Worksheet_SelectionChange, я не знаю...

Автор - Kenbroladeb
Дата добавления - 06.06.2017 в 16:09
Karataev Дата: Вторник, 06.06.2017, 16:22 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 857
Репутация: 321 ±
Замечаний: 0% ±

Excel
Макрос запускается при изменении в столбцах A:C.
Макрос находится в модуле листа 1.

PS. Не цитируйте посты целиком. Если хотите к кому-то обратиться, то щелкните по нику, ник будет вставлен в пост, а затем пишите сообщение.
К сообщению приложен файл: _Microsoft_Exce.xlsb(16Kb)


 
Ответить
СообщениеМакрос запускается при изменении в столбцах A:C.
Макрос находится в модуле листа 1.

PS. Не цитируйте посты целиком. Если хотите к кому-то обратиться, то щелкните по нику, ник будет вставлен в пост, а затем пишите сообщение.

Автор - Karataev
Дата добавления - 06.06.2017 в 16:22
Kenbroladeb Дата: Вторник, 06.06.2017, 16:29 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Karataev, Спасибо, все работает, это то что надо, про цитирование учту.
 
Ответить
СообщениеKarataev, Спасибо, все работает, это то что надо, про цитирование учту.

Автор - Kenbroladeb
Дата добавления - 06.06.2017 в 16:29
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Макрос суммы ячеек для столбца (Макросы/Sub)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!