Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Копировать данные из одной книги в другую.. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Копировать данные из одной книги в другую.. (Макросы/Sub)
Копировать данные из одной книги в другую..
Makar1986 Дата: Вторник, 04.07.2017, 09:05 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравтвуйте, нужно скопировать данные из книги 2 согласно выбранному месяцу в книге 2-5, чтобы при этом еще изменялись автоматически кол-во дней в месяце и выделялись другим цветом выходные. Название оборудования остается неизменным. В книге 2-5 пример заполнения на январь месяц. Спасибо заранее
К сообщению приложен файл: _2.xlsx(15Kb) · _2-5.xlsm(22Kb)


Сообщение отредактировал Makar1986 - Вторник, 04.07.2017, 09:08
 
Ответить
СообщениеЗдравтвуйте, нужно скопировать данные из книги 2 согласно выбранному месяцу в книге 2-5, чтобы при этом еще изменялись автоматически кол-во дней в месяце и выделялись другим цветом выходные. Название оборудования остается неизменным. В книге 2-5 пример заполнения на январь месяц. Спасибо заранее

Автор - Makar1986
Дата добавления - 04.07.2017 в 09:05
Makar1986 Дата: Вторник, 04.07.2017, 14:16 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Часть сделал, нужно только макрос копирования столбца с выбранным месяцем и как убрать чтобы даты следующего месяца не выводились, заранее всем спасибо
К сообщению приложен файл: 6940341.xlsm(23Kb)
 
Ответить
СообщениеЧасть сделал, нужно только макрос копирования столбца с выбранным месяцем и как убрать чтобы даты следующего месяца не выводились, заранее всем спасибо

Автор - Makar1986
Дата добавления - 04.07.2017 в 14:16
Perfect2You Дата: Вторник, 04.07.2017, 14:47 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 231
Репутация: 58 ±
Замечаний: 0% ±

Excel 2010
Формула для F7:
Код
=ЕСЛИ(МЕСЯЦ($E$7)=МЕСЯЦ(E7+1);E7+1;"")

и протянуть по строке.

Если поместить лист "Освещение" в книгу с отчетом, то формула для AJ12:
Код
=ИНДЕКС(Освещение!$A$1:$P$27;ПОИСКПОЗ($B12;Освещение!$B$1:$B$27;0);ПОИСКПОЗ($E$2;Освещение!$A$4:$P$4;0))

и далее распространить на столбец.
Можно не копировать лист в книгу с отчетом, тогда организовать ссылки на нужный файл.

Вот скрыть пустой столбец формулы не могут... Но макрос для этого очень простой...

Pelena! Огромное спасибо за подсказку! Потерял квалификацию!
К сообщению приложен файл: _6940341.xlsm(25Kb)


Сообщение отредактировал Perfect2You - Вторник, 04.07.2017, 14:52
 
Ответить
СообщениеФормула для F7:
Код
=ЕСЛИ(МЕСЯЦ($E$7)=МЕСЯЦ(E7+1);E7+1;"")

и протянуть по строке.

Если поместить лист "Освещение" в книгу с отчетом, то формула для AJ12:
Код
=ИНДЕКС(Освещение!$A$1:$P$27;ПОИСКПОЗ($B12;Освещение!$B$1:$B$27;0);ПОИСКПОЗ($E$2;Освещение!$A$4:$P$4;0))

и далее распространить на столбец.
Можно не копировать лист в книгу с отчетом, тогда организовать ссылки на нужный файл.

Вот скрыть пустой столбец формулы не могут... Но макрос для этого очень простой...

Pelena! Огромное спасибо за подсказку! Потерял квалификацию!

Автор - Perfect2You
Дата добавления - 04.07.2017 в 14:47
Pelena Дата: Вторник, 04.07.2017, 14:48 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11481
Репутация: 2549 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Perfect2You, оформите формулы тегами (кнопка fx)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеPerfect2You, оформите формулы тегами (кнопка fx)

Автор - Pelena
Дата добавления - 04.07.2017 в 14:48
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Копировать данные из одной книги в другую.. (Макросы/Sub)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!