Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/поиск повторяющихся значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по VBA » поиск повторяющихся значений (Макросы/Sub)
поиск повторяющихся значений
rovi221 Дата: Суббота, 02.12.2017, 23:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте
Помогите, пожалуйста, с макросом
Необходимо перебрать столбцы 2 и 3
(желательно по строчкам)
повторяющиеся ячейки закрасить
К сообщению приложен файл: 12345.xls(28Kb)
 
Ответить
СообщениеЗдравствуйте
Помогите, пожалуйста, с макросом
Необходимо перебрать столбцы 2 и 3
(желательно по строчкам)
повторяющиеся ячейки закрасить

Автор - rovi221
Дата добавления - 02.12.2017 в 23:39
buchlotnik Дата: Суббота, 02.12.2017, 23:55 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3430
Репутация: 920 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
rovi221, поясните - ячейки столбца 2 должны повторяться в столбце 3 или просто вытащить повторяющиеся значения? и второе - зачем макрос? какой у вас объем данных?


"заступлюсь за Юрия" - публичный плевок в душу!
 
Ответить
Сообщениеrovi221, поясните - ячейки столбца 2 должны повторяться в столбце 3 или просто вытащить повторяющиеся значения? и второе - зачем макрос? какой у вас объем данных?

Автор - buchlotnik
Дата добавления - 02.12.2017 в 23:55
rovi221 Дата: Воскресенье, 03.12.2017, 16:07 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
buchlotnik
значения в ячейках могут повторяться и во 2 и 3 столбцах
их надо просто закрасить (повторы)
размер таблицы может меняться до несколько сотен строк
 
Ответить
Сообщениеbuchlotnik
значения в ячейках могут повторяться и во 2 и 3 столбцах
их надо просто закрасить (повторы)
размер таблицы может меняться до несколько сотен строк

Автор - rovi221
Дата добавления - 03.12.2017 в 16:07
buchlotnik Дата: Воскресенье, 03.12.2017, 18:56 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3430
Репутация: 920 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
если несколько сотен - достаточно УФ по дубликатам - см. файл
К сообщению приложен файл: 2470130.xls(46Kb)


"заступлюсь за Юрия" - публичный плевок в душу!
 
Ответить
Сообщениеесли несколько сотен - достаточно УФ по дубликатам - см. файл

Автор - buchlotnik
Дата добавления - 03.12.2017 в 18:56
rovi221 Дата: Воскресенье, 03.12.2017, 23:10 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
buchlotnik, еще раз здравствуйте
я очень сильно извиняюсь - наверное неправильно сформулировал вопрос
нужно перебрать ячейки 2 и 3 столбца.
сижу уже 15 минут и не могу выразить, что хочу
надо закрасить лишнии ячейки - которые я не буду учитывать в дальнейшем
т.е. - если найдено 5 ячеек с дубликатами, то надо закрасить 4 ячейки - одну оставить чистой.

и еще - что такое "достаточно УФ по дубликатам"
вроде бы фильтр знаю, а вот это не попадалось.
 
Ответить
Сообщениеbuchlotnik, еще раз здравствуйте
я очень сильно извиняюсь - наверное неправильно сформулировал вопрос
нужно перебрать ячейки 2 и 3 столбца.
сижу уже 15 минут и не могу выразить, что хочу
надо закрасить лишнии ячейки - которые я не буду учитывать в дальнейшем
т.е. - если найдено 5 ячеек с дубликатами, то надо закрасить 4 ячейки - одну оставить чистой.

и еще - что такое "достаточно УФ по дубликатам"
вроде бы фильтр знаю, а вот это не попадалось.

Автор - rovi221
Дата добавления - 03.12.2017 в 23:10
_Boroda_ Дата: Воскресенье, 03.12.2017, 23:35 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11850
Репутация: 4910 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
УФ - это Условное форматирование. Находится на вкладке Главная
Если Вам нужно первую ячейку не красить, то последовательность действий такая:
Встать в ячейку В2, Нажать Шифт+СтрелкаВправо, нажать Контрл+Шифт+СтрелкаВниз - перейти на вкладку Главная - Условное форматирование - Создать правило - Использовать формулу - в строку "Форматировать значения ..." ввести формулу
Код
=СЧЁТЕСЛИ($B$1:$C1;B2)+СЧЁТЕСЛИ($B2:B2;B2)>1

- нажать кнопку "Формат" - перейти на вкладку "Заливка" - выбрать заливку - ОК - ОК
* Обращаю Ваше внимание на то, что выделять диапазон на листе перед вводом формулы в УФ ОБЯЗАТЕЛЬНО начиная с ячейки В2, т.к. формула написана именно для нее
К сообщению приложен файл: 12345_1.xls(40Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУФ - это Условное форматирование. Находится на вкладке Главная
Если Вам нужно первую ячейку не красить, то последовательность действий такая:
Встать в ячейку В2, Нажать Шифт+СтрелкаВправо, нажать Контрл+Шифт+СтрелкаВниз - перейти на вкладку Главная - Условное форматирование - Создать правило - Использовать формулу - в строку "Форматировать значения ..." ввести формулу
Код
=СЧЁТЕСЛИ($B$1:$C1;B2)+СЧЁТЕСЛИ($B2:B2;B2)>1

- нажать кнопку "Формат" - перейти на вкладку "Заливка" - выбрать заливку - ОК - ОК
* Обращаю Ваше внимание на то, что выделять диапазон на листе перед вводом формулы в УФ ОБЯЗАТЕЛЬНО начиная с ячейки В2, т.к. формула написана именно для нее

Автор - _Boroda_
Дата добавления - 03.12.2017 в 23:35
rovi221 Дата: Понедельник, 04.12.2017, 20:01 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, добрый вечер
спасибо большое - все получилось
хотелось конечно в макросе, но и это прекрасно работает
 
Ответить
Сообщение_Boroda_, добрый вечер
спасибо большое - все получилось
хотелось конечно в макросе, но и это прекрасно работает

Автор - rovi221
Дата добавления - 04.12.2017 в 20:01
Мир MS Excel » Вопросы и решения » Вопросы по VBA » поиск повторяющихся значений (Макросы/Sub)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!