Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Результат выпадающего списка - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Результат выпадающего списка (Макросы/Sub)
Результат выпадающего списка
Dadojon Дата: Пятница, 05.01.2018, 14:43 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Необходим результат поиска ФИО с одного листа с другим листом. При точного совпадении ФИО с листом Список, результат отражается на листе Список 2. Пример в приложении. Погрешность (ошибки) букв в правописании ФИО по спискам не более двух символов.
К сообщению приложен файл: 1234.xls(26.0 Kb)
 
Ответить
СообщениеДобрый день.
Необходим результат поиска ФИО с одного листа с другим листом. При точного совпадении ФИО с листом Список, результат отражается на листе Список 2. Пример в приложении. Погрешность (ошибки) букв в правописании ФИО по спискам не более двух символов.

Автор - Dadojon
Дата добавления - 05.01.2018 в 14:43
китин Дата: Суббота, 06.01.2018, 09:56 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4924
Репутация: 786 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
может так?
формула массива
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(1=1;ЕЧИСЛО(ПОИСК(A2;Список!$A$2:$A$14));0));"Есть";"")

[p.s.]
да, с извращениями
К сообщению приложен файл: Dadojon.xls(28.0 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеможет так?
формула массива
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(1=1;ЕЧИСЛО(ПОИСК(A2;Список!$A$2:$A$14));0));"Есть";"")

[p.s.]
да, с извращениями

Автор - китин
Дата добавления - 06.01.2018 в 09:56
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Результат выпадающего списка (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!