Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/перестроение диаграммы при нажатии на клавишу - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » перестроение диаграммы при нажатии на клавишу (Макросы/Sub)
перестроение диаграммы при нажатии на клавишу
Sasha318 Дата: Понедельник, 05.02.2018, 20:48 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Привет, прошу помощи.
Задание во вложении, там подробно описал.
нужно чтобы при нажатии на клавишу менялись данные в диаграмме.
К сообщению приложен файл: 9645058.xlsm(29.0 Kb)


Сообщение отредактировал Sasha318 - Понедельник, 05.02.2018, 21:11
 
Ответить
СообщениеПривет, прошу помощи.
Задание во вложении, там подробно описал.
нужно чтобы при нажатии на клавишу менялись данные в диаграмме.

Автор - Sasha318
Дата добавления - 05.02.2018 в 20:48
Pelena Дата: Понедельник, 05.02.2018, 20:59 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12907
Репутация: 2843 ±
Замечаний: 0% ±

Excel 2010, 2016 & Mac Excel
Название темы должно отражать суть задачи. Что за протяжка?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНазвание темы должно отражать суть задачи. Что за протяжка?

Автор - Pelena
Дата добавления - 05.02.2018 в 20:59
Sasha318 Дата: Понедельник, 05.02.2018, 21:12 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, исправил
 
Ответить
СообщениеPelena, исправил

Автор - Sasha318
Дата добавления - 05.02.2018 в 21:12
Manyasha Дата: Вторник, 06.02.2018, 11:01 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 2190
Репутация: 889 ±
Замечаний: 0% ±

Excel 2010, 2016
Sasha318, здравствуйте, посмотрите вариант через именованные диапазоны:
для OTR (формула в диспетчере имен):
Код
=ИНДЕКС(Лист1!$AG$13:$DZ$13;ПОИСКПОЗ("яяя";Лист1!$AG$3:$DZ$3)-4):ИНДЕКС(Лист1!$AG$13:$DZ$13;ПОИСКПОЗ("яяя";Лист1!$AG$3:$DZ$3))

для других строк аналогично
К сообщению приложен файл: 9645058-2.xlsm(29.5 Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеSasha318, здравствуйте, посмотрите вариант через именованные диапазоны:
для OTR (формула в диспетчере имен):
Код
=ИНДЕКС(Лист1!$AG$13:$DZ$13;ПОИСКПОЗ("яяя";Лист1!$AG$3:$DZ$3)-4):ИНДЕКС(Лист1!$AG$13:$DZ$13;ПОИСКПОЗ("яяя";Лист1!$AG$3:$DZ$3))

для других строк аналогично

Автор - Manyasha
Дата добавления - 06.02.2018 в 11:01
Mikael Дата: Вторник, 06.02.2018, 11:39 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 80
Репутация: 31 ±
Замечаний: 0% ±

Excel 2010
Всем доброго дня!
вариант для Вашей кнопки:
[vba]
Код
    Dim rng As Range
    Set rng = Union([ag3], [ag13].Resize(7), Cells(3, lc - 3).Resize(, 5), Cells(13, lc - 3).Resize(7, 5))
    ActiveSheet.ChartObjects("Диаграмма 1").Chart.SetSourceData rng, xlRows
[/vba]
К сообщению приложен файл: 9645058-Mika.xlsm(31.5 Kb)
 
Ответить
СообщениеВсем доброго дня!
вариант для Вашей кнопки:
[vba]
Код
    Dim rng As Range
    Set rng = Union([ag3], [ag13].Resize(7), Cells(3, lc - 3).Resize(, 5), Cells(13, lc - 3).Resize(7, 5))
    ActiveSheet.ChartObjects("Диаграмма 1").Chart.SetSourceData rng, xlRows
[/vba]

Автор - Mikael
Дата добавления - 06.02.2018 в 11:39
Sasha318 Дата: Вторник, 06.02.2018, 12:35 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Manyasha, класс)спасибо большое!
 
Ответить
СообщениеManyasha, класс)спасибо большое!

Автор - Sasha318
Дата добавления - 06.02.2018 в 12:35
Sasha318 Дата: Вторник, 06.02.2018, 12:36 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Mikael, не менее хороший вариант))огромное спасибище!
 
Ответить
СообщениеMikael, не менее хороший вариант))огромное спасибище!

Автор - Sasha318
Дата добавления - 06.02.2018 в 12:36
Sasha318 Дата: Вторник, 06.02.2018, 13:20 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Manyasha, вроде бы ввел имена да ничего не происходит %)
 
Ответить
СообщениеManyasha, вроде бы ввел имена да ничего не происходит %)

Автор - Sasha318
Дата добавления - 06.02.2018 в 13:20
Sasha318 Дата: Вторник, 06.02.2018, 13:25 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 23
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Manyasha, с диаграммой необходимо при этом какие то манипуляции проводить?
 
Ответить
СообщениеManyasha, с диаграммой необходимо при этом какие то манипуляции проводить?

Автор - Sasha318
Дата добавления - 06.02.2018 в 13:25
Manyasha Дата: Вторник, 06.02.2018, 14:31 | Сообщение № 10
Группа: Модераторы
Ранг: Старожил
Сообщений: 2190
Репутация: 889 ±
Замечаний: 0% ±

Excel 2010, 2016
Sasha318, да, нужно в окошке выбрать данные, для каждого ряда, вместо Вашего диапазона указать именованный:
Выбрать ряд OTR - изменить - в поле Значения указать ='9645058-2.xlsm'!OTR
Аналогично для других и для горизонтальной оси.


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804


Сообщение отредактировал Manyasha - Вторник, 06.02.2018, 14:32
 
Ответить
СообщениеSasha318, да, нужно в окошке выбрать данные, для каждого ряда, вместо Вашего диапазона указать именованный:
Выбрать ряд OTR - изменить - в поле Значения указать ='9645058-2.xlsm'!OTR
Аналогично для других и для горизонтальной оси.

Автор - Manyasha
Дата добавления - 06.02.2018 в 14:31
Мир MS Excel » Вопросы и решения » Вопросы по VBA » перестроение диаграммы при нажатии на клавишу (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!