Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Мягкое закрепление границ массива - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Мягкое закрепление границ массива (Макросы/Sub)
Мягкое закрепление границ массива
Kaiyr Дата: Вторник, 13.02.2018, 15:49 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте! Данные по годам но регионы повторяются по тем же годам. Надо что бы массив был гибким и менял закрепление по регионам.
Код
=A3/СУММ($A$2:A3)
Типа
Код
Сумма
С ячейки
Код
А1[/code] до ячейки [code]А1+105
. Что бы диапазон массива было всегда 104 строки. В файле пояснение и пример.
К сообщению приложен файл: 9546151.xlsx(11.9 Kb)


Активный участник Википедии, могу проконсультировать

Сообщение отредактировал Kaiyr - Вторник, 13.02.2018, 15:51
 
Ответить
СообщениеЗдравствуйте! Данные по годам но регионы повторяются по тем же годам. Надо что бы массив был гибким и менял закрепление по регионам.
Код
=A3/СУММ($A$2:A3)
Типа
Код
Сумма
С ячейки
Код
А1[/code] до ячейки [code]А1+105
. Что бы диапазон массива было всегда 104 строки. В файле пояснение и пример.

Автор - Kaiyr
Дата добавления - 13.02.2018 в 15:49
nilem Дата: Вторник, 13.02.2018, 16:00 | Сообщение № 2
Группа: Авторы
Ранг: Старожил
Сообщений: 1451
Репутация: 512 ±
Замечаний: 0% ±

Excel 2013
Kaiyr, привет
попробуйте
[vba]
Код
Sub ttttt()
Dim r As Range

For Each r In Range("A1", Cells(Rows.Count, 1).End(xlUp)).SpecialCells(2, 1).Areas
    r.Offset(, 3).FormulaR1C1 = "=RC[-3]/SUM(R" & r.Row & "C1:RC[-3])"
Next r
End Sub
[/vba]


Яндекс.Деньги 4100159601573
 
Ответить
СообщениеKaiyr, привет
попробуйте
[vba]
Код
Sub ttttt()
Dim r As Range

For Each r In Range("A1", Cells(Rows.Count, 1).End(xlUp)).SpecialCells(2, 1).Areas
    r.Offset(, 3).FormulaR1C1 = "=RC[-3]/SUM(R" & r.Row & "C1:RC[-3])"
Next r
End Sub
[/vba]

Автор - nilem
Дата добавления - 13.02.2018 в 16:00
gling Дата: Вторник, 13.02.2018, 22:51 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1772
Репутация: 430 ±
Замечаний: 0% ±

2010
Здравствуйте. Этот раздел форума, для вопросов по макросам, а Вы здесь формулы показываете. Вариант формулами такой
Код
=ЕСЛИОШИБКА(A2/СУММ(ИНДЕКС($A$1:A2;ПОИСКПОЗ("яяя";$A$1:A2;1)+1):A2);"")


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте. Этот раздел форума, для вопросов по макросам, а Вы здесь формулы показываете. Вариант формулами такой
Код
=ЕСЛИОШИБКА(A2/СУММ(ИНДЕКС($A$1:A2;ПОИСКПОЗ("яяя";$A$1:A2;1)+1):A2);"")

Автор - gling
Дата добавления - 13.02.2018 в 22:51
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Мягкое закрепление границ массива (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!