Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма ячеек по двум условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Сумма ячеек по двум условиям (Макросы/Sub)
Сумма ячеек по двум условиям
Didrou Дата: Вторник, 10.04.2018, 09:45 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте!

Прошу помощи у знающих. В приложенном файле требуется заполнить ячейки B3-B9 и F3-F9 просуммировав "Значения" из "Списка" ниже, соответствующие каждой "Характеристике", но с учётом признака "а" и "б".
К сообщению приложен файл: 6371134.xlsx(9.4 Kb)


Сообщение отредактировал Didrou - Вторник, 10.04.2018, 10:22
 
Ответить
СообщениеЗдравствуйте!

Прошу помощи у знающих. В приложенном файле требуется заполнить ячейки B3-B9 и F3-F9 просуммировав "Значения" из "Списка" ниже, соответствующие каждой "Характеристике", но с учётом признака "а" и "б".

Автор - Didrou
Дата добавления - 10.04.2018 в 09:45
китин Дата: Вторник, 10.04.2018, 09:46 | Сообщение № 2
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5071
Репутация: 807 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
В приложенном файле

нехорошо обманывать :D


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
В приложенном файле

нехорошо обманывать :D

Автор - китин
Дата добавления - 10.04.2018 в 09:46
Didrou Дата: Вторник, 10.04.2018, 10:22 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Простите, вот)
К сообщению приложен файл: 123.xlsx(9.4 Kb)
 
Ответить
СообщениеПростите, вот)

Автор - Didrou
Дата добавления - 10.04.2018 в 10:22
sboy Дата: Вторник, 10.04.2018, 10:28 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2105
Репутация: 604 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Самый простой вариант это сводная таблица
К сообщению приложен файл: 123-6-.xlsx(13.1 Kb)
 
Ответить
СообщениеДобрый день.
Самый простой вариант это сводная таблица

Автор - sboy
Дата добавления - 10.04.2018 в 10:28
китин Дата: Вторник, 10.04.2018, 10:31 | Сообщение № 5
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5071
Репутация: 807 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Так надо?
Код
=СУММПРОИЗВ($C$14:$C$42*($A$14:$A$42=$A3)*($B$14:$B$42="б"))
К сообщению приложен файл: Didrou.xlsx(10.1 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеТак надо?
Код
=СУММПРОИЗВ($C$14:$C$42*($A$14:$A$42=$A3)*($B$14:$B$42="б"))

Автор - китин
Дата добавления - 10.04.2018 в 10:31
Didrou Дата: Вторник, 10.04.2018, 10:32 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день.
Самый простой вариант это сводная таблица

Здорово!
Не знал про эту возможность. Спасибо и плюсик)
 
Ответить
Сообщение
Добрый день.
Самый простой вариант это сводная таблица

Здорово!
Не знал про эту возможность. Спасибо и плюсик)

Автор - Didrou
Дата добавления - 10.04.2018 в 10:32
Didrou Дата: Вторник, 10.04.2018, 10:34 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Так надо?
[Перевод / Translate]
=СУММПРОИЗВ($C$14:$C$42*($A$14:$A$42=$A3)*($B$14:$B$42="б"))


Да, так. И тебе спасибо за альтернативный вариант.
 
Ответить
Сообщение
Так надо?
[Перевод / Translate]
=СУММПРОИЗВ($C$14:$C$42*($A$14:$A$42=$A3)*($B$14:$B$42="б"))


Да, так. И тебе спасибо за альтернативный вариант.

Автор - Didrou
Дата добавления - 10.04.2018 в 10:34
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Сумма ячеек по двум условиям (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!