Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Число из ячейки передать в переменную как текст с форматом - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Число из ячейки передать в переменную как текст с форматом (Макросы/Sub)
Число из ячейки передать в переменную как текст с форматом
Sancho Дата: Пятница, 13.04.2018, 13:28 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 220
Репутация: 11 ±
Замечаний: 0% ±

2007, 2010, 2013
Всем привет! Подскажите пожалуйста, как число из ячейки передать в переменную как текст с определенным форматом наподобие функции
Код
=ТЕКСТ(A1;"0000")

в ячейке A1 файла примера число "20". Требуется отобразить в MsgBox именно "0020"
попытался применить из записанного рекордером NumberFormat = "0000" совершенно не то, видимо задает только формат ячейки
[vba]
Код

gg1 = ActiveSheet.Cells(1, 1).NumberFormat = "0000"
MsgBox gg1
[/vba]

подскажите пожалуйста истинный путь
К сообщению приложен файл: dimtext.xlsm(14.8 Kb)
 
Ответить
СообщениеВсем привет! Подскажите пожалуйста, как число из ячейки передать в переменную как текст с определенным форматом наподобие функции
Код
=ТЕКСТ(A1;"0000")

в ячейке A1 файла примера число "20". Требуется отобразить в MsgBox именно "0020"
попытался применить из записанного рекордером NumberFormat = "0000" совершенно не то, видимо задает только формат ячейки
[vba]
Код

gg1 = ActiveSheet.Cells(1, 1).NumberFormat = "0000"
MsgBox gg1
[/vba]

подскажите пожалуйста истинный путь

Автор - Sancho
Дата добавления - 13.04.2018 в 13:28
krosav4ig Дата: Пятница, 13.04.2018, 13:35 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1576
Репутация: 658 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Здавствуйте
[vba]
Код
gg1 = Format(ActiveSheet.Cells(1, 1), "0000")
[/vba]


(_)Õvõ(_)
 
Ответить
СообщениеЗдавствуйте
[vba]
Код
gg1 = Format(ActiveSheet.Cells(1, 1), "0000")
[/vba]

Автор - krosav4ig
Дата добавления - 13.04.2018 в 13:35
Sancho Дата: Пятница, 13.04.2018, 13:55 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 220
Репутация: 11 ±
Замечаний: 0% ±

2007, 2010, 2013
krosav4ig, Спасибо!
 
Ответить
Сообщениеkrosav4ig, Спасибо!

Автор - Sancho
Дата добавления - 13.04.2018 в 13:55
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Число из ячейки передать в переменную как текст с форматом (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!