Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/макрос определение последней пустой ячейки в таблице - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » макрос определение последней пустой ячейки в таблице (Макросы/Sub)
макрос определение последней пустой ячейки в таблице
Chelovekov Дата: Понедельник, 14.05.2018, 11:32 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрые день, гуры Екселя.
Помоги те пожалуйста, нужен макрос который вставляет текст ,в последнею строку таблицы, в нужный столбец.
Заранее благодарен.

Пример прикрепляю.
К сообщению приложен файл: 6151449.xlsx(13.2 Kb)
 
Ответить
СообщениеДобрые день, гуры Екселя.
Помоги те пожалуйста, нужен макрос который вставляет текст ,в последнею строку таблицы, в нужный столбец.
Заранее благодарен.

Пример прикрепляю.

Автор - Chelovekov
Дата добавления - 14.05.2018 в 11:32
китин Дата: Понедельник, 14.05.2018, 11:48 | Сообщение № 2
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5071
Репутация: 807 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Как то так, чисто по приложенному примеру
К сообщению приложен файл: Chelovekov.xlsm(19.1 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 14.05.2018, 11:49
 
Ответить
СообщениеКак то так, чисто по приложенному примеру

Автор - китин
Дата добавления - 14.05.2018 в 11:48
_Boroda_ Дата: Понедельник, 14.05.2018, 12:12 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13251
Репутация: 5457 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
[vba]
Код
Sub Макрос1()
    Application.ScreenUpdating = 0
    Range("A2:D2").Copy
    Sheets("Таблица").Range("B" & Range("Таблица1[#All]").Rows.Count + 1).Resize(1, 4).PasteSpecial (xlPasteValues)
    Application.CutCopyMode = 0
    Application.ScreenUpdating = 1
End Sub
[/vba]
А в таблице в первом столбце формула
Код
=СУММ(A1;1)
К сообщению приложен файл: 6151449_1.xlsm(19.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
[vba]
Код
Sub Макрос1()
    Application.ScreenUpdating = 0
    Range("A2:D2").Copy
    Sheets("Таблица").Range("B" & Range("Таблица1[#All]").Rows.Count + 1).Resize(1, 4).PasteSpecial (xlPasteValues)
    Application.CutCopyMode = 0
    Application.ScreenUpdating = 1
End Sub
[/vba]
А в таблице в первом столбце формула
Код
=СУММ(A1;1)

Автор - _Boroda_
Дата добавления - 14.05.2018 в 12:12
Chelovekov Дата: Понедельник, 14.05.2018, 13:59 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Огромное всем спасибо hands
 
Ответить
СообщениеОгромное всем спасибо hands

Автор - Chelovekov
Дата добавления - 14.05.2018 в 13:59
Мир MS Excel » Вопросы и решения » Вопросы по VBA » макрос определение последней пустой ячейки в таблице (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!