Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос текста по критериям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Перенос текста по критериям (Макросы/Sub)
Перенос текста по критериям
deft0n Дата: Среда, 11.07.2018, 14:49 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте! Прошу помощи, необходимо сделать следующее:
У нас есть текст - Шкаф Термик-ШПК 1 поз. 5050, необходимо чтобы текст "поз. 5050" переносился на ячейку ниже.
Идентичное чтобы происходило и по следующим записям, нужно чтобы все что идет до "поз" было в одной ячейке, а то что будет начинаться с "поз" уходило на ячейку ниже.
 
Ответить
СообщениеЗдравствуйте! Прошу помощи, необходимо сделать следующее:
У нас есть текст - Шкаф Термик-ШПК 1 поз. 5050, необходимо чтобы текст "поз. 5050" переносился на ячейку ниже.
Идентичное чтобы происходило и по следующим записям, нужно чтобы все что идет до "поз" было в одной ячейке, а то что будет начинаться с "поз" уходило на ячейку ниже.

Автор - deft0n
Дата добавления - 11.07.2018 в 14:49
Pelena Дата: Среда, 11.07.2018, 17:18 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13032
Репутация: 2877 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Файл с примером помог бы в понимании проблемы


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Файл с примером помог бы в понимании проблемы

Автор - Pelena
Дата добавления - 11.07.2018 в 17:18
deft0n Дата: Четверг, 12.07.2018, 07:59 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Пожалуйста :)
Повторюсь что все, что идет после текста а именно "Поз" должно переноситься на ячейку ниже, которая свободная под текстом.
К сообщению приложен файл: 5218189.xlsx(10.3 Kb)
 
Ответить
СообщениеПожалуйста :)
Повторюсь что все, что идет после текста а именно "Поз" должно переноситься на ячейку ниже, которая свободная под текстом.

Автор - deft0n
Дата добавления - 12.07.2018 в 07:59
boa Дата: Четверг, 12.07.2018, 09:01 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 143
Репутация: 20 ±
Замечаний: 0% ±

2013, 365
deft0n,
Код
=IF(RC1<>"";MID(RC1;1;SEARCH("поз.";RC1)-1);MID(R[-1]C1;SEARCH("поз.";R[-1]C1);20))
К сообщению приложен файл: 5218189-2.xlsx(12.2 Kb)


 
Ответить
Сообщениеdeft0n,
Код
=IF(RC1<>"";MID(RC1;1;SEARCH("поз.";RC1)-1);MID(R[-1]C1;SEARCH("поз.";R[-1]C1);20))

Автор - boa
Дата добавления - 12.07.2018 в 09:01
deft0n Дата: Четверг, 12.07.2018, 09:09 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
boa, так это можно было сделать формулой, спасибо большое :)
 
Ответить
Сообщениеboa, так это можно было сделать формулой, спасибо большое :)

Автор - deft0n
Дата добавления - 12.07.2018 в 09:09
_Boroda_ Дата: Четверг, 12.07.2018, 09:28 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12981
Репутация: 5337 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант формулой
Код
=ЕСЛИ(A2="";ПОДСТАВИТЬ(A1;B1;);ЛЕВБ(A2;ПОИСК(" поз.";A2)))

(Добавил сверху строку)
К сообщению приложен файл: 5218189_1.xlsx(11.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант формулой
Код
=ЕСЛИ(A2="";ПОДСТАВИТЬ(A1;B1;);ЛЕВБ(A2;ПОИСК(" поз.";A2)))

(Добавил сверху строку)

Автор - _Boroda_
Дата добавления - 12.07.2018 в 09:28
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Перенос текста по критериям (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!