Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/SUMIF в VBA cчитающий снизу вверх (финансовый учет) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » SUMIF в VBA cчитающий снизу вверх (финансовый учет) (Макросы/Sub)
SUMIF в VBA cчитающий снизу вверх (финансовый учет)
Zender Дата: Четверг, 23.08.2018, 21:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Ребята, добрый вечер!
столкнулся с одной проблемой, что нужна необычная формула SUMIF макросом. Файл прилагаю. Вкратце, если делать вручную
1) формула должна запускаться снизу вверх
2) верхнюю часть диапазона фиксируем двумя долларами
3) нижний диапазон должен смещаться на шаг вверх, т.е. как бы быть без долларов
4) как только SUMIF достигает суммы "ноль", дальше смысла считать нет и результат должен быть "0".

если в строке 21 суммесли дает "0" цикл для одного материала/переменной нужно закончить и перейти к другому материалу/переменной.
строка 22 = ЕСЛИ(И($G22="261";СУММЕСЛИ($A$1:$A22;A22;$I$1:$I22)=0);0;1)
строка 23 = ЕСЛИ(И($G23="261";СУММЕСЛИ($A$1:$A23;A23;$I$1:$I23)=0);0;1)

При помощи дополнительных манипуляций при условии реализации SUMIF в VBA, хочу построить финансовый учет по методу ФИФО и определить Days Inventory On Hands.

Спасибо большое за совет и помощь!!!
К сообщению приложен файл: SUMIF-Macros.xlsm(21.8 Kb)


Сообщение отредактировал Zender - Пятница, 24.08.2018, 17:20
 
Ответить
СообщениеРебята, добрый вечер!
столкнулся с одной проблемой, что нужна необычная формула SUMIF макросом. Файл прилагаю. Вкратце, если делать вручную
1) формула должна запускаться снизу вверх
2) верхнюю часть диапазона фиксируем двумя долларами
3) нижний диапазон должен смещаться на шаг вверх, т.е. как бы быть без долларов
4) как только SUMIF достигает суммы "ноль", дальше смысла считать нет и результат должен быть "0".

если в строке 21 суммесли дает "0" цикл для одного материала/переменной нужно закончить и перейти к другому материалу/переменной.
строка 22 = ЕСЛИ(И($G22="261";СУММЕСЛИ($A$1:$A22;A22;$I$1:$I22)=0);0;1)
строка 23 = ЕСЛИ(И($G23="261";СУММЕСЛИ($A$1:$A23;A23;$I$1:$I23)=0);0;1)

При помощи дополнительных манипуляций при условии реализации SUMIF в VBA, хочу построить финансовый учет по методу ФИФО и определить Days Inventory On Hands.

Спасибо большое за совет и помощь!!!

Автор - Zender
Дата добавления - 23.08.2018 в 21:57
Zender Дата: Пятница, 24.08.2018, 18:50 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Альтернативное решение найдено. Тему можно закрыть. Извините за тупость!
 
Ответить
СообщениеАльтернативное решение найдено. Тему можно закрыть. Извините за тупость!

Автор - Zender
Дата добавления - 24.08.2018 в 18:50
Pelena Дата: Пятница, 24.08.2018, 18:54 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 13216
Репутация: 2908 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Не хотите поделиться решением?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНе хотите поделиться решением?

Автор - Pelena
Дата добавления - 24.08.2018 в 18:54
Мир MS Excel » Вопросы и решения » Вопросы по VBA » SUMIF в VBA cчитающий снизу вверх (финансовый учет) (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!