Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Распределение исходя из доли с условием. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Распределение исходя из доли с условием. (Макросы/Sub)
Распределение исходя из доли с условием.
Elvira66 Дата: Понедельник, 27.08.2018, 18:40 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 93
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день! Помогите пожалуйста с формулой, пришел новый закуп и его нужно распределить согласно старым продажам (т.е. доли продаж), при этом, чтобы в тех точках где продажи были 0 шт., в данную точку попало 5 шт. от закупа, пример в приложенном файле.
К сообщению приложен файл: 8605884.xlsx(10.2 Kb)
 
Ответить
СообщениеДобрый день! Помогите пожалуйста с формулой, пришел новый закуп и его нужно распределить согласно старым продажам (т.е. доли продаж), при этом, чтобы в тех точках где продажи были 0 шт., в данную точку попало 5 шт. от закупа, пример в приложенном файле.

Автор - Elvira66
Дата добавления - 27.08.2018 в 18:40
Pelena Дата: Понедельник, 27.08.2018, 18:54 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13020
Репутация: 2875 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
В первом приближении можно так
Код
=ОКРУГЛ(ЕСЛИ(A5;($E$3-5*СЧЁТЕСЛИ($A$5:$A$9;0))*B5;5);0)

Но с округлением не всегда получается точно привести к нужной сумме
К сообщению приложен файл: 3291666.xlsx(11.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
В первом приближении можно так
Код
=ОКРУГЛ(ЕСЛИ(A5;($E$3-5*СЧЁТЕСЛИ($A$5:$A$9;0))*B5;5);0)

Но с округлением не всегда получается точно привести к нужной сумме

Автор - Pelena
Дата добавления - 27.08.2018 в 18:54
_Boroda_ Дата: Понедельник, 27.08.2018, 19:21 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 12958
Репутация: 5330 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Но с округлением не всегда получается точно привести к нужной сумме
Да, тогда такой вариант
Код
=ЕСЛИ(A5;ОКРУГЛ((E$3-5*СЧЁТЕСЛИ(A$5:A$9;0))*B5;0)+ЕСЛИ(ПОИСКПОЗ(МАКС(A$5:A$9);A$1:A$9;)=СТРОКА();E$3-5*СЧЁТЕСЛИ(A$5:A$9;0)-СУММПРОИЗВ(ОКРУГЛ((E$3-5*СЧЁТЕСЛИ(A$5:A$9;0))*B$5:B$9;0)));5)

В первой по порядку максимальной сумме продаж считаем не по проценту, а по разнице нового закупа и всех остальных округленных продаж
К сообщению приложен файл: 8605884_1.xlsx(10.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Но с округлением не всегда получается точно привести к нужной сумме
Да, тогда такой вариант
Код
=ЕСЛИ(A5;ОКРУГЛ((E$3-5*СЧЁТЕСЛИ(A$5:A$9;0))*B5;0)+ЕСЛИ(ПОИСКПОЗ(МАКС(A$5:A$9);A$1:A$9;)=СТРОКА();E$3-5*СЧЁТЕСЛИ(A$5:A$9;0)-СУММПРОИЗВ(ОКРУГЛ((E$3-5*СЧЁТЕСЛИ(A$5:A$9;0))*B$5:B$9;0)));5)

В первой по порядку максимальной сумме продаж считаем не по проценту, а по разнице нового закупа и всех остальных округленных продаж

Автор - _Boroda_
Дата добавления - 27.08.2018 в 19:21
Elvira66 Дата: Понедельник, 27.08.2018, 19:26 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 93
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо! Задача решена!
 
Ответить
СообщениеСпасибо! Задача решена!

Автор - Elvira66
Дата добавления - 27.08.2018 в 19:26
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Распределение исходя из доли с условием. (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!