Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Счетчик секундомера с каждым проходом увеличивает шаг на 1 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Счетчик секундомера с каждым проходом увеличивает шаг на 1 (Макросы/Sub)
Счетчик секундомера с каждым проходом увеличивает шаг на 1
Sancho Дата: Четверг, 18.10.2018, 13:17 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 240
Репутация: 13 ±
Замечаний: 0% ±

2007, 2010, 2013
Всем привет!

Бьюсь уже второй день с секундомером и не могу понять в чем причина: Если запустить код повторно нажав OK в сообщении "ПРОЙТИ ЕЩЕ РАЗ", то секундомер увеличивает шаг отсчета на +1, т.е. если второй проход то +2 секунды, третий +3 секунды, и т.д.

Что надо сделать, подскажите пожалуйста.
К сообщению приложен файл: TimeStep.xlsm(18.3 Kb)
 
Ответить
СообщениеВсем привет!

Бьюсь уже второй день с секундомером и не могу понять в чем причина: Если запустить код повторно нажав OK в сообщении "ПРОЙТИ ЕЩЕ РАЗ", то секундомер увеличивает шаг отсчета на +1, т.е. если второй проход то +2 секунды, третий +3 секунды, и т.д.

Что надо сделать, подскажите пожалуйста.

Автор - Sancho
Дата добавления - 18.10.2018 в 13:17
_Boroda_ Дата: Четверг, 18.10.2018, 17:22 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13514
Репутация: 5529 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно ввести еще одну переменную-флаг
К сообщению приложен файл: TimeStep_1.xlsm(20.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно ввести еще одну переменную-флаг

Автор - _Boroda_
Дата добавления - 18.10.2018 в 17:22
Sancho Дата: Четверг, 18.10.2018, 20:12 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 240
Репутация: 13 ±
Замечаний: 0% ±

2007, 2010, 2013
Спасибо, работает, но

Можно ввести еще одну переменную-флаг


Я так понимаю это переменная "k"? Не понимаю тогда для чего "n", если она локальная, и еще для чего вычисляется?

И у меня рвёт мозг от конструкции [vba]
Код
If k Then
[/vba], как её понимать? почему не [vba]
Код
If k=1 Then
[/vba]???

В общем шайтанома...
 
Ответить
СообщениеСпасибо, работает, но

Можно ввести еще одну переменную-флаг


Я так понимаю это переменная "k"? Не понимаю тогда для чего "n", если она локальная, и еще для чего вычисляется?

И у меня рвёт мозг от конструкции [vba]
Код
If k Then
[/vba], как её понимать? почему не [vba]
Код
If k=1 Then
[/vba]???

В общем шайтанома...

Автор - Sancho
Дата добавления - 18.10.2018 в 20:12
_Boroda_ Дата: Четверг, 18.10.2018, 20:20 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13514
Репутация: 5529 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
n вообще не нужно, убейте. Это я баловался, всё вроде лишнее стер потом, а это забыл

Как в Excel можно написать для числовых значений в А1
Код
=ЕСЛИ(A1;5;9)
- если в А1 любое отличное от нуля число, то это будет ИСТИНА, если ноль (или пустая ячейка), то ЛОЖЬ
Аналогично и с[vba]
Код
If k Then
[/vba] - если k ноль или Empty, то k = False, иначе - True


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеn вообще не нужно, убейте. Это я баловался, всё вроде лишнее стер потом, а это забыл

Как в Excel можно написать для числовых значений в А1
Код
=ЕСЛИ(A1;5;9)
- если в А1 любое отличное от нуля число, то это будет ИСТИНА, если ноль (или пустая ячейка), то ЛОЖЬ
Аналогично и с[vba]
Код
If k Then
[/vba] - если k ноль или Empty, то k = False, иначе - True

Автор - _Boroda_
Дата добавления - 18.10.2018 в 20:20
Sancho Дата: Четверг, 18.10.2018, 20:25 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 240
Репутация: 13 ±
Замечаний: 0% ±

2007, 2010, 2013
Спасибо, не знал.
 
Ответить
СообщениеСпасибо, не знал.

Автор - Sancho
Дата добавления - 18.10.2018 в 20:25
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Счетчик секундомера с каждым проходом увеличивает шаг на 1 (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!