Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Скрыть диапазона строк в зависимости от значения в ячейке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Скрыть диапазона строк в зависимости от значения в ячейке (Макросы/Sub)
Скрыть диапазона строк в зависимости от значения в ячейке
Slonaviator Дата: Понедельник, 29.10.2018, 20:15 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здрасти.
Ответ искал, подобные встречаются и, возможно, если бы я знал хоть чуть язык, то подправил бы под себя, НО... увы и ах. ))

Необходимо, чтобы скрывались несколько строк (1-59) в зависимости от значения в ячейке на другом листе и в противном случае скрывался другой диапазон (58-115).

Например.
1 условие) На листе "Печать "Счет"" ячейка H13 содержит значение ООО "Рога" . На листе "Печать "Счет"" скрывается диапазон строк 1-57, на листе "Печать "Акт"" скрывается диапазон строк 1-59.
2 условие) На листе "Печать "Счет"" ячейка H13 содержит любое значение отличное от значения ООО "Рога". На листе "Печать "Счет"" скрывается диапазон строк 58-115, на листе "Печать "Акт"" скрывается диапазон строк 60-116.

Поможите )
К сообщению приложен файл: 7227822.xlsm(11.6 Kb)
 
Ответить
СообщениеЗдрасти.
Ответ искал, подобные встречаются и, возможно, если бы я знал хоть чуть язык, то подправил бы под себя, НО... увы и ах. ))

Необходимо, чтобы скрывались несколько строк (1-59) в зависимости от значения в ячейке на другом листе и в противном случае скрывался другой диапазон (58-115).

Например.
1 условие) На листе "Печать "Счет"" ячейка H13 содержит значение ООО "Рога" . На листе "Печать "Счет"" скрывается диапазон строк 1-57, на листе "Печать "Акт"" скрывается диапазон строк 1-59.
2 условие) На листе "Печать "Счет"" ячейка H13 содержит любое значение отличное от значения ООО "Рога". На листе "Печать "Счет"" скрывается диапазон строк 58-115, на листе "Печать "Акт"" скрывается диапазон строк 60-116.

Поможите )

Автор - Slonaviator
Дата добавления - 29.10.2018 в 20:15
_Boroda_ Дата: Понедельник, 29.10.2018, 21:38 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13502
Репутация: 5526 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если Вам это только для печати, то можно и не скрывать ничего.
Посмотрите в файле - когда Вы на третьем листе выбираете ООО Рога, то во втором листе область печати желтая (попробуйте предварительный просмотр посмотреть). А когда выбираете не Рога, то зеленая.
Как сделано? Жмите Контрл F3, попадете в именованные диапазоны, там есть имя "Область_печати" для листа "Акт", а в нем формула
Код
=ЕСЛИ(СЧЁТЕСЛИ(Лист3!$H$13;"*ООО Рога*");'Печать "Акт"'!$A$60:$I$116;'Печать "Акт"'!$A$1:$I$59)

Аналогично делаем и для листа "Счет". Диапазоны можно другие
К сообщению приложен файл: 7227822_1.xlsm(16.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли Вам это только для печати, то можно и не скрывать ничего.
Посмотрите в файле - когда Вы на третьем листе выбираете ООО Рога, то во втором листе область печати желтая (попробуйте предварительный просмотр посмотреть). А когда выбираете не Рога, то зеленая.
Как сделано? Жмите Контрл F3, попадете в именованные диапазоны, там есть имя "Область_печати" для листа "Акт", а в нем формула
Код
=ЕСЛИ(СЧЁТЕСЛИ(Лист3!$H$13;"*ООО Рога*");'Печать "Акт"'!$A$60:$I$116;'Печать "Акт"'!$A$1:$I$59)

Аналогично делаем и для листа "Счет". Диапазоны можно другие

Автор - _Boroda_
Дата добавления - 29.10.2018 в 21:38
Slonaviator Дата: Понедельник, 29.10.2018, 22:48 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, спасибо.
Перенес, но не работает. Может быть из-за кавычек в названии? У меня все названия с кавычками, например, не ООО Рога, а ООО "Рога" .
 
Ответить
Сообщение_Boroda_, спасибо.
Перенес, но не работает. Может быть из-за кавычек в названии? У меня все названия с кавычками, например, не ООО Рога, а ООО "Рога" .

Автор - Slonaviator
Дата добавления - 29.10.2018 в 22:48
_Boroda_ Дата: Понедельник, 29.10.2018, 22:53 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13502
Репутация: 5526 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Тогда нужно писать так
Код
=ЕСЛИ(СЧЁТЕСЛИ(Лист3!$H$13;"*ООО ""Рога""*");'Печать "Акт"'!$A$60:$I$116;'Печать "Акт"'!$A$1:$I$59)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТогда нужно писать так
Код
=ЕСЛИ(СЧЁТЕСЛИ(Лист3!$H$13;"*ООО ""Рога""*");'Печать "Акт"'!$A$60:$I$116;'Печать "Акт"'!$A$1:$I$59)

Автор - _Boroda_
Дата добавления - 29.10.2018 в 22:53
Slonaviator Дата: Понедельник, 29.10.2018, 23:22 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, СПАСИБИЩЕ :D
Все работает!
 
Ответить
Сообщение_Boroda_, СПАСИБИЩЕ :D
Все работает!

Автор - Slonaviator
Дата добавления - 29.10.2018 в 23:22
RAN Дата: Понедельник, 29.10.2018, 23:53 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4882
Репутация: 974 ±
Замечаний: 0% ±

2010


Быть или не быть, вот в чем загвоздка!
 
Ответить
СообщениеKuzmich

Автор - RAN
Дата добавления - 29.10.2018 в 23:53
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Скрыть диапазона строк в зависимости от значения в ячейке (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!