Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Функция СТРОКА для умной таблицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Функция СТРОКА для умной таблицы (как написать.)
Функция СТРОКА для умной таблицы
neonar Дата: Понедельник, 24.12.2018, 21:48 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день, подскажите как сделать функцию аналог встроенной excel =СТРОКА(), но для умной таблицы на листе.
Проще говоря как написать функцию, которая бы возвращала номер строки умной таблицы, в одной из ячеек данной строки которой введена эта формула?
 
Ответить
СообщениеДобрый день, подскажите как сделать функцию аналог встроенной excel =СТРОКА(), но для умной таблицы на листе.
Проще говоря как написать функцию, которая бы возвращала номер строки умной таблицы, в одной из ячеек данной строки которой введена эта формула?

Автор - neonar
Дата добавления - 24.12.2018 в 21:48
Pelena Дата: Понедельник, 24.12.2018, 22:30 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14087
Репутация: 3080 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
neonar, опишите задачу целиком. Что Вы дальше с этой функцией собираетесь делать? Приложите небольшой файл с примером.
Возможно, найдётся другое решение. А так, на словах - из текущей строки вычесть номер строки заголовка


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеneonar, опишите задачу целиком. Что Вы дальше с этой функцией собираетесь делать? Приложите небольшой файл с примером.
Возможно, найдётся другое решение. А так, на словах - из текущей строки вычесть номер строки заголовка

Автор - Pelena
Дата добавления - 24.12.2018 в 22:30
neonar Дата: Понедельник, 24.12.2018, 22:44 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Задача: функция должна возвращать номер строки умной таблицы в столбце Номер строки таблицы (см. приложенный файл), при этом имя таблицы определяется автоматически внутри функции, работает по принципу стандартной функции =СТРОКА().

Нужна для того, чтобы вычислять значение в столбце сумма. Если номер строки = 1, то сумма = 5000, иначе 1000 (см. прикрепленный файл). Вот как то так.

Спасибо!
К сообщению приложен файл: 2702587.xlsm(9.4 Kb)
 
Ответить
СообщениеЗадача: функция должна возвращать номер строки умной таблицы в столбце Номер строки таблицы (см. приложенный файл), при этом имя таблицы определяется автоматически внутри функции, работает по принципу стандартной функции =СТРОКА().

Нужна для того, чтобы вычислять значение в столбце сумма. Если номер строки = 1, то сумма = 5000, иначе 1000 (см. прикрепленный файл). Вот как то так.

Спасибо!

Автор - neonar
Дата добавления - 24.12.2018 в 22:44
Pelena Дата: Понедельник, 24.12.2018, 23:06 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14087
Репутация: 3080 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Формулой не подойдёт?
[vba]
Код
=СТРОКА()-СТРОКА(Таблица3[[#Заголовки];[Номер строки таблицы]])
[/vba]
К сообщению приложен файл: 2810161.xlsm(14.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормулой не подойдёт?
[vba]
Код
=СТРОКА()-СТРОКА(Таблица3[[#Заголовки];[Номер строки таблицы]])
[/vba]

Автор - Pelena
Дата добавления - 24.12.2018 в 23:06
neonar Дата: Понедельник, 24.12.2018, 23:22 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо. можно так, но если эту формулу вложить в другую формулу с условием =ЕСЛИ((СТРОКА()-СТРОКА(Таблица3[[#Заголовки];[Номер строки таблицы]]))=1;1000;5000), получается громоздко, думал можно как то покороче.
 
Ответить
СообщениеСпасибо. можно так, но если эту формулу вложить в другую формулу с условием =ЕСЛИ((СТРОКА()-СТРОКА(Таблица3[[#Заголовки];[Номер строки таблицы]]))=1;1000;5000), получается громоздко, думал можно как то покороче.

Автор - neonar
Дата добавления - 24.12.2018 в 23:22
Pelena Дата: Понедельник, 24.12.2018, 23:27 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14087
Репутация: 3080 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
UDF
[vba]
Код
Public Function NumRow()
    With Application.Caller
        NumRow = .Row - .ListObject.HeaderRowRange.Row
    End With
End Function
[/vba]


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеUDF
[vba]
Код
Public Function NumRow()
    With Application.Caller
        NumRow = .Row - .ListObject.HeaderRowRange.Row
    End With
End Function
[/vba]

Автор - Pelena
Дата добавления - 24.12.2018 в 23:27
gling Дата: Понедельник, 24.12.2018, 23:39 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1929
Репутация: 480 ±
Замечаний: 0% ±

2010
Здравствуйте. А так не подойдет?
Код
=(СЧЁТ($D$5:D5)>1)*500+500


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте. А так не подойдет?
Код
=(СЧЁТ($D$5:D5)>1)*500+500

Автор - gling
Дата добавления - 24.12.2018 в 23:39
neonar Дата: Вторник, 25.12.2018, 07:36 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, gling спасибо! то что надо
 
Ответить
СообщениеPelena, gling спасибо! то что надо

Автор - neonar
Дата добавления - 25.12.2018 в 07:36
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Функция СТРОКА для умной таблицы (как написать.)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!