Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/сумма по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » сумма по условию (Макросы/Sub)
сумма по условию
Asretyq Дата: Понедельник, 14.01.2019, 16:16 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 180
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый вечер
Есть даты в колоне A и есть сумма в колоне B, нужно в зависимости от квартала и года просуммировать значения из колоны B
Мозги не доходят, я так понял нужно сначала вписать в I уникальные не повторяющие значения, затем по критериям просуммировать
К сообщению приложен файл: 123.xlsm(10.9 Kb)
 
Ответить
СообщениеДобрый вечер
Есть даты в колоне A и есть сумма в колоне B, нужно в зависимости от квартала и года просуммировать значения из колоны B
Мозги не доходят, я так понял нужно сначала вписать в I уникальные не повторяющие значения, затем по критериям просуммировать

Автор - Asretyq
Дата добавления - 14.01.2019 в 16:16
vikttur Дата: Понедельник, 14.01.2019, 16:36 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Самое простое: прописать все квартал+год. Ну, будет 1-2 строки с нулевой суммой - смертельно?
Код
=СУММЕСЛИМН($B$2:$B$20;$D$2:$D$20;I2;$E$2:$E$20;J2)


Сообщение отредактировал vikttur - Понедельник, 14.01.2019, 16:53
 
Ответить
СообщениеСамое простое: прописать все квартал+год. Ну, будет 1-2 строки с нулевой суммой - смертельно?
Код
=СУММЕСЛИМН($B$2:$B$20;$D$2:$D$20;I2;$E$2:$E$20;J2)

Автор - vikttur
Дата добавления - 14.01.2019 в 16:36
_Boroda_ Дата: Понедельник, 14.01.2019, 17:29 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14885
Репутация: 5882 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Без допстолбцов с кварталами и годами, сразу по датам
Код
=ЕСЛИОШИБКА(ОТБР((МЕСЯЦ(НАИМЕНЬШИЙ(A$2:A$99;1+ЕСЛИ(Ч(I1);СУММПРОИЗВ((A$2:A$99<ДАТАМЕС(I1*3&-J1;1))-(A$2:A$99=0)))))+2)/3);-1)

Код
=ЕСЛИ(I2>0;ГОД(НАИМЕНЬШИЙ(A$2:A$99;1+ЕСЛИ(Ч(I1);СУММПРОИЗВ((A$2:A$99<ДАТАМЕС(I1*3&-J1;1))-(A$2:A$99=0)))));)

Код
=ЕСЛИ(J2;СУММЕСЛИ(A:A;"<"&ДАТАМЕС(I2*3&-J2;1);B:B)-СУММ(K$1:K1);)

Формат ячеек 0;;
К сообщению приложен файл: 123-7-1.xlsm(11.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеБез допстолбцов с кварталами и годами, сразу по датам
Код
=ЕСЛИОШИБКА(ОТБР((МЕСЯЦ(НАИМЕНЬШИЙ(A$2:A$99;1+ЕСЛИ(Ч(I1);СУММПРОИЗВ((A$2:A$99<ДАТАМЕС(I1*3&-J1;1))-(A$2:A$99=0)))))+2)/3);-1)

Код
=ЕСЛИ(I2>0;ГОД(НАИМЕНЬШИЙ(A$2:A$99;1+ЕСЛИ(Ч(I1);СУММПРОИЗВ((A$2:A$99<ДАТАМЕС(I1*3&-J1;1))-(A$2:A$99=0)))));)

Код
=ЕСЛИ(J2;СУММЕСЛИ(A:A;"<"&ДАТАМЕС(I2*3&-J2;1);B:B)-СУММ(K$1:K1);)

Формат ячеек 0;;

Автор - _Boroda_
Дата добавления - 14.01.2019 в 17:29
Asretyq Дата: Вторник, 15.01.2019, 06:35 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 180
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
_Boroda_, четко)) спасибо
vikttur, спасибо
 
Ответить
Сообщение_Boroda_, четко)) спасибо
vikttur, спасибо

Автор - Asretyq
Дата добавления - 15.01.2019 в 06:35
Мир MS Excel » Вопросы и решения » Вопросы по VBA » сумма по условию (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!