Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Пересчет формулы в конкретной ячейке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Пересчет формулы в конкретной ячейке (Макросы/Sub)
Пересчет формулы в конкретной ячейке
ASWP Дата: Суббота, 16.02.2019, 18:18 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 174
Репутация: 23 ±
Замечаний: 0% ±

Excel 2007
Не обновляется автоматически формула, как это сделать при помощи vba?
Код
=СУММПРОИЗВ((C13=Таблица2[Дата])*(E13<Таблица2[Время конец])*(G13>Таблица2[Время начала]))



Тем более, что нужно уточнение - пересчитать одну формулу, несколько, весь лист, все открытые файлы Excel?
И зачем перед копированием пересчитывать?

Все настройки включены (обновления связей, макросы, автовычисления), но при определенных условиях формула сама не обновляется, надо зайти в нее и нажать энтер, чтобы она обновилась и показала правильный результат.


я знаю что ничего не знаю, но другие не знают и этого

Сообщение отредактировал ASWP - Суббота, 16.02.2019, 18:22
 
Ответить
СообщениеНе обновляется автоматически формула, как это сделать при помощи vba?
Код
=СУММПРОИЗВ((C13=Таблица2[Дата])*(E13<Таблица2[Время конец])*(G13>Таблица2[Время начала]))



Тем более, что нужно уточнение - пересчитать одну формулу, несколько, весь лист, все открытые файлы Excel?
И зачем перед копированием пересчитывать?

Все настройки включены (обновления связей, макросы, автовычисления), но при определенных условиях формула сама не обновляется, надо зайти в нее и нажать энтер, чтобы она обновилась и показала правильный результат.

Автор - ASWP
Дата добавления - 16.02.2019 в 18:18
_Boroda_ Дата: Суббота, 16.02.2019, 18:45 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14424
Репутация: 5774 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Странно. При каких "определенных" условиях?
Попробуйте так
[vba]
Код
range("A1").FormulaLocal=range("A1").FormulaLocal
[/vba]
Или так
[vba]
Код
range("A1").Calculate
[/vba]


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСтранно. При каких "определенных" условиях?
Попробуйте так
[vba]
Код
range("A1").FormulaLocal=range("A1").FormulaLocal
[/vba]
Или так
[vba]
Код
range("A1").Calculate
[/vba]

Автор - _Boroda_
Дата добавления - 16.02.2019 в 18:45
ASWP Дата: Суббота, 16.02.2019, 18:57 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 174
Репутация: 23 ±
Замечаний: 0% ±

Excel 2007
При каких "определенных" условиях?

При "одновременном" добавлении данных в таблицу. Спасибо, первый вариант подошел, вроде бы работает.


я знаю что ничего не знаю, но другие не знают и этого

Сообщение отредактировал ASWP - Суббота, 16.02.2019, 18:57
 
Ответить
Сообщение
При каких "определенных" условиях?

При "одновременном" добавлении данных в таблицу. Спасибо, первый вариант подошел, вроде бы работает.

Автор - ASWP
Дата добавления - 16.02.2019 в 18:57
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Пересчет формулы в конкретной ячейке (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!