Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Обработка данных, введённых вручную в одной ячейке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Обработка данных, введённых вручную в одной ячейке (Макросы/Sub)
Обработка данных, введённых вручную в одной ячейке
drago_782 Дата: Среда, 03.07.2019, 22:56 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Вижу 2 решения проблемы. Но не получилось решить (((
1) В ячейке "светлозелёной" (для наглядности, может быть и белой) нажимаем и выскакивает окно с галочками
"A" -
"B"
....
ставим галочки напротив букв, которые надо обрабатывать и ставим рядом число (целое) 10, 20, 30...10000 и т.д.
Требуется собрать эти данные в результирующую таблицу
2) В ячейке "светлозелёной", вручную пишем A,10;B,90;D,5000 ..... и т.д.
Требуется собрать эти данные в результирующую таблицу

Подскажите пожалуйста как это можно решить, голову уже с формулами сломал. Предпочтителен 1й вариант.
К сообщению приложен файл: 001.xls(30.0 Kb)


Сообщение отредактировал drago_782 - Среда, 03.07.2019, 22:58
 
Ответить
СообщениеВижу 2 решения проблемы. Но не получилось решить (((
1) В ячейке "светлозелёной" (для наглядности, может быть и белой) нажимаем и выскакивает окно с галочками
"A" -
"B"
....
ставим галочки напротив букв, которые надо обрабатывать и ставим рядом число (целое) 10, 20, 30...10000 и т.д.
Требуется собрать эти данные в результирующую таблицу
2) В ячейке "светлозелёной", вручную пишем A,10;B,90;D,5000 ..... и т.д.
Требуется собрать эти данные в результирующую таблицу

Подскажите пожалуйста как это можно решить, голову уже с формулами сломал. Предпочтителен 1й вариант.

Автор - drago_782
Дата добавления - 03.07.2019 в 22:56
Nic70y Дата: Четверг, 04.07.2019, 08:17 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5683
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
нифига не понял %)
Код
=СУММ(ЕСЛИ(ЕЧИСЛО(ПОИСК($B10;C$4:C$8));--ПСТР(C$4:C$8;4;15)))
К сообщению приложен файл: 6938358.xls(34.5 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениенифига не понял %)
Код
=СУММ(ЕСЛИ(ЕЧИСЛО(ПОИСК($B10;C$4:C$8));--ПСТР(C$4:C$8;4;15)))

Автор - Nic70y
Дата добавления - 04.07.2019 в 08:17
drago_782 Дата: Четверг, 04.07.2019, 11:53 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Благодарю за вариант. Да, этот вариант работает с одним условием. А как поставить несколько условий? чтобы они отрабатывались
К сообщению приложен файл: 5481183.jpg(25.3 Kb)
 
Ответить
СообщениеБлагодарю за вариант. Да, этот вариант работает с одним условием. А как поставить несколько условий? чтобы они отрабатывались

Автор - drago_782
Дата добавления - 04.07.2019 в 11:53
Nic70y Дата: Четверг, 04.07.2019, 12:55 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5683
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
Код
=СУММ(--ЛЕВБ(0&ПОДСТАВИТЬ(ПСТР(C$4:C$8;ПОИСК($B10;C$4:C$8&$B10)+3;15);";";ПОВТОР(" ";15));15))


ЯД(poison) 41001841029809
 
Ответить
Сообщение
Код
=СУММ(--ЛЕВБ(0&ПОДСТАВИТЬ(ПСТР(C$4:C$8;ПОИСК($B10;C$4:C$8&$B10)+3;15);";";ПОВТОР(" ";15));15))

Автор - Nic70y
Дата добавления - 04.07.2019 в 12:55
drago_782 Дата: Четверг, 04.07.2019, 13:49 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Хм, вроде понял, вроде логично. прошёл по цепочке. Но не считает. Может у меня формат ячеек не тот.

Приложил
К сообщению приложен файл: 2336572.xls(38.0 Kb)
 
Ответить
СообщениеХм, вроде понял, вроде логично. прошёл по цепочке. Но не считает. Может у меня формат ячеек не тот.

Приложил

Автор - drago_782
Дата добавления - 04.07.2019 в 13:49
Nic70y Дата: Четверг, 04.07.2019, 14:07 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 5683
Репутация: 1246 ±
Замечаний: 0% ±

ru13;10;03
я думал, что Вы знаете, что это формула массива.
{формула массива вводится одновременным нажатием Ctrl Shift Enter}
К сообщению приложен файл: 7152481.xls(45.0 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениея думал, что Вы знаете, что это формула массива.
{формула массива вводится одновременным нажатием Ctrl Shift Enter}

Автор - Nic70y
Дата добавления - 04.07.2019 в 14:07
drago_782 Дата: Понедельник, 08.07.2019, 12:14 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Нет, незнал что есть такой вариант ввода.

Благодарю за помощь, очень помогли.
 
Ответить
СообщениеНет, незнал что есть такой вариант ввода.

Благодарю за помощь, очень помогли.

Автор - drago_782
Дата добавления - 08.07.2019 в 12:14
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Обработка данных, введённых вручную в одной ячейке (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!