Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическая сортировка по выбору категории товара. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Автоматическая сортировка по выбору категории товара. (Макросы/Sub)
Автоматическая сортировка по выбору категории товара.
Ярик Дата: Понедельник, 19.08.2019, 17:23 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 130
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Добрый день. Помогите решить задачу, есть таблица, в которую заносятся данные «лист1», на 2-м листе «лист2» с помощью выпадающего списка выбирается категория товара, формулами в столбце «название» подтягиваются все наименования из выбранной категории.
Помогите выполнить сортировку от А до Я. У меня не получается.
При выборе нужной категории сортировка товара должна выполнятся автоматически.
К сообщению приложен файл: 8376762.xlsb(15.6 Kb)


753123
 
Ответить
СообщениеДобрый день. Помогите решить задачу, есть таблица, в которую заносятся данные «лист1», на 2-м листе «лист2» с помощью выпадающего списка выбирается категория товара, формулами в столбце «название» подтягиваются все наименования из выбранной категории.
Помогите выполнить сортировку от А до Я. У меня не получается.
При выборе нужной категории сортировка товара должна выполнятся автоматически.

Автор - Ярик
Дата добавления - 19.08.2019 в 17:23
Pelena Дата: Вторник, 20.08.2019, 08:12 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14474
Репутация: 3172 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица1[Название];ПОИСКПОЗ(АГРЕГАТ(15;6;СЧЁТЕСЛИ(Таблица1[Название];"<="&Таблица1[Название])/(Таблица1[категория]=$E$2);СТРОКА(A1));СЧЁТЕСЛИ(Таблица1[Название];"<="&Таблица1[Название]);0));"")
К сообщению приложен файл: 0269437.xlsb(16.7 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица1[Название];ПОИСКПОЗ(АГРЕГАТ(15;6;СЧЁТЕСЛИ(Таблица1[Название];"<="&Таблица1[Название])/(Таблица1[категория]=$E$2);СТРОКА(A1));СЧЁТЕСЛИ(Таблица1[Название];"<="&Таблица1[Название]);0));"")

Автор - Pelena
Дата добавления - 20.08.2019 в 08:12
Ярик Дата: Вторник, 20.08.2019, 08:39 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 130
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Pelena, огромное Вам спасибо. Я думал такое можно только макросом сделать. Поэтому в этом разделе создал тему.
Спасибо еще раз.


753123
 
Ответить
СообщениеPelena, огромное Вам спасибо. Я думал такое можно только макросом сделать. Поэтому в этом разделе создал тему.
Спасибо еще раз.

Автор - Ярик
Дата добавления - 20.08.2019 в 08:39
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Автоматическая сортировка по выбору категории товара. (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!