Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/не получается разобраться с примером из книги Эйткена - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » не получается разобраться с примером из книги Эйткена (Макросы/Sub)
не получается разобраться с примером из книги Эйткена
Davka Дата: Суббота, 24.08.2019, 22:13 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте.
Решил изучить подробнее Excel и VBA, начал читать книгу Эйткена "Интенсивный курс программирования в Excel за выходные". Дошел до первого примера и сразу же не получилось)
Строки кода один в один с книги:
[vba]
Код
#Public Sub программа()
Range("B2").Select
ActiveCell.Value = InputBox("введите значение")
Range("B3").Select
ActiveCell.Value = InputBox("введите значение")
Range("B4").Select
ActiveCell.Value = InputBox("введите значение")
Range("B5").Select
ActiveCell.Value = InputBox("введите значение")
Range("B6").Select
ActiveCell.Value = InputBox("введите значение")
Range("B7").Select
ActiveCell.Formula = "=СУММ(B2:B6)"
ActiveWorkbook.SaveAs Filename:="программа.xls"
End Sub#
[/vba]

При запуске вначале все идет как и должно, просит ввести значение, и так 5 раз, записывает в ячейки В2 - В6
При вводе последнего значения В6, в ячейке В7 должна появиться сумма, но вместо нее выходит #ИМЯ?, но в строке функции формула указана верно: =СУММ(B2:B6)
Если мышкой нажать на формулу в строке функции ячейки В7, то пото формула срабатывает и выводится сумма.
В чем ошибка? Думаю не в коде, а в самом Excel, может я не в том формате сохраняю? хотя пробовал разные.
Может кто подскажет, буду благодарен. Еще прикреплю файл, если у себя откроете, и у вас все работает, дайте знать, значит и правда проблема в самом Excel
К сообщению приложен файл: 5775665.xlsm(13.5 Kb)


Сообщение отредактировал Davka - Воскресенье, 25.08.2019, 08:01
 
Ответить
СообщениеЗдравствуйте.
Решил изучить подробнее Excel и VBA, начал читать книгу Эйткена "Интенсивный курс программирования в Excel за выходные". Дошел до первого примера и сразу же не получилось)
Строки кода один в один с книги:
[vba]
Код
#Public Sub программа()
Range("B2").Select
ActiveCell.Value = InputBox("введите значение")
Range("B3").Select
ActiveCell.Value = InputBox("введите значение")
Range("B4").Select
ActiveCell.Value = InputBox("введите значение")
Range("B5").Select
ActiveCell.Value = InputBox("введите значение")
Range("B6").Select
ActiveCell.Value = InputBox("введите значение")
Range("B7").Select
ActiveCell.Formula = "=СУММ(B2:B6)"
ActiveWorkbook.SaveAs Filename:="программа.xls"
End Sub#
[/vba]

При запуске вначале все идет как и должно, просит ввести значение, и так 5 раз, записывает в ячейки В2 - В6
При вводе последнего значения В6, в ячейке В7 должна появиться сумма, но вместо нее выходит #ИМЯ?, но в строке функции формула указана верно: =СУММ(B2:B6)
Если мышкой нажать на формулу в строке функции ячейки В7, то пото формула срабатывает и выводится сумма.
В чем ошибка? Думаю не в коде, а в самом Excel, может я не в том формате сохраняю? хотя пробовал разные.
Может кто подскажет, буду благодарен. Еще прикреплю файл, если у себя откроете, и у вас все работает, дайте знать, значит и правда проблема в самом Excel

Автор - Davka
Дата добавления - 24.08.2019 в 22:13
Pelena Дата: Суббота, 24.08.2019, 23:41 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14473
Репутация: 3172 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Davka, оформите код тегами с помощью кнопки # в режиме правки поста


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеDavka, оформите код тегами с помощью кнопки # в режиме правки поста

Автор - Pelena
Дата добавления - 24.08.2019 в 23:41
Kuzmich Дата: Воскресенье, 25.08.2019, 23:07 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 393
Репутация: 76 ±
Замечаний: 0% ±

Excel 2003
Помогающим просьба воздержаться от ответов в этой теме до исправления замечания
Ответ удален.ТС еще не исправил замечание модератора


Сообщение отредактировал китин - Понедельник, 26.08.2019, 07:27
 
Ответить
СообщениеПомогающим просьба воздержаться от ответов в этой теме до исправления замечания
Ответ удален.ТС еще не исправил замечание модератора

Автор - Kuzmich
Дата добавления - 25.08.2019 в 23:07
Davka Дата: Вторник, 27.08.2019, 22:54 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте.
Решил изучить подробнее Excel и VBA, начал читать книгу Эйткена "Интенсивный курс программирования в Excel за выходные". Дошел до первого примера и сразу же не получилось)
Строки кода один в один с книги:
[vba]
Код
Public Sub программа()
Range("B2").Select
ActiveCell.Value = InputBox("введите значение")
Range("B3").Select
ActiveCell.Value = InputBox("введите значение")
Range("B4").Select
ActiveCell.Value = InputBox("введите значение")
Range("B5").Select
ActiveCell.Value = InputBox("введите значение")
Range("B6").Select
ActiveCell.Value = InputBox("введите значение")
Range("B7").Select
ActiveCell.Formula = "=СУММ(B2:B6)"
ActiveWorkbook.SaveAs Filename:="программа.xls"
End Sub
[/vba]

При запуске вначале все идет как и должно, просит ввести значение, и так 5 раз, записывает в ячейки В2 - В6
При вводе последнего значения В6, в ячейке В7 должна появиться сумма, но вместо нее выходит #ИМЯ?, но в строке функции формула указана верно: =СУММ(B2:B6)
Если мышкой нажать на формулу в строке функции ячейки В7, то пото формула срабатывает и выводится сумма.
В чем ошибка? Думаю не в коде, а в самом Excel, может я не в том формате сохраняю? хотя пробовал разные.
Может кто подскажет, буду благодарен. Еще прикреплю файл, если у себя откроете, и у вас все работает, дайте знать, значит и правда проблема в самом Excel
 
Ответить
СообщениеЗдравствуйте.
Решил изучить подробнее Excel и VBA, начал читать книгу Эйткена "Интенсивный курс программирования в Excel за выходные". Дошел до первого примера и сразу же не получилось)
Строки кода один в один с книги:
[vba]
Код
Public Sub программа()
Range("B2").Select
ActiveCell.Value = InputBox("введите значение")
Range("B3").Select
ActiveCell.Value = InputBox("введите значение")
Range("B4").Select
ActiveCell.Value = InputBox("введите значение")
Range("B5").Select
ActiveCell.Value = InputBox("введите значение")
Range("B6").Select
ActiveCell.Value = InputBox("введите значение")
Range("B7").Select
ActiveCell.Formula = "=СУММ(B2:B6)"
ActiveWorkbook.SaveAs Filename:="программа.xls"
End Sub
[/vba]

При запуске вначале все идет как и должно, просит ввести значение, и так 5 раз, записывает в ячейки В2 - В6
При вводе последнего значения В6, в ячейке В7 должна появиться сумма, но вместо нее выходит #ИМЯ?, но в строке функции формула указана верно: =СУММ(B2:B6)
Если мышкой нажать на формулу в строке функции ячейки В7, то пото формула срабатывает и выводится сумма.
В чем ошибка? Думаю не в коде, а в самом Excel, может я не в том формате сохраняю? хотя пробовал разные.
Может кто подскажет, буду благодарен. Еще прикреплю файл, если у себя откроете, и у вас все работает, дайте знать, значит и правда проблема в самом Excel

Автор - Davka
Дата добавления - 27.08.2019 в 22:54
Kuzmich Дата: Вторник, 27.08.2019, 23:36 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 393
Репутация: 76 ±
Замечаний: 0% ±

Excel 2003
[vba]
Код
ActiveCell.Formula = "=Sum(B2:B6)"
[/vba]
 
Ответить
Сообщение[vba]
Код
ActiveCell.Formula = "=Sum(B2:B6)"
[/vba]

Автор - Kuzmich
Дата добавления - 27.08.2019 в 23:36
Davka Дата: Вторник, 27.08.2019, 23:45 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Kuzmich, спасибо, заработало!
интересно, почему русское СУММ не срабатывает?
 
Ответить
СообщениеKuzmich, спасибо, заработало!
интересно, почему русское СУММ не срабатывает?

Автор - Davka
Дата добавления - 27.08.2019 в 23:45
китин Дата: Среда, 28.08.2019, 07:34 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 5828
Репутация: 907 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
русское СУММ не срабатывает?

[vba]
Код
ActiveCell.FormulaLocal = "=СУММ(B2:B6)"
[/vba]


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
русское СУММ не срабатывает?

[vba]
Код
ActiveCell.FormulaLocal = "=СУММ(B2:B6)"
[/vba]

Автор - китин
Дата добавления - 28.08.2019 в 07:34
Davka Дата: Среда, 28.08.2019, 14:13 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо
 
Ответить
СообщениеСпасибо

Автор - Davka
Дата добавления - 28.08.2019 в 14:13
Мир MS Excel » Вопросы и решения » Вопросы по VBA » не получается разобраться с примером из книги Эйткена (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!