Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Скопировать из ячейки, если соседняя ячейка пустая - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Скопировать из ячейки, если соседняя ячейка пустая (Макросы/Sub)
Скопировать из ячейки, если соседняя ячейка пустая
Yar4i Дата: Пятница, 13.09.2019, 09:44 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 110
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброе утро, дамы и господа :D

Из A6 нужно скопировать в F6 - эти позиции неизменны и фиксированы.
И далее (ниже) в столбце A нужно найти текст, который расположен напротив пустой ячейки столбца C (также как и D и E), далее этот текст нужно скопировать в ту же строку в ячейку столбца F.
Пример:
A15 копируется на F15, т.к. C15 пустая
К сообщению приложен файл: 1309.xls(62.5 Kb)


Сообщение отредактировал Yar4i - Пятница, 13.09.2019, 10:50
 
Ответить
СообщениеДоброе утро, дамы и господа :D

Из A6 нужно скопировать в F6 - эти позиции неизменны и фиксированы.
И далее (ниже) в столбце A нужно найти текст, который расположен напротив пустой ячейки столбца C (также как и D и E), далее этот текст нужно скопировать в ту же строку в ячейку столбца F.
Пример:
A15 копируется на F15, т.к. C15 пустая

Автор - Yar4i
Дата добавления - 13.09.2019 в 09:44
K-SerJC Дата: Пятница, 13.09.2019, 12:09 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 469
Репутация: 83 ±
Замечаний: 0% ±

Excel 2013
A15 копируется на F15, т.к. C15 пустая

Доброго дня!
а формулой не вариант?
Код
=ЕСЛИ(C6="";A6;"")


Благими намерениями выстелена дорога в АД.
 
Ответить
Сообщение
A15 копируется на F15, т.к. C15 пустая

Доброго дня!
а формулой не вариант?
Код
=ЕСЛИ(C6="";A6;"")

Автор - K-SerJC
Дата добавления - 13.09.2019 в 12:09
Yar4i Дата: Пятница, 13.09.2019, 12:32 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 110
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
а формулой

Спасибо. В голове именно формула и крутилась (если А пусто, то Б=...) супер.
 
Ответить
Сообщение
а формулой

Спасибо. В голове именно формула и крутилась (если А пусто, то Б=...) супер.

Автор - Yar4i
Дата добавления - 13.09.2019 в 12:32
Yar4i Дата: Пятница, 13.09.2019, 15:18 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 110
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
а формулой

попробовал далее выделить пустые ячейки через f5, однако в них сидит формула. Копирую и вставляю как 123, однако не видит, что они пустые.
****
F7 и F8 - по мнению Эксель не пустые
К сообщению приложен файл: 12345.xls(34.0 Kb)


Сообщение отредактировал Yar4i - Пятница, 13.09.2019, 16:06
 
Ответить
Сообщение
а формулой

попробовал далее выделить пустые ячейки через f5, однако в них сидит формула. Копирую и вставляю как 123, однако не видит, что они пустые.
****
F7 и F8 - по мнению Эксель не пустые

Автор - Yar4i
Дата добавления - 13.09.2019 в 15:18
Yar4i Дата: Пятница, 13.09.2019, 16:10 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 110
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
А в VBA можно как-либо решить данную беду?

из припасов нашел лишь:
[vba]
Код

Range("L17").Select
  '   ActiveCell.FormulaR1C1 = "=ÅÑËÈ(ÅÏÓÑÒÎ(I20);"ÍÅÒ ÑÒÎÈÌÎÑÒÍÛÕ ÌÀÒÅÐÈÀËÎÂ!";"")"
' ActiveCell.FormulaR1C1 = "=IF(ISBLANK(R[-93]C[-64]),""ÍÅÒ ÑÒÎÈÌÎÑÒÍÛÕ ÌÀÒÅÐÈÀËÎÂ!"","""")"
  ActiveCell.FormulaLocal = "=ÅÑËÈ(ÅÏÓÑÒÎ(I20);""ÍÅÒ ÑÒÎÈÌÎÑÒÍÛÕ ÌÀÒÅÐÈÀËÎÂ!"";"""")"
        With Selection.Font
        .Color = -16776961
        .TintAndShade = 0
    End With
    ' Èòîãî â òåêóùèõ öåíàõ
    Range("I13").Select
     ActiveCell.FormulaR1C1 = "Èòîãî â òåê. öåíàõ ="
     With Selection.Font
        .Color = -7829368
        .TintAndShade = 0
    End With
[/vba]
 
Ответить
СообщениеА в VBA можно как-либо решить данную беду?

из припасов нашел лишь:
[vba]
Код

Range("L17").Select
  '   ActiveCell.FormulaR1C1 = "=ÅÑËÈ(ÅÏÓÑÒÎ(I20);"ÍÅÒ ÑÒÎÈÌÎÑÒÍÛÕ ÌÀÒÅÐÈÀËÎÂ!";"")"
' ActiveCell.FormulaR1C1 = "=IF(ISBLANK(R[-93]C[-64]),""ÍÅÒ ÑÒÎÈÌÎÑÒÍÛÕ ÌÀÒÅÐÈÀËÎÂ!"","""")"
  ActiveCell.FormulaLocal = "=ÅÑËÈ(ÅÏÓÑÒÎ(I20);""ÍÅÒ ÑÒÎÈÌÎÑÒÍÛÕ ÌÀÒÅÐÈÀËÎÂ!"";"""")"
        With Selection.Font
        .Color = -16776961
        .TintAndShade = 0
    End With
    ' Èòîãî â òåêóùèõ öåíàõ
    Range("I13").Select
     ActiveCell.FormulaR1C1 = "Èòîãî â òåê. öåíàõ ="
     With Selection.Font
        .Color = -7829368
        .TintAndShade = 0
    End With
[/vba]

Автор - Yar4i
Дата добавления - 13.09.2019 в 16:10
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Скопировать из ячейки, если соседняя ячейка пустая (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!