Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка данных из другой книги - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Выборка данных из другой книги (Макросы/Sub)
Выборка данных из другой книги
tih66 Дата: Понедельник, 16.09.2019, 15:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем доброго дня!
Имеются 2 файла, в первом Прайс лист поставщика, во втором таблица из 3 столбцов (первый столбец с внутренними артикулами товара, второй столбец артикулы поставщика, третий столбец цена). Необходимо сделать сопоставление данных, а именно если в табличке совпадает артикул поставщика из файла прайс лист, то подставить цену товара в таблицу из прайс листа.
К сообщению приложен файл: 5045243.xls(26.5 Kb) · 9166884.xlsx(8.0 Kb)
 
Ответить
СообщениеВсем доброго дня!
Имеются 2 файла, в первом Прайс лист поставщика, во втором таблица из 3 столбцов (первый столбец с внутренними артикулами товара, второй столбец артикулы поставщика, третий столбец цена). Необходимо сделать сопоставление данных, а именно если в табличке совпадает артикул поставщика из файла прайс лист, то подставить цену товара в таблицу из прайс листа.

Автор - tih66
Дата добавления - 16.09.2019 в 15:20
krosav4ig Дата: Понедельник, 16.09.2019, 17:11 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2182
Репутация: 913 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Добрый день
Код
=ВПР(B2;'D:\TMP\[5045243.xls]TDSheet'!$B$9:$G$9999;6;)

у себя в формуле поменяйте путь к файлу и его имя


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
СообщениеДобрый день
Код
=ВПР(B2;'D:\TMP\[5045243.xls]TDSheet'!$B$9:$G$9999;6;)

у себя в формуле поменяйте путь к файлу и его имя

Автор - krosav4ig
Дата добавления - 16.09.2019 в 17:11
tih66 Дата: Вторник, 17.09.2019, 11:15 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Все работает! Спасибо!
P/s/ рано радовался. Если такого значения нет (артикула поставщика в табличке, нет в прайс листе), то берется ближайший результат. Как такое исключить? Спасибо.


Сообщение отредактировал tih66 - Вторник, 17.09.2019, 11:38
 
Ответить
СообщениеВсе работает! Спасибо!
P/s/ рано радовался. Если такого значения нет (артикула поставщика в табличке, нет в прайс листе), то берется ближайший результат. Как такое исключить? Спасибо.

Автор - tih66
Дата добавления - 17.09.2019 в 11:15
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Выборка данных из другой книги (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!