Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вставка формулы в зависимости от условия - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Вставка формулы в зависимости от условия (Макросы/Sub)
Вставка формулы в зависимости от условия
tvyur Дата: Понедельник, 11.05.2020, 10:24 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 53
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброе утро. Прошу вашей помощи в реализации следующей задачи, и ответа на вопрос - возможно ли её вообще реализовать. Прошу прощения если сумбурно получится.
помогите, пожалуйста с помощью макроса сделать так, чтобы во все ячейки, окрашенные в жёлтый цвет в таблице проставлялось время в формате 0:00 если в ячейки, окрашенные синим цветом будет вводится "ОТ" (отпуск) , а если в эти же ячейки (синего цвета) всей таблицы будет проставляться время от 0:00 до 24:00, то в ячейках, окрашенных жёлтым цветом должна срабатывать формула. Подробно попыталась описать в самом файле. Его прикладываю.
К сообщению приложен файл: 4150728.xlsm(136.9 Kb)


tvyur
 
Ответить
СообщениеДоброе утро. Прошу вашей помощи в реализации следующей задачи, и ответа на вопрос - возможно ли её вообще реализовать. Прошу прощения если сумбурно получится.
помогите, пожалуйста с помощью макроса сделать так, чтобы во все ячейки, окрашенные в жёлтый цвет в таблице проставлялось время в формате 0:00 если в ячейки, окрашенные синим цветом будет вводится "ОТ" (отпуск) , а если в эти же ячейки (синего цвета) всей таблицы будет проставляться время от 0:00 до 24:00, то в ячейках, окрашенных жёлтым цветом должна срабатывать формула. Подробно попыталась описать в самом файле. Его прикладываю.

Автор - tvyur
Дата добавления - 11.05.2020 в 10:24
RAN Дата: Понедельник, 11.05.2020, 10:59 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5296
Репутация: 1061 ±
Замечаний: 0% ±

2010
А без макроса нельзя?
Код
=ЕСЛИОШИБКА(AC28-AC27-AC29;0)


Быть или не быть, вот в чем загвоздка!
 
Ответить
СообщениеА без макроса нельзя?
Код
=ЕСЛИОШИБКА(AC28-AC27-AC29;0)

Автор - RAN
Дата добавления - 11.05.2020 в 10:59
tvyur Дата: Понедельник, 11.05.2020, 13:24 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 53
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
RAN, СПАСИБО ЗА ПОДСКАЗКУ. hands


tvyur

Сообщение отредактировал tvyur - Понедельник, 11.05.2020, 14:48
 
Ответить
СообщениеRAN, СПАСИБО ЗА ПОДСКАЗКУ. hands

Автор - tvyur
Дата добавления - 11.05.2020 в 13:24
tvyur Дата: Понедельник, 11.05.2020, 18:47 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 53
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Вот только формула при подсчёте времени работает не совсем корректно. Файл прикладываю Как исправить?
К сообщению приложен файл: 0862119.xlsm(52.6 Kb)


tvyur
 
Ответить
СообщениеВот только формула при подсчёте времени работает не совсем корректно. Файл прикладываю Как исправить?

Автор - tvyur
Дата добавления - 11.05.2020 в 18:47
Pelena Дата: Понедельник, 11.05.2020, 19:06 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 15745
Репутация: 3430 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Так подойдёт?
Код
=ОСТАТ(AC23-AC22;1)
К сообщению приложен файл: 3476097.xlsm(53.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТак подойдёт?
Код
=ОСТАТ(AC23-AC22;1)

Автор - Pelena
Дата добавления - 11.05.2020 в 19:06
RAN Дата: Понедельник, 11.05.2020, 19:13 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5296
Репутация: 1061 ±
Замечаний: 0% ±

2010
работает не совсем корректно.

Цитата
Жизнь невозможно повернуть назад, И время ни на миг не остановишь

С 17 до 24, это вперед. А вот с 17 до 0???


Быть или не быть, вот в чем загвоздка!
 
Ответить
Сообщение
работает не совсем корректно.

Цитата
Жизнь невозможно повернуть назад, И время ни на миг не остановишь

С 17 до 24, это вперед. А вот с 17 до 0???

Автор - RAN
Дата добавления - 11.05.2020 в 19:13
tvyur Дата: Понедельник, 11.05.2020, 19:26 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 53
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
RAN, спасибо, исправила.


tvyur
 
Ответить
СообщениеRAN, спасибо, исправила.

Автор - tvyur
Дата добавления - 11.05.2020 в 19:26
Мир MS Excel » Вопросы и решения » Вопросы по VBA » Вставка формулы в зависимости от условия (Макросы/Sub)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!